Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Показать сообщение отдельно
nasta22
0 / 0 / 0
Регистрация: 09.06.2015
Сообщений: 10
0

Ошибка в процедуре: не считается сумма

10.10.2015, 11:35. Просмотров 597. Ответов 6
Метки (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена; 
КонецПроцедуры
 
 
 
Процедура ДокументСписокКоличествоПриИзменении(Элемент)
     СтрокаТабличнойЧасти = Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
Процедура ДокументСписокЦенаПриИзменении(Элемент)
       СтрокаТабличнойЧасти = Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
выдает ошибку программы
 
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена; 
КонецПроцедуры
 
 
 
Процедура ДокументСписокКоличествоПриИзменении(Элемент)
     СтрокаТабличнойЧасти = <?>Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
Процедура ДокументСписокЦенаПриИзменении(Элемент)
       СтрокаТабличнойЧасти = <?>Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
Добавлено через 6 минут
{Документ.Прибыль.Форма.ФормаВыбора(9,28)}: Переменная не определена (Элементы)
СтрокаТабличнойЧасти = <<?>>Элементы.Документ.ТекущиеДанные;
{Документ.Прибыль.Форма.ФормаВыбора(4,5)}: Переменная не определена (РаботаСДокументами)
<<?>>РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
{Документ.Прибыль.Форма.ФормаВыбора(10,5)}: Переменная не определена (РаботаСДокументами)
<<?>>РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);

Вернуться к обсуждению:
Ошибка в процедуре: не считается сумма
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.10.2015, 11:35
Готовые ответы и решения:

Сумма в документах не считается
Помогите решить проблему! ТиС 7.7. После объединения одной конфигурации с...

С клавиатуры вводится строка, в ней и+1 меняется с и-1 элементом, считается количество таких перестановок, после этого считается сумма всех четных си
Дорогие форумчане, вы не раз мне помогали в решении проблем, но сегодня...

Не считается сумма товара
есть программа которая принимает тип товара и проданное количество этого...

Не считается сумма бесконечного ряда
Сделал програму но она не хочет считать суму ряду...никак не могу найти где я...

Не считается сумма в форме access
Приветствую всех. Есть такая проблема: Существует ленточная форма с набором...

6
Другие темы раздела
1С Техническое задание Домоуправление http://www.cyberforum.ru/1c-custom/thread1548474.html
Всем привет. Посоветуйте как написать техническое задание на тему "Разработка на платформе 1С: Предприятие 8.3 модуля «Домоуправление»". Думаю что то сделать на тему жкх. Но ничего в голову не...
1С Бизнес процесс не работает как надо есть БП в нем точка старта, потом точка разделения на две ветки создаются две задачи. потом они сливаются и конец. таки вот. после выполнения первой задачи переходим к концу. после выполнения... http://www.cyberforum.ru/1c-custom/thread1547915.html
1С Учебник 1С
помогите вспомогательной литературой: функции, операторы, всякая хрень которая точно пригодятся при программировании 1с. Задачи разные, примеры. Спасибо всем кто поможет
1С Работа с регистром
Встала такая задача при каждом изменении реквизита Статус и сохранении документа нужно создавать новый Регистр сведений. Вот я сделал процедуру Процедура СтатусПриИзменении(Элемент) Движение =...
1С Ошибка: Поле объекта не обнаружено http://www.cyberforum.ru/1c-custom/thread1547218.html
Ругается на параметр макета,типа его нет... хотя в отладчике в параметрах области его видно!! Уже и макет новый сделал, и наименование параметра менял - ничего не получаается! макет =...
1С Работа с макетом Подскажите как можно с макета перейти сразу в Справочник.ЛицевыеСчетаАбонентов Вот код макета Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка) ТабДок = Новый... подробнее
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru