Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Заполнение поля http://www.cyberforum.ru/1c-custom/thread1686576.html
Имеется форма для заполнения реквизитов документа. Как сделать так, чтобы: При заполнении Поля ФИО заполнялось поле Должность, которое привязано в справочнике Сотрудники? Т.е. 1) Петров Петр...
1С К кому можно обратитьс за допиской базы? Здравствуйте, подскажите, к кому можно обратиться за небольшой допиской базы 1с УПП 8.3 обычное приложение http://www.cyberforum.ru/1c-custom/thread1686464.html
Как передать значение параметра? 1С
Всем привет.. Как передать значение реквизита документа в справочник? Процедура ОбработкаПроведения(Отказ, РежимПроведения) СпрСотр = Справочники.Сотрудники.СоздатьЭлемент();...
Неверные параметры в операции сравнения 1С
Подскажите почему вылезает ошибка {Форма.Форма.Форма(101)}: Ошибка при вызове метода контекста (Выполнить) Результат = Запрос.Выполнить().Выбрать(); по причине: {(20, 33)}: Неверные параметры в...
1С Есть ДанныеФормыКоллекция "прилетевшая" из другой формы.что с ней делать? http://www.cyberforum.ru/1c-custom/thread1685692.html
открываю форму, в параметры её открытия передаю "данныеФормыКоллекция" другой формы. как определить структуру этой данные формы коллекция чтобы с открываемой форме создать аналогичную? имя этой...
1С СКД в пользовательском режиме всем привет. карочи есть задача. сформировать отчет полностью произвольно. ну т.е. сформировать СКД, перекинуть в нее таблицу( специально подготовленную) и отобразить на форме отчета... подробнее
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
17.03.2016, 10:47 0

Как на мобильном клиенте проверить корректность введенного адреса эл. почты?

17.03.2016, 10:47. Просмотров 464. Ответов 9
Метки (Все метки)

Ответ

Volexovich, нет. В синтакс-помощнике смотри "Почта".

Вот кусок из типовой (УТ 11)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
Функция АдресЭлектроннойПочтыСоответствуетТребованиям(Знач Адрес, РазрешитьЛокальныеАдреса = Ложь) Экспорт
    
    // Допустимые символы для email.
    Буквы = "abcdefghijklmnopqrstuvwxyzабвгдеёжзийклмнопрстуфхцчшщъыьэюя";
    Цифры = "0123456789";
    СпецСимволы = ".@_-";
    
    // Проверяем любые сочетания спецсимволов.
    Если СтрДлина(СпецСимволы) > 1 Тогда
        Для Позиция1 = 1 По СтрДлина(СпецСимволы)-1 Цикл
            Символ1 = Сред(СпецСимволы, Позиция1, 1);
            Для Позиция2 = Позиция1 + 1 По СтрДлина(СпецСимволы) Цикл
                Символ2 = Сред(СпецСимволы, Позиция2, 1);
                Комбинация1 = Символ1 + Символ2;
                Комбинация2 = Символ2 + Символ1;
                Если Найти(Адрес, Комбинация1) > 0 Или Найти(Адрес, Комбинация2) > 0 Тогда
                    Возврат Ложь;
                КонецЕсли;
            КонецЦикла;
        КонецЦикла;
    КонецЕсли;
    
    // проверяем символ @
    Если СтрЧислоВхождений(Адрес, "@") <> 1 Тогда
        Возврат Ложь;
    КонецЕсли;
       
    // проверяем две точки подряд
    Если Найти(Адрес, "..") > 0 Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // Приводим строку адреса к нижнему регистру.
    Адрес = НРег(Адрес);
    
    // Проверяем допустимые символы.
    Если Не СтрокаСодержитТолькоДопустимыеСимволы(Адрес, Буквы + Цифры + СпецСимволы) Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // Разбираем адрес на local-part и domain.
    Позиция = Найти(Адрес,"@");
    ЛокальноеИмя = Лев(Адрес, Позиция - 1);
    Домен = Сред(Адрес, Позиция + 1);
    
    // Проверяем на заполненность и допустимость длины.
    Если ПустаяСтрока(ЛокальноеИмя)
        Или ПустаяСтрока(Домен)
        Или СтрДлина(ЛокальноеИмя) > 64
        Или СтрДлина(Домен) > 255 Тогда
        
        Возврат Ложь;
    КонецЕсли;
    
    // Проверяем наличие спецсимволов в начале и в конце частей адреса.
    Если ЕстьСимволыВНачалеВКонце(ЛокальноеИмя, СпецСимволы) Или ЕстьСимволыВНачалеВКонце(Домен, СпецСимволы) Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // В домене должна быть минимум одна точка.
    Если Не РазрешитьЛокальныеАдреса И Найти(Домен,".") = 0 Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // В домене не должно быть символа подчеркивания.
    Если Найти(Домен,"_") > 0 Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // Выделяем зону (TLD) из имени домена.
    Зона = Домен;
    Позиция = Найти(Зона,".");
    Пока Позиция > 0 Цикл
        Зона = Сред(Зона, Позиция + 1);
        Позиция = Найти(Зона,".");
    КонецЦикла;
    
    // Проверяем зону домена (минимум 2 символа, только буквы).
    Возврат РазрешитьЛокальныеАдреса Или СтрДлина(Зона) >= 2 И СтрокаСодержитТолькоДопустимыеСимволы(Зона,Буквы);
    
КонецФункции


Вернуться к обсуждению:
Как на мобильном клиенте проверить корректность введенного адреса эл. почты?
1
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.03.2016, 10:47
Готовые ответы и решения:

Проверка на корректность введенного e-mail адреса
Доброго времени суток! Написал программу связанную из http-запросов, но не могу написать проверку...

Проверка введенного url адреса на корректность
Здравствуйте, требуется ваша помощь не могли бы подсказать как организовать проверку введенного...

Как проверить работоспособность адреса электронной почты?
подскажите, как проверить работоспособность адреса эл.почты, не отправляя на него письма. возможно...

Нужно проверить на корректность ввода E-mail адреса
Допустим пользователь вводит _____@___.___ Как мы можем проверить эти три ↑ ..... ↑.... ...

Разработать программу, которая вводит адрес электронной почты и проверяет синтаксис введенного адреса
В имени пользователя могут быть только следующие символы: буквы латинского алфавита, цифры, дефис...

9
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru