Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С План закупок http://www.cyberforum.ru/1c-custom/thread1698424.html
Есть документ "заявка на закупку", скажите пожалуйста, как сделать план закупок, чтобы отобразить товары из заявок?
1С Ввод на основании Здравствуйте, есть два документа: «ПринятиеКУчету», который создается на основе «ПриходнаяНакладная». В Приходной накладной указывается кол-во техники, а в документе Принятие к учету задается техники... http://www.cyberforum.ru/1c-custom/thread1698051.html
1С Обратиться к ячейке табличной части
Здравствуйте! Такая проблема.... В табличную часть обработки выбирается абонент из справочника, и автоматически подгружается лицевой счет. Далее нужно, чтобы по этому лицевому счету программа через...
1С В отчете вывести заказ-наряды за период, которые не утверждены клиентом
Всем доброго времени суток. В отчете нужно вывести заказ-наряды за период, которые не утверждены клиентом и не прошли осмотр места, и статус которых "производство завершено". Проблема с условием,...
1С 1C 8 УПП обычные формы отразить табличное поле без привязки к данным http://www.cyberforum.ru/1c-custom/thread1697611.html
1C 8 УПП обычные формы отразить табличное поле без привязки к данным. Надо просто просмотреть результаты запроса (он создается при изменении строки ТП Документа ) в отдельной таблице без создания...
1С Решение задачки Встретил на просторах интернета такую задачку: Ради интереса захотел её решить на 1ске. Предлагаю такое решение: Процедура ПриНачалеРаботыСистемы() Перем Помидор; Перем Виноград;... подробнее
vino0s
9 / 9 / 8
Регистрация: 26.03.2014
Сообщений: 353
30.03.2016, 22:24  [ТС] 0

Загрузка и выгрузка табличной части документа в Excel

30.03.2016, 22:24. Просмотров 4372. Ответов 57
Метки (Все метки)

Ответ

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
&НаКлиенте
Процедура Команда1(Команда)
    // Вставить содержимое обработчика.
    Сохранить();
КонецПроцедуры
 
&НаСервере
Процедура Сохранить()  
    ApplicationExcel= Новый COMОбъект("Excel.Application");  
    ApplicationExcel.Visible = Истина;  
    ApplicationExcel.Workbooks.Open ("E:\1C\Клиенты.xlsx");
    ТЧ=Объект.ПереченьТоваров;
    i=4;  
    
    КоличествоСтрок = ТЧ.Количество();
    Если КоличествоСтрок <> 0 Тогда
    Для каждого Строчка из ТЧ Цикл
        ApplicationExcel.Sheets(1).Cells(i, 10).Value = Строчка.Цена;
        ApplicationExcel.Sheets(1).Cells(i, 9).Value = Строчка.Количество;
        ApplicationExcel.Sheets(1).Cells(i, 11).Value = Строчка.Сумма;
ApplicationExcel.Sheets(1).Cells(i, 1).Value = Строка(Строчка.Товар);
        i=i+1;
    КонецЦикла
    КонецЕсли;
    ApplicationExcel.Application.Quit();    
КонецПроцедуры
Добавлено через 2 минуты
Отблагодарил, обозначил "лучший" всем спасибо)
Остался вопрос не из темы, проверить на пустое значение в 1с, есть способы?

Добавлено через 26 секунд
Цитата Сообщение от GreenkO Посмотреть сообщение
ЗначениеЗаполнено(Значение).
Попробую

Вернуться к обсуждению:
Загрузка и выгрузка табличной части документа в Excel
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.03.2016, 22:24

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник &quot;Сотрудники&quot; и подчиненный ему...

Выгрузка табличной части в таблицу значений
Ситуация такая,в документе имеется табличная часть Подписки (см. скрин), в ней есть колонка...

Ошибка в табличной части документа
Приветствую Вас многоуважаемые форумчане:drink: После долгого отсутствия мне наконец-то дали...

0
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru