Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С План закупок http://www.cyberforum.ru/1c-custom/thread1698424.html
Есть документ "заявка на закупку", скажите пожалуйста, как сделать план закупок, чтобы отобразить товары из заявок?
1С Ввод на основании Здравствуйте, есть два документа: «ПринятиеКУчету», который создается на основе «ПриходнаяНакладная». В Приходной накладной указывается кол-во техники, а в документе Принятие к учету задается техники... http://www.cyberforum.ru/1c-custom/thread1698051.html
1С Обратиться к ячейке табличной части
Здравствуйте! Такая проблема.... В табличную часть обработки выбирается абонент из справочника, и автоматически подгружается лицевой счет. Далее нужно, чтобы по этому лицевому счету программа через...
1С В отчете вывести заказ-наряды за период, которые не утверждены клиентом
Всем доброго времени суток. В отчете нужно вывести заказ-наряды за период, которые не утверждены клиентом и не прошли осмотр места, и статус которых "производство завершено". Проблема с условием,...
1С 1C 8 УПП обычные формы отразить табличное поле без привязки к данным http://www.cyberforum.ru/1c-custom/thread1697611.html
1C 8 УПП обычные формы отразить табличное поле без привязки к данным. Надо просто просмотреть результаты запроса (он создается при изменении строки ТП Документа ) в отдельной таблице без создания...
1С Решение задачки Встретил на просторах интернета такую задачку: Ради интереса захотел её решить на 1ске. Предлагаю такое решение: Процедура ПриНачалеРаботыСистемы() Перем Помидор; Перем Виноград;... подробнее
vino0s
9 / 9 / 8
Регистрация: 26.03.2014
Сообщений: 353
30.03.2016, 22:49  [ТС] 0

Загрузка и выгрузка табличной части документа в Excel

30.03.2016, 22:49. Просмотров 4374. Ответов 57
Метки (Все метки)

Ответ

Цитата Сообщение от GreenkO Посмотреть сообщение
посмотрите проверку на ПоследнююСтроку, ПоследнийСтолбец
Это у меня есть, спасибо. Просто интересно как проверить на пустое или тут нельзя?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
&НаКлиенте
Процедура Команда2(Команда)
    
    ДиалогФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогФайла.Фильтр = "Наш файл (*.xls, *.xlsx, *.csv)|*.xls; *.xlsx; *.csv";
    ДиалогФайла.МножественныйВыбор = Ложь;
    
    ОП = Новый ОписаниеОповещения("Загрузить", ЭтаФорма, Новый Структура);
    
    ДиалогФайла.Показать(ОП);
    
КонецПроцедуры
 
&НаКлиенте
Процедура Загрузить(РезультатВыбора, СтруктураДополнительныхПараметров) Экспорт
    
    Если РезультатВыбора = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Exl = Новый ComObject("Excel.Application");     
    Попытка
        Exl.Application.Workbooks.Open(РезультатВыбора[0]);
    Исключение
        мСообщение = Новый СообщениеПользователю();
        мСообщение.Текст = "что то пошло не так ...." + символы.ПС + ОписаниеОшибки();
        мСообщение.Сообщить();
        Возврат;
    КонецПопытки;
    
    // то что хочешь сделать с файлом
    i=4;
    ВсегоСтрок = Exl.Sheets(1).Cells(1,1).SpecialCells(11).Row;
    Пока i <= ВсегоСтрок Цикл
    //Пока ЗначениеЗаполнено(Exl.Sheets(1).Cells(i,1)) Цикл
        Строка = Объект.ПереченьТоваров.Добавить();
        Строка.Цена = Exl.Sheets(1).Cells(i, 10).Value;
        Строка.Количество = Exl.Sheets(1).Cells(i, 9).Value;
        Строка.Сумма = Exl.Sheets(1).Cells(i, 11).Value;
        Строка.Товар = НайтиТоварНаСервере(Exl.Sheets(1).Cells(i, 1).Value);
 
        i=i+1;
        // Обработка коллекции табличной части документа
    КонецЦикла;
    
    Exl.Application.Quit();
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция НайтиТоварНаСервере(Наименование)
 Возврат Справочники.Товары.НайтиПоНаименованию(Наименование);
КонецФункции
Все работает! Спасибо! Ждите меня завтра) С новыми вопросами)
Весь ответ на изначальный вопрос мог быть написан так во втором посте:
Добавьте приведение типа в этой строке:
1C
1
ApplicationExcel.Sheets(1).Cells(i, 1).Value = Строка(Строчка.Товар);
Но тогда бы я не узнал многого другого нового и интересного)

Добавлено через 3 минуты
1C
1
2
&НаКлиенте
Процедура Загрузить(РезультатВыбора, СтруктураДополнительныхПараметров) Экспорт
Можете пояснить что тут происходит?

Вернуться к обсуждению:
Загрузка и выгрузка табличной части документа в Excel
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.03.2016, 22:49

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник &quot;Сотрудники&quot; и подчиненный ему...

Выгрузка табличной части в таблицу значений
Ситуация такая,в документе имеется табличная часть Подписки (см. скрин), в ней есть колонка...

Ошибка в табличной части документа
Приветствую Вас многоуважаемые форумчане:drink: После долгого отсутствия мне наконец-то дали...

0
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru