Форум программистов, компьютерный форум, киберфорум
Наши страницы

Не проставляется оклад при печати трудового договора - 1С

Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Поиск по табличной части совпадение с каким-то наименованием и вывод совпадения http://www.cyberforum.ru/1c-custom/thread1879616.html
Имеется справочник, в нем есть реквизиты, также табличные части, в которых также есть реквизиты. Я создал кнопку которая должна выдать где есть совпадения с конкретным значением. (вывести...
1С Вывод даты в ясейку Excel в формате даты Здравствуйте. Пытаюсь вывести из табличной части обработки 1с дату в ячейку Excel: Лист.Cells(Стр + 4, 8).Value = Строка(ТаблицаВыгрузки.ДатаОкончанияРабот); Лист.Cells(Стр + 4, 8).NumberFormat=... http://www.cyberforum.ru/1c-custom/thread1879014.html
Создать элемент контактной информации (факс) 1С
Приветствую всех. Вопрос возник у меня. Мне надо у контрагента в его контактной информации "Телефон контрагента 1" перенести в "Факс контрагента", который ещё не создан. Делаю так: Запрос =...
1С Условное оформление со ссылкой на другой документ
Делаю подсистему по страхованию физлиц. Хочу сделать условное оформление "если клиент есть в документе СмертельныеСлучаи, то выделить его красным". Но через форму в 1С такую фичу сделать не смог. Как...
1С Не печатает нули в табличном документе http://www.cyberforum.ru/1c-custom/thread1877843.html
В обработке куча строк, но интересующий фрагмент кода ВыводОтчета = Ложь; Если ВыводОтчета Тогда Макет = ПолучитьМакет("МакетПОБезОпераций"); ОбластьЗаголовок =...
1С Временные таблицы Есть 2 запроса (внизу). Результат на выходе должен быть одинаковый, но нет. Запрос 1 без временных таблиц (справочник соединие левое сам с собой). Запрос 2 - тоже самое только разбито на... подробнее

Показать сообщение отдельно
CJX
14 / 14 / 4
Регистрация: 26.11.2015
Сообщений: 235

1C 8.x Не проставляется оклад при печати трудового договора - 1С

16.12.2016, 11:21. Просмотров 243. Ответов 0
Метки (Все метки)

Привет всем. Есть обработка, которая выводит в doc-файл форму трудового договора. Все данные работают нормально, кроме Оклада. Вне зависимости от выбранного сотрудника - всегда оклад = 0 рублей. Подскажите, пожалуйста, в связи с чем это может быть. Спасибо.

Оклад:
1C
1
2
3
4
5
6
7
8
9
10
ЭтоТарифнаяСтавка = Ложь;
    Оклад = ПолучитьОкладТарифнуюСтавку (Стр.Сотрудник, ЭтоТарифнаяСтавка);
    
    Если НЕ ЭтоТарифнаяСтавка Тогда
        Данные.Вставить ("Оклад", Оклад);
        Данные.Вставить ("ТарифнаяСтавка", "");
    Иначе
        Данные.Вставить ("Оклад", "");
        Данные.Вставить ("ТарифнаяСтавка", Оклад);
    КонецЕсли;
Функция
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
Функция ПолучитьОкладТарифнуюСтавку (Сотрудник, ЭтоТарифнаяСтавка)
    Отбор = Новый Структура ("Сотрудник", Сотрудник);
    Начисления = СсылкаНаОбъект.ОсновныеНачисления.НайтиСтроки (Отбор);
    Для Каждого Стр Из Начисления Цикл
        Если Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоДням Тогда
            ЭтоТарифнаяСтавка = Ложь;
            Возврат Стр.Показатель1;
        ИначеЕсли Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоЧасам Тогда
            ЭтоТарифнаяСтавка = Истина;
            Возврат Стр.Показатель1;
        ИначеЕсли Стр.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ТарифЧасовой Тогда
            ЭтоТарифнаяСтавка = Истина;
            Возврат Стр.Показатель1;
        КонецЕсли;
    КонецЦикла;
    
    ЭтоТарифнаяСтавка = Ложь;
    Возврат 0;
КонецФункции // ПолучитьОкладТарифнуюСтавку
Добавлено через 7 минут
Конфигурация ЗУП 2.5

Добавлено через 43 минуты
Конфигурация ЗУП 2.5
Цитата Сообщение от CJX Посмотреть сообщение
Возврат 0;
Всё из-за этого кусочка. Если его вообще убрать - то там вообще нет ничего. При попытке сделать
1C
1
Вовзрат Оклад
выдает ошибку, переменная не определена.

Добавлено через 4 минуты
Всё сделал. Извините за захламление.
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru