Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Расчёт пени http://www.cyberforum.ru/1c-custom/thread1885629.html
В документе Задолженности в поле табличной части Пеня рассчитать собственно пеню. Исходная сумма берётся из поля Сумма табличной части этого же документа. Сумма берётся из регистра сведений...
1С Выборка нужной информации из разных справочников Добрый день господа. С 1С работаю недавно, по этому возможно для большинства мой вопрос покажется достаточно смешным. И так суть проблемы вот в чем: Есть 2 справочника "Номенклатура" и... http://www.cyberforum.ru/1c-custom/thread1885584.html
Можно ли так сделать запись в регистр 1С
День добрый. Делаю движения по регистру, сначала выполняется запрос, и в запросе получаю поле "Период". Далее пишу так: Таблица = Запрос.Выполнить().Выгрузить(); Далее хочу в движениях...
Как скрыть данные параметров в макете 1С
Привет. В БП нужно при печати акта сверки, чтобы данные по контрагентам не заполнялись, сама таблица оставалась, параметры в макете тоже должны оставаться, а при выводе на печать просто пустая часть...
1С Редактирование формата табличного документа http://www.cyberforum.ru/1c-custom/thread1884751.html
Всем привет. Дело вот в чём. Есть таблица, в которой есть лишние данные (выделены на скрине) Их удалил программно, поэтому при печати на обычный лист А4, оставшаяся часть размечена по левой...
1С Вывод на печать с условием 1С 8.3 Здравствуйте. Имеется команда для вывода на печать (ПечатьДопФорм) и два макета печати ПечатьП1, ПечатьП2. На форме документа есть два реквизита (П1 и П2) являющихся флажками - в зависимости от... подробнее
renat_dmitriev
390 / 292 / 121
Регистрация: 26.08.2016
Сообщений: 900
22.12.2016, 19:42 0

1с отчет СКД выбор данных в зависимости от значения логического параметра

22.12.2016, 19:42. Просмотров 3330. Ответов 13
Метки (Все метки)

Ответ

Tatiana21,

Не имеет смысла создавать три логически параметра, достаточно создать в запросе СКД одно поле

РазрешениеЗаявлениеЗаполнены, что-то вроде

1C
1
2
3
4
ВЫБОР КОГДА Разрешение = ДАТА(1, 1, 1, 0, 0, 0) ТОГДА ЛОЖЬ
КОГДА Заявление = ДАТА(1, 1, 1, 0, 0, 0) ТОГДА ЛОЖЬ
ИНАЧЕ ИСТИНА
КОНЕЦ КАК РазрешениеЗаявлениеЗаполнены
и поместить на форму переключатель с тремя возможными значениями.

Не забудьте в СКД добавить его в отбор

При изменении переключателя устанавливайте программно значение этого поля или снимайте галочку использование, если необходимы все записи.

Пример процедуры программной установки значения отбора

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Процедура УстановтьОтборПоПолюКомпоновки(Имя,Значение = Неопределено, ВидСравнения = Неопределено)
         Для Каждого ЭлементОтбора Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
              Если ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(Имя) Тогда
                    Если Значение = Неопределено Тогда
                          ЭлементОтбора.Использование = Ложь;
                    Иначе
                          ЭлементОтбора.ВидСравнения = ВидСравнения; 
                          ЭлементОтбора.ПравоеЗначение = Значение; 
                          ЭлементОтбора.Использование = Истина; 
                    КонецЕсли;
              КонецЕсли;
         КонецЦикла;
КонецПроцедуры
Соответственно в первом случае вызываете процедуру

1C
1
УстановтьОтборПоПолюКомпоновки("РазрешениеЗаявлениеЗаполнены", Неопределено, ВидСравнения.Равно);
во втором случае ту же процедуру со вторым параметром ЛОЖЬ
в третьем случае со вторым параметром ИСТИНА

Вернуться к обсуждению:
1с отчет СКД выбор данных в зависимости от значения логического параметра
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.12.2016, 19:42

1с отчет на СКД: независимые наборы данных
Всем привет! Платформа 1С:Предприятие 8.3, конфигурация редактированная типовая, режим...

Распределить значения по годам в зависимости от параметра
Есть куча домов. У каждого дома рассчитывается параметр описывающий его износ (в баллах). В...

Отчет СКД: получение данных из двух регистров накопления, неверные суммы результата запроса
День добрый, я здесь,так как это последний фронт. Пишу внешний отчетик на скд. Я уже упростил его...

0
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru