Форум программистов, компьютерный форум, киберфорум
Наши страницы

Python: научные вычисления

Войти
Регистрация
Восстановить пароль
 
 
megabax
6 / 6 / 1
Регистрация: 06.08.2009
Сообщений: 241
#1

Как установить Tensorflow? - Python

12.06.2017, 20:23. Просмотров 827. Ответов 16
Метки нет (Все метки)

Добрый день.
Подскажите пожалуйста, как правильно установить Tensorflow?
Делаю так:
python -m pip install tensorflow

выдает вот такое сообщение об ошибке https://yadi.sk/i/Aj1E-1Ov3K4CH2

Если делаю так python -m pip install tf то устанавливается и не работает, при попытке, выполнить, например вот такой код:
Python
1
2
3
4
5
import tf as tf
 
hello = tf.constant('Hello, TensorFlow!')
sess = tf.Session()
print(sess.run(hello))
Говорит:
Traceback (most recent call last):
File "D:/Самообразование/Питон/TensorFlow/proba.py", line 3, in <module>
hello = tf.constant('Hello, TensorFlow!')
AttributeError: 'module' object has no attribute 'constant'
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.06.2017, 20:23
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Как установить Tensorflow? (Python):

Jupyter Notebook не видит tensorflow - Python
Привет! ситуация такова: Ipython, jupyter QtConsole видят библиотеку, а notebook нет. как решить проблему?

Что лучше выбрать новичку для криволинейной регрессии: tensorflow, sckit, theano, keras? - Python
Здравствуйте, мне нужно с помощью машинного обучения решить задачу регрессии. Мне понадобится криволинейная регрессия. Подскажите,...

Не устанавливается tensorflow - Python
Прошу опытных товарищей растолковать почему не устанавливается tensorflow , хотя по сути вроде все правильно, вот скрин

Как установить Nuitka? - Python
Хотел поставить вот это, не получилось, но с причинами сильно не разбирался, есть у кого нибудь опыт работы с Нуиткой? (Заявлена...

Как установить Python 3.3? - Python
Я новичок в питоне и мне не помогла тема &quot;Если вы новичок в Python, то вам сюда&quot;. :D Решил установить Python 3.3.2 на Centos 6.4....

Как установить lxml? - Python
При компиляции вылазит ошибка как исправить? Что я использую lxml 3.3.5 python 3.4.1 MinGW 0.6.2 beta

16
Garry Galler
969 / 742 / 214
Регистрация: 28.10.2013
Сообщений: 1,869
12.06.2017, 20:33 #2
tf это Randomised true or false values, а не тензорные исчисления.
Что касается tensorflow - для вашей версии python (3.4) на pypi (как впрочем и на .lfd.uci.edu) отсутствует windows дистрибутив.
0
megabax
6 / 6 / 1
Регистрация: 06.08.2009
Сообщений: 241
12.06.2017, 21:25  [ТС] #3
Garry Galler, а для какой есть виндовый дисрибутив?
0
Garry Galler
969 / 742 / 214
Регистрация: 28.10.2013
Сообщений: 1,869
12.06.2017, 21:56 #4
У вас есть уникальная возможность воспользоваться современными поисковиками, которые на введенную чушь
вроде знзш еутящкадщц тем не менее дадут вам осмысленный ответ в виде ссылки, не потратив на это ни секунды вашего времени.
0
alex925
2571 / 2222 / 527
Регистрация: 19.03.2012
Сообщений: 8,664
14.06.2017, 07:45 #5
megabax, pip берет дистрибутивы вот отсюда https://pypi.python.org/pypi/tensorflow/1.2.0rc2, заходишь и смотришь, под какие версии python есть сборки.

Для винды есть сборки под 64 битную версию python 3.5 and 3.6.

А вообще, судя по ошибки у тебя проблема не с утановкой библиотеки, а тем, что у нее api изменилось. Скорее всего ты смотришь старый ман или старую доку.
0
Garry Galler
969 / 742 / 214
Регистрация: 28.10.2013
Сообщений: 1,869
14.06.2017, 13:27 #6
Цитата Сообщение от alex925 Посмотреть сообщение
судя по ошибки у тебя проблема не с уcтановкой библиотеки, а тем, что у нее api изменилось
API не изменилось, просто tf != tensorflow.
tf это модуль tf-1.0.0 с одной функцией: This is the "tf.py" module, and it provides one function called rand_tf()
which prints a random value of true or false.
0
vlasovsv26
4 / 4 / 2
Регистрация: 06.03.2017
Сообщений: 133
16.08.2017, 10:04 #7
чтобы завести тензорфло нужна 64 разрядная версия винды?
0
Garry Galler
969 / 742 / 214
Регистрация: 28.10.2013
Сообщений: 1,869
16.08.2017, 15:40 #8
Цитата Сообщение от vlasovsv26 Посмотреть сообщение
нужна 64 разрядная версия винды
Иное указано в доках tensorflow? Не указано.
Впрочем желающим предлагается пройти увлекательный тур по самостоятельной компиляции из исходников без гарантии получения какого-либо рабочего результата.
0
vlasovsv26
4 / 4 / 2
Регистрация: 06.03.2017
Сообщений: 133
25.09.2017, 22:06 #9
народ, не могу найти системные требования tensor flow? подскажите, а то хочу выбрать нетбук чтобы можно было запустить в винде
0
megabax
6 / 6 / 1
Регистрация: 06.08.2009
Сообщений: 241
29.12.2017, 21:32  [ТС] #10
Добрый день. подскажите, пожалуйста, что делаю не так, выполняю воттакой батник,
Код
C:\Users\user\AppData\Local\Programs\Python\Python36-32\python.exe -m pip install tensorflow-1.2.0rc2-cp36-cp36m-win_amd64.whl
pause
whl лежит в том ж каталоге.
Выдает вот такую ошибку (вложенный файл)
0
Миниатюры
Как установить Tensorflow?  
megabax
6 / 6 / 1
Регистрация: 06.08.2009
Сообщений: 241
29.12.2017, 21:33  [ТС] #11
Операционка стоит вот такая (второй вложенный файл)
0
Миниатюры
Как установить Tensorflow?  
Jabbson
Модератор
Эксперт по компьютерным сетям
3251 / 2328 / 499
Регистрация: 03.11.2009
Сообщений: 7,413
Записей в блоге: 3
29.12.2017, 22:31 #12
А питон-то -32
0
megabax
6 / 6 / 1
Регистрация: 06.08.2009
Сообщений: 241
30.12.2017, 09:02  [ТС] #13
Цитата Сообщение от Jabbson Посмотреть сообщение
А питон-то -32
Э... это значит он 32-битный что ли, поэтому не работает?
0
Garry Galler
969 / 742 / 214
Регистрация: 28.10.2013
Сообщений: 1,869
30.12.2017, 14:10 #14
Цитата Сообщение от megabax Посмотреть сообщение
он 32-битный что ли, поэтому не работает
Да. 32-битный процесс не может сказать 64-битному: "привет, дай-ка мне вот эту функцию по этому адресу", потому что они существуют в параллельных вселенных и их адресация не совпадает.

Краткий курс архитектуры ОС:
Процесс одной размерности (битности) может загрузить только модуль той же размерности
Введение в 64 бита на Windows
1
megabax
6 / 6 / 1
Регистрация: 06.08.2009
Сообщений: 241
31.12.2017, 10:08  [ТС] #15
Garry Galler, Спасибо, буду изучать.
0
31.12.2017, 10:08
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.12.2017, 10:08
Привет! Вот еще темы с ответами:

Как установить html5lib? - Python
Уважаемые знатоки, подскажите, пожалуйста, как установить эту библиотеку? Python 3.5.1 (64-bit) Windows 8 x64 Установил Python...

Как установить lxml? - Python
Для модуля LXML требует libxml2 и libxslt. Поискал информации в интернете, и как я понял, для Windows надо скачать бинарник (Binary...

Как установить среду разработки? - Python
Скачал python. Думал, нормальная среда - шиш! Консоль и все! Как будто вообще скачал что-то нерабочее. Пожалуйста, объясните нормальным...

Как установить модуль requests? - Python
я не знаю что такое PIP, поэтому нажал на downlod tarball, скачал, то что было в архиве скинул в папку с Python, в папку Lib, я что то не...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.