Форум программистов, компьютерный форум, киберфорум
Наши страницы
Ruby on Rails
Войти
Регистрация
Восстановить пароль
 
HackeXe
0 / 0 / 0
Регистрация: 29.11.2017
Сообщений: 53
1

Проблема в обновлении rails из 4.2.0 в 5.0.2

11.07.2019, 09:01. Просмотров 220. Ответов 0
Метки нет (Все метки)

Ruby
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    active_model_serializers (~> 0.10.0.rc5) was resolved to 0.10.9, which depends on
      actionpack (>= 4.1, < 6)
 
    axlsx_rails (~> 0.5.0) was resolved to 0.5.2, which depends on
      actionpack (>= 3.1)
 
    haml-rails was resolved to 1.0.0, which depends on
      actionpack (>= 4.0.1)
 
    rails (= 5.0.2) was resolved to 5.0.2, which depends on
      actionpack (= 5.0.2)
 
    responders (~> 2.0) was resolved to 2.4.1, which depends on
      actionpack (>= 4.2.0, < 6.0)
 
    rspec-rails (~> 3.0) was resolved to 3.8.2, which depends on
      actionpack (>= 3.0)
 
Bundler could not find compatible versions for gem "activerecord":
  In Gemfile:
    activerecord-postgis-adapter (~> 3.1.4) was resolved to 3.1.5, which depends on
      activerecord (~> 4.2)
 
    rails (= 5.0.2) was resolved to 5.0.2, which depends on
      activerecord (= 5.0.2)
 
Bundler could not find compatible versions for gem "rails":
  In Gemfile:
    rails (= 5.0.2)
 
    leaflet-rails was resolved to 1.5.1, which depends on
      rails (>= 4.2.0)
 
    react-rails (~> 1.6.0) was resolved to 1.6.2, which depends on
      rails (>= 3.2)
 
Bundler could not find compatible versions for gem "resque":
  In Gemfile:
    resque (~> 1.26.0)
 
    resque-scheduler (~> 4.3.0) was resolved to 4.3.1, which depends on
      resque (~> 1.26)
Я поменял в файле "GemFile" на 5.0.2 и выдала ошибку. В ошибке не сказано, что какой-либо gem не поддерживает 5.0.2. Помогите, пожалуйста.
Причина обновления из-за:

Ruby
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
dayanov-sa@dayanov-sa:~/workspace/main/sokol_dev$ rails c
/home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/core_ext/object/duplicable.rb:85: warning: BigDecimal.new is deprecated; use BigDecimal() method instead.
/home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric/conversions.rb:121: warning: constant ::Fixnum is deprecated
/home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric/conversions.rb:121: warning: constant ::Bignum is deprecated
Traceback (most recent call last):
        7948: from bin/rails:4:in `<main>'
        7947: from bin/rails:4:in `require'
        7946: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/railties-4.2.0/lib/rails/commands.rb:17:in `<top (required)>'
        7945: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/railties-4.2.0/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
        7944: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/railties-4.2.0/lib/rails/commands/commands_tasks.rb:67:in `console'
        7943: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/railties-4.2.0/lib/rails/commands/commands_tasks.rb:142:in `require_application_and_environment!'
        7942: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/railties-4.2.0/lib/rails/application.rb:328:in `require_environment!'
        7941: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/dependencies.rb:274:in `require'
         ... 7936 levels...
           4: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric/conversions.rb:131:in `block (2 levels) in <class:Numeric>'
           3: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric/conversions.rb:131:in `block (2 levels) in <class:Numeric>'
           2: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric/conversions.rb:131:in `block (2 levels) in <class:Numeric>'
           1: from /home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric/conversions.rb:131:in `block (2 levels) in <class:Numeric>'
/home/dayanov-sa/.rvm/gems/ruby-2.6.3/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric/conversions.rb:131:in `block (2 levels) in <class:Numeric>': stack level too deep (SystemStackError)
перепробовал многие методы для решения данной проблемы, но ничего не помогло. Кто-нибудь сталкивался с подобной ситуацией и знает какой-нибудь путь решения?

Rails 4.2.0

ruby 2.6.3p62 (2019-04-16 revision 67580) [x86_64-linux]
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.07.2019, 09:01
Ответы с готовыми решениями:

проблема при обновлении Viewки
Здравствуйте. С недавнего времени изучаю Lotus. Вопрос вот какой возник. Попробую вратце обрисовать...

Проблема при обновлении Упп
Доброго времени суток. Обновил с 21.1 на 22.1 при проверке конфы, вылезла ошибка в документе...

Чтобы писать на Ruby on Rails - нужно учить Ruby потом Rails?
Чтобы выучить Ruby on Rails - нужно учить Ruby потом Rails?


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
0
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru