Форум программистов, компьютерный форум, киберфорум
Наши страницы
Turbo Pascal
Войти
Регистрация
Восстановить пароль
 
sergei3ru
21 / 18 / 4
Регистрация: 07.04.2010
Сообщений: 791
1

Напишите алгоритм, определяющий, есть ли в заданном двумерном массиве строки, не содержащие нулей

09.06.2015, 19:36. Просмотров 421. Ответов 3
Метки нет (Все метки)

Добрый день, текст задачи:
Напишите алгоритм, определяющий, есть ли в заданном двумерном массиве строки, не содержащие нулей.
Есть начало программы в Кумире, подскажите, как прописать условие, есть ли в массиве строки без нулей?
Pascal
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
алг 
нач целтаб м[1:10,1:5], цел т, н
нц для т от 1 до 3
нц для н от 1 до 3
ввод м[т,н]
кц
кц
нц для т от 1 до 3
нц для н от 1 до 3
вывод м[т,н], " "
кц
вывод нс
кц
если м[т,н]<>0
то 
вывод 'есть строки не содержащие нулей' 
все
кон
Добавлено через 2 часа 11 минут
Может как то так, но все равно не получается:
Pascal
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
алг 
нач целтаб м[1:10,1:5], цел т, н, к, лог ф
к:=0
нц для т от 1 до 3
нц для н от 1 до 3
ввод м[т,н]
кц
кц
нц для т от 1 до 3
нц для н от 1 до 3
вывод м[т,н], " "
кц
вывод нс
кц
нц для т от 1 до 3
ф:=нет
нц для н от 1 до 3
если м [т,н]<>0 то 
ф:=да
все
кц
кц
если ф то вывод 'да' 
иначе
вывод 'Нет'
все
кон
Добавлено через 21 час 10 минут
Помогите, пожалуйста!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.06.2015, 19:36
Ответы с готовыми решениями:

В произвольно заданном двумерном массиве поменять местами строки, содержащие минимальный и максимальный элемент
9. В произвольно заданном двумерном массиве поменять местами строки, содержащие...

В двумерном массиве найти строки содержащие отрицательные и положительные элементы
В двумерном массиве найти строки содержащие отрицательные и положительные...

В двумерном массиве поменять местами строки, содержащие максимальный и минимальный элементы.
Помогите пожалуйста с 2-мя задачами на массив. 1.Одномерный массив,...

Составьте программу, выясняющую, есть ли в заданном двумерном массиве A(N,M) элементы, принадлежащие множеству (K,C,P,T)
Составьте программу, выясняющую, есть ли в заданном двумерном массиве A(N,M)...

Поиск нулей в двумерном массиве. Не могу найти ошибку в коде
Дан двумерный массив. Заполнен единицами и нулями. Например такой: 0 0 1 1...

3
sergei3ru
21 / 18 / 4
Регистрация: 07.04.2010
Сообщений: 791
10.06.2015, 19:34  [ТС] 2
Всю задачу не надо, только сам алгоритм определения есть строки без нулей или нет.

Добавлено через 7 минут
Всем спасибо. Задача решена!
Pascal
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
алг 
нач целтаб м[1:10,1:5], цел т, н, к, лог ф
к:=0
нц для т от 1 до 3
нц для н от 1 до 3
ввод м[т,н]
кц
кц
нц для т от 1 до 3
нц для н от 1 до 3
вывод м[т,н], " "
кц
вывод нс
кц
нц для т от 1 до 3
ф:=да
нц для н от 1 до 3
если м [т,н]=0 то 
ф:=нет
все
кц
кц
если ф то вывод 'да'
иначе вывод 'нет'
все
кон
0
Cyborg Drone
Модератор
5397 / 3201 / 2450
Регистрация: 17.08.2012
Сообщений: 10,274
12.06.2015, 00:38 3
Так, что ль...
Код
нц для т от 1 до 3
ф:=да
нц для н от 1 до 3
ф:=ф и (м [т,н]<>0)
кц
если ф 
то выход
все
кц
вывод ф
кон
0
Puporev
Модератор
54978 / 42287 / 29200
Регистрация: 18.05.2008
Сообщений: 99,910
12.06.2015, 12:41 4
Код
алг 
нач
цел т,н,р,с,ф|количество строк, столбцов счетчики по ним, фиксатор ноля
цел таб а[1:10,1:10]|матрица
вывод "Введите количество строк от 2 до 10", нс
ввод т
если т<2 или т>20 то вывод "Неверное количество строк" все
вывод "Введите количество столбцов от 2 до 10", нс
ввод н
если н<2 или н>20 то вывод "Неверное количество столбцов" все
вывод "Введите элементы  последователности, целые числа", нс
р:=0
нц т раз
р:=р+1
с:=0
нц н раз
с:=с+1
вывод "а[",р,",",с,"]="
ввод а[р,с]
кц
кц
вывод "Исходная матрица", нс
р:=0;
нц т раз
р:=р+1
с:=0;
нц н раз
с:=с+1
вывод а[р,с]," "
кц
вывод нс
кц
ф:=0| нет 0
р:=1
нц пока р<=т и ф=0
с:=1
нц пока с<=н и ф=0
если а[р,с]=0 то ф:=1 иначе с:=с+1 все|есть 0
кц
если ф=0 то р:=р+1 все
кц
если ф=0 то вывод "есть строки не содержащие нолей"
иначе вывод "нет строк не содержащих нолей"
все
кон
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.06.2015, 12:41

Определить количество нулей в одномерном заданном массиве
Помогите)

В двумерном массиве вставить перед четными столбцами столбец из нулей, а после нечетных строк строку из единиц
Добрый день! Подскажите пожалуйста решение следующей проблемы. Задан...

В заданном двумерном массиве из целых чисел вывести строку с максимальным элементом
3. В заданном двумерном массиве из целых чисел вывести строку с максимальным...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru