Форум программистов, компьютерный форум, киберфорум
Наши страницы
Ubuntu, Mint Linux
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.93/15: Рейтинг темы: голосов - 15, средняя оценка - 4.93
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
1

Ubuntu 15.10 не работает Wifi Acer Aspire V3-574

28.10.2015, 14:28. Просмотров 2830. Ответов 15
Метки нет (Все метки)

Здравствуйте уважаемые форумчани.
Приобрел себе ноутбук (так сказать на перспективу) Acer Aspire V3-574G-55SG
На лицензионный Windows денег (да и желания нет). Решил поставить Ubuntu 15.10.
Для отладки кода под Windows думаю сделать винду в VirtyalBox.

Ubuntu стала отчично (ставил в UEFI).
Да вот незадача оказывается Wifi не работает,
Wiif я меня:
Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 20)

пробовал установить прошивку:

Bash
1
2
3
4
5
6
git clone [url]https://github.com/atondwal/ath10k-firmware.git[/url]
sudo cp -r ath10k-firmware/ath10k/ /lib/firmware/
cd /lib/firmware/ath10k/QCA6164
sudo cp -r hw2.1/ /lib/firmware/ath10k/QCA6174/
 
Reboot
Не помогло.

Может есть здесь лоди которые знают решении данной проблемы. Буду очень благодарен.

Добавлено через 12 минут
Bash
1
2
3
4
user@ouser-desktop:~$ rfkill list
1: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.10.2015, 14:28
Ответы с готовыми решениями:

Ubuntu 15.10 не выключается ПК Aspire V3-574
Здравствуйте! Ubuntu 15.10 ПК - Aspire V3-574 При выключении ПК -...

Очень сильно греется Acer Aspire 5750G в Ubuntu 12.04
Очень сильно греется Acer Aspire 5750G в Ubuntu 12.04. Даже без запуска...

Ubuntu 15.10 не работает wifi
ребятушки, установил ubuntu 15.10(32bit), а wifi не работает. Ehternet...

Не работает WiFi на Ubuntu 11.10
Помогите срочно!!! Установил Ubuntu 11.10 и возникли проблемы с подключением...

Не работает WiFi на ubuntu 11.10
Есть компьютер на котором стоить убунту 11.10, OC менять не могу, нет...

15
Marinero
Модератор
Эксперт NIX
2059 / 1669 / 570
Регистрация: 02.03.2015
Сообщений: 5,490
28.10.2015, 15:25 2
Bash
1
lspci -k | grep -iA2 net
А вот позвольте у Вас поинтересоваться: Почему 15.10, а не 14.04.3?
0
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
29.10.2015, 00:31  [ТС] 3
В 14.04.3 таже проблема. Да и 14.04.3 не хочет запускатся в UEFI (safe mode)

Bash
1
2
3
4
5
6
7
user@user-leptop:~$ lspci -k | grep -iA2 net
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
    Subsystem: Acer Incorporated [ALI] Device 102e
    Kernel driver in use: r8169
03:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 20)
    Subsystem: Foxconn International, Inc. Device e08e
    Kernel driver in use: ath10k_pci
0
Marinero
Модератор
Эксперт NIX
2059 / 1669 / 570
Регистрация: 02.03.2015
Сообщений: 5,490
29.10.2015, 01:23 4
Цитата Сообщение от http://askubuntu.com/questions/661424/ubuntu-14-04-wireless-not-working-no-network-interface-atheros-168c003e-dev
You can try a solution from there

Bash
1
2
3
wget [url]http://kernel.ubuntu.com/~adamlee/lp1383184/ath10k-dkms_1.1_all.deb[/url]
sudo dpkg -i ath10k-dkms_1.1_all.deb
sudo apt-get install -f
You need kernel 3.19 to be installed. It can be checked by uname -r command.

If you have kernel 3.13 or 3.16 in Ubuntu 14.04, then run
Bash
1
sudo apt-get install linux-generic-lts-vivid
and reboot prior to driver installation
Давайте проверим
Bash
1
uname -r
0
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
29.10.2015, 01:32  [ТС] 5
Bash
1
2
user@user-leptop:~$ uname -r
4.2.0-16-generic
0
Marinero
Модератор
Эксперт NIX
2059 / 1669 / 570
Регистрация: 02.03.2015
Сообщений: 5,490
29.10.2015, 01:35 6
Тогда пробуйте 1,2,3 (без [URL] — это сайт вставляет)
0
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
29.10.2015, 01:55  [ТС] 7
Bash
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
user@user-leptop:~/Загрузки$ sudo dpkg -i ath10k-dkms_1.1_all.deb
[sudo] пароль для user: 
(Чтение базы данных … на данный момент установлено 225622 файла и каталога.)
Подготовка к распаковке ath10k-dkms_1.1_all.deb …
Распаковывается ath10k-dkms (1.1) на замену (1.1) …
dpkg: зависимости пакетов не позволяют настроить пакет ath10k-dkms:
 ath10k-dkms зависит от dkms (>= 1.95), однако:
  Пакет dkms не установлен.
 
dpkg: ошибка при обработке пакета ath10k-dkms (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для initramfs-tools (0.120ubuntu6) …
update-initramfs: Generating /boot/initrd.img-4.2.0-16-generic
При обработке следующих пакетов произошли ошибки:
 ath10k-dkms
user@user-leptop:~/Загрузки$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  dkms
НОВЫЕ пакеты, которые будут установлены:
  dkms
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 65,5 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 262 kB.
Хотите продолжить? [Д/н] y
Получено:1 [url]http://ua.archive.ubuntu.com/ubuntu/[/url] wily/main dkms all 2.2.0.3-2ubuntu6 [65,5 kB]
Получено 65,5 kБ за 0с (382/c)
Выбор ранее не выбранного пакета dkms.
(Чтение базы данных … на данный момент установлено 225622 файла и каталога.)
Подготовка к распаковке …/dkms_2.2.0.3-2ubuntu6_all.deb …
Распаковывается dkms (2.2.0.3-2ubuntu6) …
Обрабатываются триггеры для man-db (2.7.4-1) …
Настраивается пакет dkms (2.2.0.3-2ubuntu6) …
Настраивается пакет ath10k-dkms (1.1) …
Loading new ath10k-1.1 DKMS files...
First Installation: checking all kernels...
Building only for 4.2.0-16-generic
Building for architecture x86_64
Building initial module for 4.2.0-16-generic
Error! Bad return status for module build on kernel: 4.2.0-16-generic (x86_64)
Consult /var/lib/dkms/ath10k/1.1/build/make.log for more information.
dpkg: ошибка при обработке пакета ath10k-dkms (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Обрабатываются триггеры для initramfs-tools (0.120ubuntu6) …
update-initramfs: Generating /boot/initrd.img-4.2.0-16-generic
При обработке следующих пакетов произошли ошибки:
 ath10k-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
0
Marinero
Модератор
Эксперт NIX
2059 / 1669 / 570
Регистрация: 02.03.2015
Сообщений: 5,490
29.10.2015, 08:38 8
Вроде по русски написано, не по басурмански даже…
Цитата Сообщение от aligator33 Посмотреть сообщение
ath10k-dkms зависит от dkms (>= 1.95), однако:
* Пакет dkms не установлен.
Bash
1
sudo apt-get install dkms
и со2-го пункта по новой (при удачной установке)
0
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
29.10.2015, 09:26  [ТС] 9
Bash
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
$ sudo dpkg -i ath10k-dkms_1.1_all.deb
Выбор ранее не выбранного пакета ath10k-dkms.
(Чтение базы данных … на данный момент установлено 221415 файлов и каталогов.)
Подготовка к распаковке ath10k-dkms_1.1_all.deb …
Распаковывается ath10k-dkms (1.1) …
Настраивается пакет ath10k-dkms (1.1) …
Loading new ath10k-1.1 DKMS files...
First Installation: checking all kernels...
Building only for 4.2.0-16-generic
Building for architecture x86_64
Building initial module for 4.2.0-16-generic
ERROR (dkms apport): unable to determine source package for ath10k-dkms
Error! Bad return status for module build on kernel: 4.2.0-16-generic (x86_64)
Consult /var/lib/dkms/ath10k/1.1/build/make.log for more information.
dpkg: ошибка при обработке пакета ath10k-dkms (--install):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Обрабатываются триггеры для initramfs-tools (0.120ubuntu6) …
update-initramfs: Generating /boot/initrd.img-4.2.0-16-generic
При обработке следующих пакетов произошли ошибки:
 ath10k-dkms
Bash
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
$ sudo apt-get install ath10k-dkms
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия ath10k-dkms.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить? [Д/н] y
Настраивается пакет ath10k-dkms (1.1) …
Removing old ath10k-1.1 DKMS files...
 
------------------------------
Deleting module version: 1.1
completely from the DKMS tree.
------------------------------
Done.
Loading new ath10k-1.1 DKMS files...
First Installation: checking all kernels...
Building only for 4.2.0-16-generic
Building for architecture x86_64
Building initial module for 4.2.0-16-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/ath10k-dkms.0.crash'
Error! Bad return status for module build on kernel: 4.2.0-16-generic (x86_64)
Consult /var/lib/dkms/ath10k/1.1/build/make.log for more information.
dpkg: ошибка при обработке пакета ath10k-dkms (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Обрабатываются триггеры для initramfs-tools (0.120ubuntu6) …
update-initramfs: Generating /boot/initrd.img-4.2.0-16-generic
При обработке следующих пакетов произошли ошибки:
 ath10k-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
0
Dmitry
Эксперт по компьютерным сетямЭксперт NIX
10751 / 6078 / 456
Регистрация: 09.09.2009
Сообщений: 24,077
29.10.2015, 10:06 10
Цитата Сообщение от Marinero Посмотреть сообщение
и со2-го пункта по новой
он его устанавливал, просто иным способом:
Цитата Сообщение от aligator33 Посмотреть сообщение
user@user-leptop:~/Загрузки$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей * * *
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
* dkms
НОВЫЕ пакеты, которые будут установлены:
* dkms
для aligator33, вам сам инсталятор предлагает проверить лог (для дополнительной информации):
Цитата Сообщение от aligator33 Посмотреть сообщение
Consult /var/lib/dkms/ath10k/1.1/build/make.log for more information.
имхо, "уже назрела" необходимость проверить, что же там все-таки написано

зы. ориентировочно, из приведеных вами сообщений уже можно предположить, что не нравится ему все-таки именно ваше ядро 4.2.0-16:
Цитата Сообщение от aligator33 Посмотреть сообщение
Error! Bad return status for module build on kernel: 4.2.0-16-generic (x86_64)
возможно пакет только для 3.Х?
0
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
29.10.2015, 17:03  [ТС] 11
Вот лог make.log
0
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
29.10.2015, 17:45  [ТС] 12
Лучший ответ Сообщение было отмечено Marinero как решение

Решение

Ребята, заработал:


Bash
1
2
3
4
5
6
7
8
9
10
sudo apt-get install build-essential linux-headers-$(uname -r) git
echo "options ath10k_core skip_otp=y" | sudo tee /etc/modprobe.d/ath10k_core.conf
wget [url]https://www.kernel.org/pub/linux/kernel/projects/backports/2015/09/03/backports-20150903.tar.gz[/url]
tar -zxvf backports-20150903.tar.gz
cd backports-20150903
make defconfig-ath10k
make
sudo make install
 
Then reboot
0
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
25.02.2016, 23:36  [ТС] 13
https://bugs.launchpad.net/ubuntu/+s...x?comments=all

Добавлено через 4 часа 23 минуты
Сегодня переустанавливал систему, для нормальной работы WiFi необходимо:

Bash
1
2
3
4
git clone [url]https://github.com/atondwal/ath10k-firmware.git[/url]
sudo cp -r ath10k-firmware/ath10k/ /lib/firmware/
cd /lib/firmware/ath10k/QCA6164
sudo cp -r hw2.1/ /lib/firmware/ath10k/QCA6174/
Reboot

Bash
1
2
3
4
5
6
7
8
sudo apt-get install build-essential linux-headers-$(uname -r) git
echo "options ath10k_core skip_otp=y" | sudo tee /etc/modprobe.d/ath10k_core.conf
wget [url]https://www.kernel.org/pub/linux/kernel/projects/backports/2015/09/03/backports-20150903.tar.gz[/url]
tar -zxvf backports-20150903.tar.gz
cd backports-20150903
make defconfig-ath10k
make
sudo make install
Then reboot
0
Daimon Dementii
0 / 0 / 0
Регистрация: 01.03.2016
Сообщений: 2
01.03.2016, 15:06 14
а вот у меня так и не заработала
у почти такойже ноут тоже ядро не 16 а 32 и Wi-fi Broadcom Corporation BCM43142 802.11b/g/n (rev 01)
0
aligator33
14 / 14 / 16
Регистрация: 17.08.2015
Сообщений: 125
Завершенные тесты: 1
01.03.2016, 17:42  [ТС] 15
Цитата Сообщение от Daimon Dementii Посмотреть сообщение
а вот у меня так и не заработала
Попробуйте посмотреть на сайте https://bugs.launchpad.net/ubuntu/+s...x?comments=all

Начиная с поста #80.

Или свяжитесть с "Jeremy (wa113y3s)" - он мне помог.
0
Daimon Dementii
0 / 0 / 0
Регистрация: 01.03.2016
Сообщений: 2
01.03.2016, 19:23 16
ситуация крайне бредовая у меня!!
пытался починить вай фай а теперь у меня как то частично обновилось до 16,04 плюс ко всему етому немогу зделать откат системы так как в параметрах системы функция резервная копия неработает!!!!!!!ето такой бред сижу целый день и никак немогу ничё зделать((((((((((
0
01.03.2016, 19:23
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
01.03.2016, 19:23

Linux ubuntu 16.04 Не работает wifi и графика nvidia
Привет всем, нужна помощь опытного пользователя. Помогите плиз, 2 недели...

xubuntu и aspire one - wifi
Поставил на acer aspire one xubuntu 12.04, не работает wi-fi. Погуглил, нашел...

Linux на Acer Aspire V3
Устанавливал ли кто-нибудь Linux на Acer Aspire V3? Есть эспаиры с Windows 8, а...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru