Форум программистов, компьютерный форум CyberForum.ru
Наши страницы

VBA

Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 12, средняя оценка - 5.00
normres
0 / 0 / 0
Регистрация: 02.08.2009
Сообщений: 50
#1

Записать формулу - VBA

01.10.2009, 23:02. Просмотров 1458. Ответов 1
Метки нет (Все метки)

Здравствуйте

Подскажите как исправить код
При нахождение ячейки строки I она становится равной значению верхней ячейки.
Необходимо чтобы она была равной формуле значения верхней ячейки.
Или занести формулу.
Код:

Код
.Cells(i, 22) = .Cells(i - 1, 22)
--------------------------------------------------------------
До и после выполнения кода.
--------------------------------------------------------------

Например строка 3 столбец V, так выглядят
Столбец А……….Столбец V
1…………………..
2…………………..=СУММ(V1)
3…………………..1234567
4…………………..=СУММ(V3)
5…………………..=СУММ(V4)
--------------------------------------------------------------
После выполнение кода, строка 3 столбец V, должны выглядеть так.
Столбец А……….Столбец V
1…………………..
2…………………..=СУММ(V1)
3…………………..=СУММ(V2)
4…………………..=СУММ(V3)
5…………………..=СУММ(V4)
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.10.2009, 23:02
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Записать формулу (VBA):

Записать формулу в макрос: ПОИСКПОЗ - VBA
Доброго времени суток! Проблема: Не получается прописать формулу на Листе Функция ячейка D9 с помощью макроса, чтобы заполнялась...

Как записать число в формулу - VBA
Нужно вычислить разницу между значениями двух ячеек и в другую ячейку записать формулу ОКРУГЛ()+полученная разница пишу так: If...

Excel 2007: записать формулу в ячейку - VBA
доброго времени суток! друзья, каким образом можно записать в ячейку формулу с помощью макроса. вот часть кода NextRow =...

Записать формулу в ячейку, используя vba - VBA
Добрый день! Имеется такая проблема: есть 2 листа, пусть лист1 и лист2. На каждом листе есть таблицы разной размерности: на листе1 - 12х12,...

Как записать формулу с переменной в VBA - VBA
Добрый день! Помогите решить проблему. В программе VBA вычисляется две переменные (Line, columbRackStateDSensor). И теперь надо при...

Как правильно записать формулу для цикла do? - VBA
Есть формула: ActiveCell.FormulaR1C1 = _ "=наличие_файла(""file://\file\44-я \file\44-я 26.10-01.11""&RC)" Как записать RC...

1
Toxa33rus
3813 / 877 / 87
Регистрация: 16.04.2009
Сообщений: 1,757
02.10.2009, 12:25 #2
Может не так понял, но вот:
Visual Basic
1
.Cells(i, 22).Formula = .Cells(i - 1, 22).Formula
Добавлено через 2 минуты
А, не, вроде не то будет. Будет везде одна и таже формула а надо их как бы растянуть?

Добавлено через 5 минут
Тогда вот так:
Visual Basic
1
Cells(i - 1, 22).AutoFill Destination:=Range(Cells(i - 1, 22), Cells(i, 22)), Type:=xlFillDefault
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.10.2009, 12:25
Привет! Вот еще темы с ответами:

Как в Vba записать формулу, содержащую ссылки на ячейки - VBA
Всем доброго времени суток. такая проблема. нужно в vba записать в ячейку формулу: Cells(17, 24).FormulaR1C1 =...

Как в ячейку записать формулу на русском языке, используя набор стандартных команд? - VBA
Вот например этот код работает szKeyType = '=IF(ISERROR(VLOOKUP(RC,' & szSource & '!C,1,FALSE)),''No'',''Yes'')' ...

Как формулу записать в basic - Basic
c=|cos^3(x)-sin^2x|

расписать формулу - VBA
ПОдскажите пожалуйста а можно ли расписать формулу COUNTIF(A1:D2,6), так же как я вот расписал другую формулу: ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru