Форум программистов, компьютерный форум, киберфорум
Наши страницы
VBA
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.65/20: Рейтинг темы: голосов - 20, средняя оценка - 4.65
Igor__
1 / 1 / 0
Регистрация: 11.12.2011
Сообщений: 30
1

Excel 2007: записать формулу в ячейку

22.04.2013, 21:32. Просмотров 3689. Ответов 6
Метки нет (Все метки)

доброго времени суток!
друзья, каким образом можно записать в ячейку формулу с помощью макроса.
вот часть кода

Visual Basic
1
2
3
NextRow = Range("K65536").End(xlUp).Row + 1
Cells(NextRow, 11).Select
Cells(NextRow, 11).FormulaLocal = ....
и далее нужна формула считающая среднее значение.

т.е. он находит пустую ячейку, в данном случае К3 и вписывает в нее формулу =СРЗНАЧ(F3:J3)

макрос срабатывает по нажатию кнопки. при следующем нажатии должен записать в ячейку К4 формулу
=СРЗНАЧ(F4:J4) итд
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.04.2013, 21:32
Ответы с готовыми решениями:

Записать формулу в ячейку, используя vba
Добрый день! Имеется такая проблема: есть 2 листа, пусть лист1 и лист2. На...

Выделение цветом строки в Excel 2007, при нажатии на соседнюю ячейку
Здравствуйте. В поиске ничего подходящего не нашел, поэтому прошу помощи. ...

Как в ячейку записать формулу на русском языке, используя набор стандартных команд?
Вот например этот код работает szKeyType = '=IF(ISERROR(VLOOKUP(RC,' &...

Win Api: записать значение в ячейку Excel
Здравствуйте, уважаемые форумчане! Считать значение ячейки A1 на текущем...

Вместо каждого числа, встреченного в выделенном диапазоне, записать в ячейку его целую часть (Excel)
26. Excel : Вместо каждого числа, встреченного в выделенном диапазоне, записать...

6
Все имена заняты
1246 / 405 / 51
Регистрация: 14.06.2009
Сообщений: 628
22.04.2013, 22:04 2
Такой вариант
Visual Basic
1
2
NextRow = Range("K65536").End(xlUp).Row + 1
Cells(NextRow, 11).FormulaLocal = "=ÑÐÇÍÀ×(F" & NextRow & ":J" & NextRow & ")"
1
Igor__
1 / 1 / 0
Регистрация: 11.12.2011
Сообщений: 30
22.04.2013, 22:51  [ТС] 3
не срабатывает
0
Все имена заняты
1246 / 405 / 51
Регистрация: 14.06.2009
Сообщений: 628
22.04.2013, 23:10 4
...
2
Вложения
Тип файла: xls записать формулу в ячейку.xls (36.0 Кб, 120 просмотров)
Igor__
1 / 1 / 0
Регистрация: 11.12.2011
Сообщений: 30
26.04.2013, 01:22  [ТС] 5
не работало из-за объединенных ячеек в шапке
0
Igor_Tr
4368 / 652 / 36
Регистрация: 17.01.2010
Сообщений: 2,134
26.04.2013, 01:42 6
Если без обьединения никак (чужой документ), можно определиться с диапазоном и записать где то так:
Cells(NextRow, 11).value=Application.WorksheetFunction.Average(mRng). Должно работать.
1
KoGG
5277 / 1350 / 320
Регистрация: 23.12.2010
Сообщений: 2,019
Записей в блоге: 1
29.04.2013, 17:55 7
Оптимальнее использовать FormulaR1C1
Visual Basic
1
Cells(NextRow, 11).FormulaR1C1 = "=AVERAGE(RC6:RC10)"
2
29.04.2013, 17:55
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.04.2013, 17:55

Вместо каждого числа, встреченного в выделенном диапазоне, записать в ячейку его дробную часть (Excel)
30. Excel : Вместо каждого числа, встреченного в выделенном диапазоне, записать...

В ячейку записать дату, если в другую ячейку ввели "+"
Добрый день! Помогите разобраться с Workbook_SheetChange Необходимо чтобы...

Макрос, вставляющий формулу в ячейку
Private Sub A1B1B2() With Worksheets("Лист1") .Range("B1") = "1" ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru