Форум программистов, компьютерный форум CyberForum.ru
CyberForum.ru - форум программистов и сисадминов > > >
Восстановить пароль Регистрация
 
 
Blackx1
Новичок
0 / 0 / 0
Регистрация: 21.04.2010
Сообщений: 15
21.04.2010, 20:49     Не работает веб камера
  #1
Подключаю веб камеру. Определяется стандартными драйверами как USB2.0_Camera. Вроде как все ОК. Ну нет уж. Запускаю Skype - микрофон работает, а видео нету. Думал камера такая - взял другой винт, поставил на него 7-ку, подключил камеру и все заработало, сделал вывод что камера рабочая(и с 7-кой работает). На своей старой винде перепробывал уйму програм - тож самое. Такое ощущение что камеру использует другое приложение. Мож кто сталкивался с таким, или так кто чего посоветует. А то оч нужно именно эту винду оставить, да и камера нужна.
AdAgent
Объявления
21.04.2010, 20:49
Blackx1
Новичок
0 / 0 / 0
Регистрация: 21.04.2010
Сообщений: 15
23.04.2010, 20:44  [ТС]
  #2
Да помогите же кто нибудь плиз...
Извелся уже весь с этой камерой.
magirus
Почетный модератор
21327 / 11297 / 334
Регистрация: 15.09.2009
Сообщений: 44,829
Записей в блоге: 35
23.04.2010, 20:51
  #3
а модель камеры секрет?
и диск какой нибудь к ней был?
(например к моей был)

Добавлено через 30 секунд
а модель камеры секрет?
и диск какой нибудь к ней был?
(например к моей был)
Blackx1
Новичок
0 / 0 / 0
Регистрация: 21.04.2010
Сообщений: 15
23.04.2010, 21:29  [ТС]
  #4
Canyon CNR-WCAM413G. Диск был, но дров под х64 не было. Дело в том что на чистой такойже винде подключил камеру и все заработало. На сколько я понял это чтото именно в моей системе а что именно не могу найти...
magirus
Почетный модератор
21327 / 11297 / 334
Регистрация: 15.09.2009
Сообщений: 44,829
Записей в блоге: 35
24.04.2010, 20:04
  #5
Цитата Сообщение от Blackx1 Посмотреть сообщение
на чистой такойже винде
а вот тут поподробнее....
Blackx1
Новичок
0 / 0 / 0
Регистрация: 21.04.2010
Сообщений: 15
24.04.2010, 21:01  [ТС]
  #6
Взял винт, поставил на него с того же диска винду(машина таже). Прицепил камеру. Драйвера стали такиеже. И тут чудо...... Камера работает. Ставлю старый виннт - не работает. По ходу
чегото с виндой... А чего не пойму... Уже 5 лет админом работаю, а чувствую себя ламером в этом вопросе
magirus
Почетный модератор
21327 / 11297 / 334
Регистрация: 15.09.2009
Сообщений: 44,829
Записей в блоге: 35
24.04.2010, 21:16
  #7
мдя... походу на старой винде действительно , какой то кодек, или драйверок ривой есть....
посоветовать что то сложно....
удалить разве кодек паки пробовать...
statuserg
Новичок
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 3
26.04.2010, 12:42
  #8
Эта проблема мне знакома. Windows 7 x64
Камера Philips spc1030nc.
Купил, установил с диска драйвер для Vista x64 (других не было), камера работала отлично.
Не знаю что произошло но через некоторое время у камеры стал работать только микрофон, а видео отключилось.
Удалил драйвера, скачал с сайта новые для Windows 7x64 (на самом деле это те же что и для Vistax64, как оказалось). Установил эти драйвера. Подключаю камеру - винда ищет и устанавливает какие-то свои драйвера сама. В итоге снова работает только микрофон от камеры.
В диспетчере устройств виден микрофон в "Звуковые, видео и игровые устройства" и камера в "устройства обработки изображений", при попытке поставить родные драйвера пишет "драйвера не нуждаются в обновлении".
Отнес камеру в сервис, они подключают к компьютеру с Вистой - работает. Потом сам подключил к неттопу с Windows 7, тоже работает.
Позвонил в техподдержку филипса, около 2-х часов мы перезагружались и переустанавливали драйвера всякими способами. Парень из техподдержки пообещал порыться на форумах и перезвонить.
Перезвонил, еще 40 минут отчаянных попыток, снова не удалось. Пообещал отослать проблему европейским коллегам и перезвонить.

Пробовал отключать автоматический поиск драйверов в Windows update и нашел вручную и удалил те драйвера, которые винда подсовывает каждый раз вместо родных.
Наконец-то удалось установить родные драйвера!!...Но камера снова не работала.
Видимо дело не в драйверах. По крайней мере не в драйверах камеры.

Возможные проблемы: видеокарта nvidia geforce 9600 gt стоит на одном и том же прерывании (IRQ 16) еще с 4-мя устройствами.
Вроде это сейчас не сильно страшно, но я уже не знаю что думать. Тем более, что с видеокартой есть уже проблемы (тормозит при проигрывании blu-ray, не передает звук на телевизор по dvi-hdmi, хотя должна).
Две звуковые карты: со встроенной (Realtek) все нормально, а другая (c-media) была без драйверов под windows 7, устанавливал для XP и были предупреждения, что драйвера могу повлиять на работу системы.
even
Новичок
3 / 3 / 0
Регистрация: 24.11.2009
Сообщений: 10
26.04.2010, 13:55
  #9
как вариант..

в диспетчере устройств при обновлении драйвера выбрать установку из указанного места - "Включить следующее место поиска"-показать дрова на диске

в диспетчере устройств при обновлении драйвера выбрать установку из указанного места - "Не выполнять поиск. Я сам выберу нужный драйвер"-выбрать драйвер или установить с диска

подключить к дургому разъёму USB

описал по винде хп, но в семёрке по аналогии
statuserg
Новичок
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 3
26.04.2010, 13:59
  #10
even, с установкой своих драйверов на windows 7, я разобрался, хоть это и оказалось гораздо сложнее чем казалось.
Но родные драйвера с сайта не помогли, камера не работает. То есть есть какой-то конфликт что-ли, который семерка не замечает)
В другой usb переключал уже раз 200.
even
Новичок
3 / 3 / 0
Регистрация: 24.11.2009
Сообщений: 10
26.04.2010, 14:10
  #11
как устройство отображается?

Пуск\Панель управления\Все элементы панели управления\Устройства и принтеры

там через Оборудование\Свойства\Драйвер удалить драйвер..



..зы И это.. вариант переустановки скайпа был??
statuserg
Новичок
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 3
26.04.2010, 14:24
  #12
Во-первых у меня Windows 7
Во вторых если сделать так как вы пишете, то при следующем подключении устройства виндоус восстановит прежние драйвера через windows update, потому что она сохраняет их несмотря на то что вы их "удаляете". Исправить можно только если через gpedit.msc настроить параметры на поиск драйверов в windows update в Конфигурация компьютера\Административные шаблоны\Управление связью через интернет и ...\Установка драйвера.
В третьих, после установки "родных" драйверов от philips, камера все равно не работает на этом компьютере.

Устройство в диспетчере задач отображается корректно philips webcam spc1030nc и philips webcam spc1030nc (Audiomicrophone),
Скайп не переустаналивал, но камера не работает не только в скайпе, но и в браузерах и контрольная панель филипсовская тоже ее не видит.
Blackx1
Новичок
0 / 0 / 0
Регистрация: 21.04.2010
Сообщений: 15
26.04.2010, 21:09  [ТС]
  #13
Конфликты с другими девайсам по ходу отпадают(разве что с каким то драйверком). Я ставил эту камеру не просто на другую машину, а на эту же(взял только другой винт). И все работало со стандартными мелкосовтовскими дровами.
even
Новичок
3 / 3 / 0
Регистрация: 24.11.2009
Сообщений: 10
27.04.2010, 11:45
  #14
вообще-то я и говорил про windows 7 О_о
раззуй глаза и внимательно посмотри

Пуск\Панель управления\Все элементы панели управления\Устройства и принтеры

там через Оборудование\Свойства\Драйвер удалить драйвер..
- это если пункт "Просмотр" в панели управления установлен как "мелкие значки"

При выборе "Просмотр"-"категория" смотрим "Просмотр устройств и принтеров"
WW_123
Новичок
0 / 0 / 0
Регистрация: 02.04.2010
Сообщений: 6
27.04.2010, 14:30
  #15
Была похожая проблемка с камерой. Подключил к другой винде которая камеру видит, нашел файл драйвер, скопировал и просто заменил такойже файл в нужной системе... сработало.
Темный Маг
Гость
Сообщений: n/a
22.06.2010, 00:20
  #16
У меня очень похожая, на описываемую Blackx1, проблема.

Blackx1, получилось решить описанным WW_123 способом?
charset
Гость
Сообщений: n/a
08.04.2011, 22:59
  #17
Такая же история. На компе стоит Гениус старенькая, я торгую электроникой, в том числе и Вебкамерами. Не могу проверить камеры на основном компьютере (Win7 x64), приходится проверять либо на ноуте (Win7 x32), либо на втором комьютере (WinXP). Гениус тоже не работает. При чем раньше работала, перестала работать недевно. На других компах - камеры работают на ура, а вот на Вин х64 почему-то не хотят. Скорее всему виной либо оставшиеся дрова, либо какая-то программа (скорее всего второе). Причем если запустить скайп из последних версий, просто программа джет отклика видео, и это продолжается безконечно, а если в других программах или в скайпе старой версии - сразу выдает что видеокамера чем-то используется.

Понравился ответ на счет подкинуть файлы драйверов с работающего компа, но у меня там 32х разрядные системы, врятли поможет. Но попробую.
Greyson64
Новичок
0 / 0 / 0
Регистрация: 18.12.2011
Сообщений: 3
18.12.2011, 16:31
  #18
Цитата Сообщение от statuserg Посмотреть сообщение
Эта проблема мне знакома. Windows 7 x64
Камера Philips spc1030nc.
Купил, установил с диска драйвер для Vista x64 (других не было), камера работала отлично.
Не знаю что произошло но через некоторое время у камеры стал работать только микрофон, а видео отключилось.
Удалил драйвера, скачал с сайта новые для Windows 7x64 (на самом деле это те же что и для Vistax64, как оказалось). Установил эти драйвера. Подключаю камеру - винда ищет и устанавливает какие-то свои драйвера сама. В итоге снова работает только микрофон от камеры.
В диспетчере устройств виден микрофон в "Звуковые, видео и игровые устройства" и камера в "устройства обработки изображений", при попытке поставить родные драйвера пишет "драйвера не нуждаются в обновлении".
Отнес камеру в сервис, они подключают к компьютеру с Вистой - работает. Потом сам подключил к неттопу с Windows 7, тоже работает.
Позвонил в техподдержку филипса, около 2-х часов мы перезагружались и переустанавливали драйвера всякими способами. Парень из техподдержки пообещал порыться на форумах и перезвонить.
Перезвонил, еще 40 минут отчаянных попыток, снова не удалось. Пообещал отослать проблему европейским коллегам и перезвонить.

Пробовал отключать автоматический поиск драйверов в Windows update и нашел вручную и удалил те драйвера, которые винда подсовывает каждый раз вместо родных.
Наконец-то удалось установить родные драйвера!!...Но камера снова не работала.
Видимо дело не в драйверах. По крайней мере не в драйверах камеры.

Возможные проблемы: видеокарта nvidia geforce 9600 gt стоит на одном и том же прерывании (IRQ 16) еще с 4-мя устройствами.
Вроде это сейчас не сильно страшно, но я уже не знаю что думать. Тем более, что с видеокартой есть уже проблемы (тормозит при проигрывании blu-ray, не передает звук на телевизор по dvi-hdmi, хотя должна).
Две звуковые карты: со встроенной (Realtek) все нормально, а другая (c-media) была без драйверов под windows 7, устанавливал для XP и были предупреждения, что драйвера могу повлиять на работу системы.
Здравствуйте! Как вы решили проблему с камерой под Win 7 ? У меня такая же беда, даже видеокарта такая же. Измучался уже, ни что не помогает...
Blackx1
Новичок
0 / 0 / 0
Регистрация: 21.04.2010
Сообщений: 15
18.12.2011, 23:03  [ТС]
  #19
С чем-чем могут быть проблеммы, но видеокарта тут совсем не причем
Что б долго не мучаться переустановил виндовс
Проблемма исчезла и более не возвращался к этой теме
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.12.2011, 07:37

Еще ссылки по теме:

Windows 7 Старая веб-камера

Windows 7 Не работает веб-камера на моем компьютере

Windows 7 Веб камера

Windows 7 Не работает веб камера на ноутбуке msi gx70

Greyson64
Новичок
0 / 0 / 0
Регистрация: 18.12.2011
Сообщений: 3
19.12.2011, 07:37     Не работает веб камера
  #20
Цитата Сообщение от Blackx1 Посмотреть сообщение
С чем-чем могут быть проблеммы, но видеокарта тут совсем не причем
Что б долго не мучаться переустановил виндовс
Проблемма исчезла и более не возвращался к этой теме
В том то вся и проблема, что винды переставлять нежелательно! На винте 1С установлена, переставлять винды, значит покупать новую 1С, там уже количество установок (3 шт.) закончилось, вот такая хрень...
Yandex
Объявления
19.12.2011, 07:37
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Ответ Создать новую тему
Опции темы

Текущее время: 01:53. Часовой пояс GMT +4.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.7 PL3
Copyright ©2000 - 2014, vBulletin Solutions, Inc.