Форум программистов, компьютерный форум, киберфорум
Наши страницы
Xamarin
Войти
Регистрация
Восстановить пароль
 
koder_ml9
1 / 1 / 0
Регистрация: 19.11.2014
Сообщений: 7
#1

Не отображает элементы при запуске на эмуляторе (Visual Studio) - Xamarin

03.01.2018, 04:11. Просмотров 295. Ответов 1
Метки нет (Все метки)

Доброго времени суток всем!

XML
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
<?xml version="1.0" encoding="utf-8"?>
<RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android"
    android:layout_width="match_parent"
    android:layout_height="match_parent"
    android:visibility="visible"
    android:minWidth="25px"
    android:minHeight="25px">
    <Button
        android:text="Button"
        android:layout_width="match_parent"
        android:layout_height="wrap_content"
        android:visibility="visible"
        style="@style/PasscodeButtonStyle"
        android:id="@+id/button1" />
    <Button
        android:text="Button"
        android:layout_width="match_parent"
        android:layout_height="wrap_content"
        android:visibility="visible"
        style="@style/PasscodeButtonStyle"
        android:id="@+id/button2"
        android:layout_below="@id/button1" />
    <Button
        android:text="Button"
        android:layout_width="match_parent"
        style="@style/PasscodeButtonStyle"
        android:visibility="visible"
        android:layout_height="wrap_content"
        android:layout_below="@id/button2"
        android:id="@+id/button3" />
</RelativeLayout>
Вид в редакторе:

http://www.cyberforum.ru/xamarin/thread1796471.html
Не отображает элементы при запуске на эмуляторе (Visual Studio)

Вид в эмуляторе:

Не отображает элементы при запуске на эмуляторе (Visual Studio)


В другом проекте все было нормально пока не добавил эти элементы, они так же не отображаются:

Не отображает элементы при запуске на эмуляторе (Visual Studio)

Добавлено через 35 секунд
Куда копать? Не пому в чем проблема...

Добавлено через 5 минут
С тестовым разобрался, забыл дописать SetContentView(Resource.Layout.Main)...
С основным тоже SetContentView был от похожего по смыслу Layout и взял за основу его активити =\

Добавлено через 32 секунды
Всем спасибо за помощь!)
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.01.2018, 04:11
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Не отображает элементы при запуске на эмуляторе (Visual Studio) (Xamarin):

Ошибка при запуске приложения для Android в Visual Studio&Xamarin
Invalid argument: cannot open transport registration socketpair List of devices...

Ошибка при создании проекта Xamarin.Forms Portable в Visual Studio
При попытке создания проекта Xamarin.Forms Portable в Visual Studio выдает...

Пытаюсь работать с VkNet на XamarinAndroid visual studio. При добавлении библиотеки выскакивает ошибка
Не удалось установить пакет «Microsoft.NETCore.Jit 1.1.2». Вы пытаетесь...

Не отображает элементы при запуске на эмуляторе. Android Studio
Подскажите, из-за чего может быть проблема Имеются две активности Empty и...

Ошибка при запуске Visual Studio
После того как переустановил VS 2013 Express Desktop при запуски программы...

1
ProRight
0 / 0 / 0
Регистрация: 14.01.2018
Сообщений: 12
16.01.2018, 03:15 #2
А у тебя небыло ошибки 'Resource.Layout' does not contain a definition for 'Main'
Я ток создаю пустое приложение андроид запускаю через live player и уже сразу ошибка эта
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.01.2018, 03:15
Привет! Вот еще темы с решениями:

Ошибка при запуске Visual Studio 2012
Впервые столкнулся с данным типом ошибки помогите ее устранить

Ошибка при запуске Emulator в Visual Studio
При запуске Эмулятора выводит такую ошибку, не могу понять в чем дело &quot;Не...

Предупреждение при запуске Visual Studio 2012
Здравствуйте! Столкнулся с ситуацией. Всю жизнь сидел на x86 винде, теперь...

Ошибка при запуске Visual Studio 2012
Выдаёт такую ошибку при каждом запуске, переустановку делал раз 5. Как-то...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru