Форум программистов, компьютерный форум, киберфорум
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/7: Рейтинг темы: голосов - 7, средняя оценка - 4.71
0 / 0 / 0
Регистрация: 06.05.2013
Сообщений: 8
1

Как это будет в 1С

24.03.2014, 13:46. Показов 1298. Ответов 2
Метки нет (Все метки)

Pascal
1
2
3
4
5
6
7
8
9
var a:array[1..100] of integer;
n,i:integer;
begin
writeln('VVEDITE KOL-VO ELEMENTOV');
read(n);
for i:=1 to n do
read(a[i]);
if a[1]>0 then writeln('Положительное')else writeln('Отрицательное');
end.
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
24.03.2014, 13:46
Ответы с готовыми решениями:

Как это будет на С++?
На языке паскаль работа со строками: if Pos(Copy(s1, k, i), s2) > 0 как это будет на с++? Хелп

Как это будет выглядеть в С++
Вот программа на Паскале VAR S:STRING; BEGIN WHILE NOT EOF DO BEGIN ...

как это будет выглядеть на С++?
var x,p:real; i:byte; begin writeln('Vvedite x'); readln(x); p:=1;; i:=2; ...

Как это будет выглядеть на с++?
a,b=b,a Как данная строка на плюсах будет выглядеть?

2
Эксперт 1С
3042 / 1989 / 524
Регистрация: 25.06.2009
Сообщений: 6,938
24.03.2014, 14:17 2
Лучший ответ Сообщение было отмечено Dantekiberg как решение

Решение

Вообще процедуру надо повесить куда-то. И уточнить для управляемого или обычного приложения нужен код?

Код для управляемого приложения:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&НаКлиенте
Процедура ЗаполнитьМассив()
 Перем i,n; 
 a = Новый Массив(100);
 
 Массив = Новый Массив;
 Массив.Добавить(Тип("Число"));
 КЧ = Новый КвалификаторыЧисла(10,0); 
 ОписаниеТипов = Новый ОписаниеТипов(Массив, КЧ);
 Если ВвестиЗначение(n, "Введите кол-во элементов", ОписаниеТипов) Тогда
    // обработка введенного значения
    Для i = 0 по n-1 Цикл //индексация массива начинается с 0
       a.Вставить(i,i); //возможно а.Вставить(i,i+1) - из-за изменения индексации
       Если a[i] > 0 Тогда
          Сообщить("Положительное");
       ИначеЕсли a[i] < 0 Тогда // чтобы не попал 0
          Сообщить("Отрицательное");
       КонецЕсли;
    КонецЦикла;
 КонецЕсли;
КонецПроцедуры
1
Модератор
Эксперт 1С
3095 / 2782 / 523
Регистрация: 10.03.2011
Сообщений: 10,700
Записей в блоге: 1
24.03.2014, 14:35 3
Примерно так.

1C
1
2
3
4
5
6
7
8
9
10
11
Var n,i; //В 1С мягкая типизация, поэтому типа интежер нет =(
a = new Array(100);
InputNumber(n, "VVEDITE KOL-VO ELEMENTOV");
if n <> Undefined then
   for i = 0 to n-1 do
       InputNumber(a[i]);
       if a[i] > 0 then Message("Положительное'");
       else Message("Отрицательное");
       endif;
   enddo;
endif;
Цитата Сообщение от Dantekiberg Посмотреть сообщение
if a[1]>0 then writeln('Положительное')else writeln('Отрицательное');
А почему проверяем значение только первого индеска?

Добавлено через 2 минуты
не успел =))

Добавлено через 6 минут
Цитата Сообщение от Dantekiberg Посмотреть сообщение
read(a[i]);
если мне не изменяет память, то процедура read в паскале это ввод данных (чтение введенных данных с клавиатуры)
в примере из https://www.cyberforum.ru/1c/t... ost5943818 результат всегда будет положительным, т.к. сами элементы мы не вводим
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
24.03.2014, 14:35

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Как будет выглядеть это в си?
FROM inOut IMPORT Write, Writeln; CONST N=10; VAR i,k,r:CARDINAL; d:ARRAY OF CARDINAL; BEGIN ...

Hibernate. Как это будет в SQL
Здравствуйте. У меня есть запросы Hibernate 1.Criteria crit = sess.createCriteria(Cat.class);...

Как это будет работать? 3 планки
У меня материнская плата Материнская плата Asus H97-PLUS Поддержка памяти4 x DDR3 DIMM; 1333 -...

Как это будет выглядить в МАТЛАБЕ
Как это будет выглядить в МАТЛАБЕ? #include &lt;cstdlib&gt; #include &lt;iostream&gt; using namespace...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.