Форум программистов, компьютерный форум, киберфорум
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.69/26: Рейтинг темы: голосов - 26, средняя оценка - 4.69
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 85
1
1С Web

Снимок с веб-камеры

08.04.2014, 12:43. Показов 5130. Ответов 3

Добрый день.

Из 1С нужно получать снимок с веб-камеры, для этого использую библиотеку wiaaut.dll и из нее comОбъект WIA.DeviceManager.

В тонком клиенте все нормально работает, а вот в веб-клиенте вылетает ошибка

браузер Chrome
Название: ошибка.png
Просмотров: 392

Размер: 6.3 Кб

браузер IE
Снимок с веб-камеры



из-за чего может быть ошибка?
ошибка на строке создания комОбъекта
1C
1
Device = Новый COMОбъект("WIA.DeviceManager");
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
08.04.2014, 12:43
Ответы с готовыми решениями:

Снимок с веб камеры
как снять в билдер с++ снимок с веб камеры? в компонент TImage к примеру.

Снимок с веб-камеры
нашел такой пример, который выводит на окно видео в режиме онлайн с вэб камеры ...

Получить снимок с веб камеры
На данный момент смешал эти коды...

Как делать снимок с веб камеры
Подскажите WinAPI функцию, с помощью которой можно сделать снимок с веб камеры. И есть ли WinAPI...

3
Модератор
Эксперт 1С
3071 / 2760 / 520
Регистрация: 10.03.2011
Сообщений: 10,620
Записей в блоге: 1
08.04.2014, 14:11 2
В тонком и веб клиентах 1С отказалась от использования технологий ActiveX
типовыми методами это сделать не получиться

Добавлено через 4 минуты
Для веб и тонкого попробуйте воспользоваться контейнерами для создания ActivX (способ конечно через жопу), но рабочий
Вот пример:

Не по теме:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
// На форме в поле HTML вписываем вот этот текст добавится проигрыватель на всё поле. 
// Можно менять параметры.
 
 
<OBJECT id=WMP classid=CLSID:6BF52A52-394A-11D3-B153-00C04F79FAA6 width="100%" height="100%">
  <PARAM NAME="URL" VALUE="">
  <PARAM NAME="rate" VALUE="1">
  <PARAM NAME="balance" VALUE="0">
  <PARAM NAME="currentPosition" VALUE="0">
  <PARAM NAME="defaultFrame" VALUE="">
  <PARAM NAME="playCount" VALUE="1">
  <PARAM NAME="autoStart" VALUE="-1">
  <PARAM NAME="currentMarker" VALUE="0">
  <PARAM NAME="invokeURLs" VALUE="-1">
  <PARAM NAME="baseURL" VALUE="">
  <PARAM NAME="volume" VALUE="50">
  <PARAM NAME="mute" VALUE="0">
  <PARAM NAME="uiMode" VALUE="full">
  <PARAM NAME="stretchToFit" VALUE="-1">
  <PARAM NAME="windowlessVideo" VALUE="0">
  <PARAM NAME="enabled" VALUE="-1">
  <PARAM NAME="enableContextMenu" VALUE="-1">
  <PARAM NAME="fullScreen" VALUE="0">
  <PARAM NAME="SAMIStyle" VALUE="">
  <PARAM NAME="SAMILang" VALUE="">
  <PARAM NAME="SAMIFilename" VALUE="">
  <PARAM NAME="captioningID" VALUE="">
  <PARAM NAME="enableErrorDialogs" VALUE="0">
  <PARAM NAME="_cx" VALUE="24262">
  <PARAM NAME="_cy" VALUE="15319">
</OBJECT>
 
 
 
 
// Также на форме делаем кнопку которая будет (скажем загружать в WMP выбранный файл файл)
 
&НаКлиенте
Процедура Команда1(Команда)
      
      
      ЭлементВК = Элементы.НавигацияРабочийСтол.Документ.getElementById("WMP"); // Тут ищем элемент
      Если ЭлементВК = Неопределено Тогда
            Сообщить("Не найден объект компоненты!");  // Здесь понятно
              Возврат;
      КонецЕсли;
 
      Элементы.НавигацияРабочийСтол.ТолькоПросмотр = Ложь;   // Тут тоже понятно
      WMP = ЭлементВК.contentDocument;                       // Тут получаем контент компоненты      
      Режим = РежимДиалогаВыбораФайла.Открытие;
 
      ДиалогВыбораФайла = Новый ДиалогВыбораФайла(Режим);          // Создаем диалог выбора файла
      ДиалогВыбораФайла.Фильтр       = "Все файлы (все)|*.*";      // Здесь понятно
      ДиалогВыбораФайла.Заголовок = "Выберите медиафайл";              // Здесь понятно
 
      Если ДиалогВыбораФайла.Выбрать() Тогда
            ПутьКМедиаФайлу = ДиалогВыбораФайла.ПолноеИмяФайла;
        
            // В зависимости от варианта объекта запись полного пути к файлу
            // производится либо в свойство FileName, либо в свойство URL.
        
            Попытка
                  WMP.FileName = ПутьКМедиаФайлу;
        
            Исключение      
                  WMP.URL = ПутьКМедиаФайлу;
        
            КонецПопытки;      
 
      КонецЕсли;
КонецПроцедуры

0
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 85
08.04.2014, 17:27  [ТС] 3
Цитата Сообщение от Dethmontt Посмотреть сообщение
Для веб и тонкого попробуйте воспользоваться контейнерами для создания ActivX (способ конечно через жопу), но рабочий
Вот пример:
т.е через это можно заставить работать компоненту WIA.DeviceManager?
0
Модератор
Эксперт 1С
3071 / 2760 / 520
Регистрация: 10.03.2011
Сообщений: 10,620
Записей в блоге: 1
09.04.2014, 17:50 4
Цитата Сообщение от Pasych Посмотреть сообщение
т.е через это можно заставить работать компоненту WIA.DeviceManager?
Да =)))
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
09.04.2014, 17:50

Снимок с веб-камеры сохранить в файл
Всем привет! Полазив по форуму, к сожалению, нормального решения так и не нашел, везде либо...

Снимок с веб-камеры и сохранение в файл (hd)
Доброго времени суток. Есть задание: осуществить возможность сохранения снимка с веб-камеры в файл...

Как получить снимок c веб-камеры из ASP?
День добрый! Есть веб-камера Creative. Кто знает как можно с нее снимать снимок при загрузке ASP?...

Снимок с веб камеры без использования буфера
Всем привет. Такой вопрос: можно ли копировать снимок не в буфер, а например, сразу в поток?...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.