Форум программистов, компьютерный форум, киберфорум
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
0 / 0 / 0
Регистрация: 21.06.2017
Сообщений: 24
1

Не определяется ссылка на документ через оповещение()

25.11.2018, 20:48. Просмотров 454. Ответов 8
Метки нет (Все метки)

Добрый день всем! Есть проблема, нахожусь в документе, из документа при заполнении ТЧ создаю новую номенклатуру и хочу что бы автоматом она заполнялась в ТЧ документа и обновлялась! Что я не так делаю? Не могу получить ссылку на текущий документ в котором нахожусь
1C
1
2
3
4
5
6
7
8
9
10
Код в номенклатуре:
&НаСервере
Процедура ПриЗакрытииНаСервере()
    Оповестить("закрытие",Объект.Ссылка,ПолучитьФорму("Обработка.РаботаСоШтрихкодами.Форма.ФормаВводаШтрихкода"));
КонецПроцедуры
 
&НаКлиенте
Процедура ПриЗакрытии(ЗавершениеРаботы)
    ПриЗакрытииНаСервере();
КонецПроцедуры
,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
 Код в обработке!
&НаКлиенте
Функция  ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    Если ИмяСобытия = "закрытие" Тогда
        ВернутьЗначениеДляНовойНоменклатуры(ЭтаФорма.Штрихкод, Параметр);            
    КонецЕсли;
КонецФункции
&НаКлиенте
Процедура ВернутьЗначениеДляНовойНоменклатуры(Форма, Параметр) Экспорт
        //ТекТовар = НовыйТоваррррр(Параметр);    
        
        // Обновление ТЧ Документа после записи номенклатуры !!!
        п = Новый Структура("Ключ", Параметры.СсылкаНаТекДокумент); 
        Форма = ПолучитьФорму("Документ.ПоступлениеНаСклад.Форма.ФормаДокумента", п); 
        Форма.Прочитать();    
КонецПроцедуры
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
25.11.2018, 20:48
Ответы с готовыми решениями:

Отчет, ссылка на документ через регистр накопления
Доброго времени суток, такая проблема: есть документ, есть регистр накопления, есть отчет. В...

CSS, не работает ссылка на .css документ через java script
<head> <title>Сайта</title> <script language=JavaScript> if...

Ссылка на документ
Пытаюсь в событии QueryOpen документа вставить в ричтекст ссылку на документ из другой базы. Все...

Ссылка на документ в 1С 8
Всем привет. Как можно получить данные из открытого,текущего документа, в другой модуль программы?...

8
1191 / 779 / 268
Регистрация: 16.01.2015
Сообщений: 3,079
25.11.2018, 21:37 2
Цитата Сообщение от clav9nski Посмотреть сообщение
ВернутьЗначениеДляНовойНоменкл атуры(ЭтаФорма.Штрихкод, Параметр);
Цитата Сообщение от clav9nski Посмотреть сообщение
&НаКлиенте
Процедура ВернутьЗначениеДляНовойНоменкл атуры(Форма, Параметр) Экспорт
Передаете в качества параметра (первая цитата) ЭЛЕМЕНТ формы, а в процедуре пытаетесь из элемента сделать форму
Цитата Сообщение от clav9nski Посмотреть сообщение
п = Новый Структура("Ключ", Параметры.СсылкаНаТекДокумент) ;
Уверены, что в параметрах есть Ссылка? Из кода этого не следует. Ссылка у вас просто - Параметр
0
0 / 0 / 0
Регистрация: 21.06.2017
Сообщений: 24
25.11.2018, 21:51  [ТС] 3
polax, в параметрах ссылка на справочник(номенклатуру) который я создал, и после создания мне нужно что б он добавился в ТЧ документа и обновился, но он т.к. заново начинает идти по обработке он не видит мою ссылку, т.е. не могу обратиться к текущему документу для обновления ТЧ
1C
1
2
3
п = Новый Структура("Ключ", Параметры.СсылкаНаТекДокумент); 
        Форма = ПолучитьФорму("Документ.ПоступлениеНаСклад.Форма.ФормаДокумента", п); 
        Форма.Прочитать();
0
1191 / 779 / 268
Регистрация: 16.01.2015
Сообщений: 3,079
25.11.2018, 22:20 4
clav9nski, В Оповещении вы передаете напрямую Ссылку, а в Обработке оповещения обращаетесь к параметру как к структуре. Отладчиком пользоваться умеете? Посмотрите что у вас Параметр
0
0 / 0 / 0
Регистрация: 21.06.2017
Сообщений: 24
25.11.2018, 22:33  [ТС] 5
polax, так в этом то и вопрос, как мне определить ссылку на текущий документ. из справочника передаю ссылку на справочник что потом в обработке мог в документе записать, но я не знаю как ссылку на тек док получить
0
1191 / 779 / 268
Регистрация: 16.01.2015
Сообщений: 3,079
25.11.2018, 22:39 6
clav9nski, ТАК В ОПОВЕЩЕНИИ вы же передаете ОБъект.Ссылка, а в обработкеОповещения Параметр - это и есть ваша ссылка. Или я что-то недопонимаю из ваших довольно путанных объяснений. Вы говорите о документе потом об Обработке, справочнике. Объясните толком.
0
0 / 0 / 0
Регистрация: 21.06.2017
Сообщений: 24
25.11.2018, 22:47  [ТС] 7
polax, извиняюсь, выше написанный код я пометил кто где написан, я в оповещении предаю Объект.Ссылка - это ссылка на созданную мной номенклатуру, где по итогу мне не только на номенклатуру нужна ссылка но и на документ
0
1191 / 779 / 268
Регистрация: 16.01.2015
Сообщений: 3,079
25.11.2018, 22:54 8
Цитата Сообщение от clav9nski Посмотреть сообщение
нахожусь в документе, из документа при заполнении ТЧ создаю новую номенклатуру и хочу что бы автоматом она заполнялась в ТЧ документа и обновлялась!
При чем здесь Обработка? Вы еще тот объяснятель проблемы. Честно, не понимаю
0
Yulunga
25.11.2018, 23:30     Не определяется ссылка на документ через оповещение()
  #9

Не по теме:

polax, GreenkA ага!
так что нечего на меня гнать, что я не умею спрашивать! ))))

0
25.11.2018, 23:30
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
25.11.2018, 23:30
Привет! Вот еще темы с ответами:

Ссылка на документ
Добрый всем день =) Есть многопользовательская база. Когда создается новый документ, чтобы о нем...

ссылка на документ
Добрый день!Помогите пожалуйста советом. Существует следующая задача . Был создан договор,если по...

Ссылка на документ.
В поле (класс NotesRichTextItem) документа была создана ссылка на другой документ. (Call...

Ссылка на документ
Всем привет. В отчете (дополнительная внешняя обработка) необходимо чтобы в поле Документ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.