Форум программистов, компьютерный форум, киберфорум
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.55/11: Рейтинг темы: голосов - 11, средняя оценка - 4.55
55 / 30 / 5
Регистрация: 03.05.2018
Сообщений: 2,756
1
1C 8.x

Хранилище значений

03.02.2019, 15:44. Показов 2060. Ответов 4
Метки нет (Все метки)

Доброго времени суток!
Не пойму как это работает? Или это только программно делается?
Вот что нашел в интернете про это -
ХранилищеЗначения (хранилище значений 1С) – это объект в языке 1С, который позволяет хранить в базе данных прочие значения, например картинки и файлы, структуры и таблицы значений.
Создал реквизит тип хранилище значений. Но это го реквизита в режиме 1С Предприятие не видно.
Почему? Или как с этим работать?
Хранилище значений

Хранилище значений
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.02.2019, 15:44
Ответы с готовыми решениями:

Хранилище значений
Доброго времени суток! Это что за тип такой?

Хранилище Значения
Коллеги, изучая интересную вещь ХранилищеЗначения наткнулся на кое какие непонимания.. С...

1с На Сетевом Хранилище
Здравствуйте, имеется сетевое хранилище D-link dns-325 и 1С 7.7 Сетевая (Бухгалтерия), два...

Совмесное хранилище
Задача стоит следующая: Реализовать запись некоторых документов из одной базы в другую, например в...

4
755 / 564 / 149
Регистрация: 22.04.2013
Сообщений: 4,068
Записей в блоге: 1
03.02.2019, 17:54 2
а если ты туда положил файл какой-нить на десяток мегабайт, как его показать на экране?
а можно ТД (код взят с противного сайта)
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Процедура СохранитьВХранилищеНажатие(Элемент)
    ТабДок=Новый ТабличныйДокумент;    
    ТабДок.Вывести(ЭлементыФормы.ПолеТабличногоДокумента1);
    Хранилище=Новый ХранилищеЗначения(ТабДок);
    Записать();
КонецПроцедуры
 
Процедура ВосстановитьИзХранилищаНажатие(Элемент)
    ТабДок=Хранилище.Получить();
    Если ТабДок<>Неопределено Тогда
        ЭлементыФормы.ПолеТабличногоДокумента1.Вывести(ТабДок);
    КонецЕсли;
КонецПроцедуры
0
55 / 30 / 5
Регистрация: 03.05.2018
Сообщений: 2,756
03.02.2019, 18:45  [ТС] 3
Yulunga, а можно без программирования объяснить что именно такое хранилище значений? В моём случае почему ничего не выводится? Или так запланировано?
0
755 / 564 / 149
Регистрация: 22.04.2013
Сообщений: 4,068
Записей в блоге: 1
03.02.2019, 19:48 4
старшие товарищи поправят, но я предпочитаю для себя думать, что это ссылка внутренняя на что_то.
и это что_то может быть любым. файлом, массивом, таб частью, ...
поэтому выводить это на экран не надо
надо получить значение из хранилища, убедиться, что оно нужного вида, и тогда уже вывести.
вот тут 10 лет назад описано хорошо
также надо понимать, что файлы хранятся на сервере, а вывести/показать вы их хотите на клиенте.
0
Модератор
Эксперт 1С
3142 / 2818 / 534
Регистрация: 10.03.2011
Сообщений: 10,880
Записей в блоге: 1
04.02.2019, 01:30 5
Цитата Сообщение от byte777 Посмотреть сообщение
что именно такое хранилище значений?
zip архив сериализованной переменной (значения, коллекции, файла и т.д.)

Добавлено через 48 секунд
все что может быть превращено в строку, может быть упаковано в хранилище значения
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
04.02.2019, 01:30

внешнее хранилище
Кто-нибудь сталкивался с организацией внешнего хранилища для прикрепленных файлов в 1с? Задача -...

1с на сетевом хранилище
Здравствуйте, имеется сетевое хранилище D-link dns-325 и 1С 7.7 Сетевая (Бухгалтерия), два...

Хранилище значений
Привет всем! Люди, подскажите пожалуйста, первый раз сталкиваюсь с хранилищем значений, как его...

Загрузка файлов в хранилище значений
Здравствуйте, у меня такая проблема: дали задание создать БД, в которой будут кнопки &quot;Загрузить...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru