Форум программистов, компьютерный форум, киберфорум
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
77 / 17 / 4
Регистрация: 03.05.2018
Сообщений: 2,207
1
1C 8.x

Изменить табличную часть

13.03.2019, 10:07. Просмотров 422. Ответов 8
Метки нет (Все метки)

Доброго времени суток! Как это сделать ругается на количество.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
&НаКлиенте
Процедура Изменить(Команда)
    ИзменитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ИзменитьНаСервере()
    //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |   ПриходнаяНакладнаяМатериалы.Количество,
    |   ПриходнаяНакладнаяМатериалы.Ссылка
    |ИЗ
    |   Документ.ПриходнаяНакладная.Материалы КАК ПриходнаяНакладнаяМатериалы
    |ГДЕ
    |   ПриходнаяНакладнаяМатериалы.Ссылка = &Ссылка";
    
    Запрос.УстановитьПараметр("Ссылка", Документ);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ДокументОбъект = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
        ДокументОбъект.Материалы.Количество = 12; 
        ДокументОбъект.Записать();
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    
    
КонецПроцедуры
Изменить табличную часть
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
13.03.2019, 10:07
Ответы с готовыми решениями:

Звуковой сигнал при добавлении строки в табличную часть
Всем доброго времени суток. Недавно клиент тут пожелал, что бы в момент когда он сканером штрихкода...

Заполнить табличную часть
Столкнулся с такой вот проблемой, что нужно заполнить табличную часть всеми сотрудниками, что есть...

Заполнить Табличную часть из Регистра
Здравствуйте! У нас есть документ, с табличной частью, допустим ТОвары и Количество, и реквизит...

1С 8.0 Добавление в табличную часть документа
Конструкция: Доставка = Документы.Доставка.СоздатьДокумент();...

8
77 / 17 / 4
Регистрация: 03.05.2018
Сообщений: 2,207
13.03.2019, 14:13  [ТС] 2
Помогли.
1C
1
2
3
4
5
6
7
8
9
10
    Число = 0;
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
           ДокументОбъект = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
           ДокументОбъект.Материалы[Число].Количество = 777;
           Число = Число + 1;
           ДокументОбъект.Записать();
          
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
0
1200 / 786 / 270
Регистрация: 16.01.2015
Сообщений: 3,126
13.03.2019, 14:16 3
byte777, Конкретную ошибку приведите.
В запросе не вижу где присваивается значение переменной Документ
1C
1
Запрос.УстановитьПараметр("Ссылка", Документ)
это раз
Вот это
1C
1
2
3
4
5
6
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ДокументОбъект = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
        ДокументОбъект.Материалы.Количество = 12; 
        ДокументОбъект.Записать();
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
Точно не работает. ДокументОбъект.Материалы - это ТЧ, посмотрите как надо перебирать ТЧ или обращаться к строке
0
77 / 17 / 4
Регистрация: 03.05.2018
Сообщений: 2,207
13.03.2019, 14:24  [ТС] 4
Хотя так не работает, необходимо посчитать количество строк в табличной части а как это сделать?
0
1200 / 786 / 270
Регистрация: 16.01.2015
Сообщений: 3,126
13.03.2019, 14:27 5
Цитата Сообщение от byte777 Посмотреть сообщение
необходимо посчитать количество строк в табличной части а как это сделать?
Это и есть задача?
1C
1
КоличествоСтрокТЧ = Объект.Материалы.Количество()
И все, никаких запросов
0
77 / 17 / 4
Регистрация: 03.05.2018
Сообщений: 2,207
13.03.2019, 14:30  [ТС] 6
polax, а она на сервере не сработает как я понимаю. Необходимо будет запросом думаю так.
0
1200 / 786 / 270
Регистрация: 16.01.2015
Сообщений: 3,126
13.03.2019, 14:38 7
byte777, Все работает и на сервере но никто не мешает сделать это и на клиенте. Делать запрос для определения количества строк - это как с Ярославского вокзала Москвы ехать на Ленинградский вокзал даже не через Царицино, скорее через Рязань. Можно конечно, но кому в здравом уме придет такая идея?
0
77 / 17 / 4
Регистрация: 03.05.2018
Сообщений: 2,207
13.03.2019, 14:48  [ТС] 8
polax,
{Обработка.ИзменениеТабличнойЧ асти.Форма.Форма.Форма(27)}: Поле объекта не обнаружено (Материалы)
КоличествоСтрок = Объект.Материалы.Количество();

Поле объекта не обнаружено.
0
1200 / 786 / 270
Регистрация: 16.01.2015
Сообщений: 3,126
13.03.2019, 14:52 9
byte777, Делаете все это не в форме документа. "Обработка.ИзменениеТабличнойЧ асти" - об этом не было сказано ни слова. Как вы определяете какой документ вам нужен? В обработке есть поле ввода с документом? Берите это поле (предполагаю это поле "Документ")
1C
1
Объект.Документ.Материалы.Количество()
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
13.03.2019, 14:52

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Вставка колонки в табличную часть списка
Ситуация - нужно вставить колонку, отвечающую показывающую остатки в форму списка справочника...

Програмно добавить объект в табличную часть
Я хочу програмно добавить объект в табличную часть, в которой реквизитом есть ссылка на справочник....

Добавление колонки в табличную часть формы
Добрый день! Подскажите, пожалуйста, как добавить поле к табличной части формы? При этом, поле...

Вывести табличную часть в параметры макета
Здравствуйте! Есть табличная часть с тремя полями (Дата, ВремяНач, ВремяКон) и макет в виде...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.