Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.82/11: Рейтинг темы: голосов - 11, средняя оценка - 4.82
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 483
1
1C 8.x

На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений"

07.05.2014, 13:49. Просмотров 1955. Ответов 11
Метки нет (Все метки)

1С.8.0 На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений". При открытии формы в табличном поле должны отображаться товары с указанием средних значений количества, в котором они были получены (из документа "ПоступлениеТоваров"). Для правильного отображения использовать:
1C
1
2
ЭлементыФормы.ТабличноеПоле2.Значение=Результат.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам);
ЭлементыФормы.ТабличноеПоле2.СоздатьКолонки();
Ну есть одно НО. На этом справочнике я уже делал запрос. Вот он:


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
Процедура ПриОткрытии()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
|   ПродажаТоваровТовары.Товар,
|   СРЕДНЕЕ(ПродажаТоваровТовары.Цена) КАК Цена
|ИЗ
|   Документ.ПродажаТоваров.Товары КАК ПродажаТоваровТовары
|
|СГРУППИРОВАТЬ ПО
|   ПродажаТоваровТовары.Товар
|
|УПОРЯДОЧИТЬ ПО
|   Цена УБЫВ";
 
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
 
Пока Выборка.Следующий() Цикл
 
    
 
КонецЦикла;
ЭлементыФормы.ТабличноеПоле1.Значение=Результат.Выгрузить();
ЭлементыФормы.ТабличноеПоле1.СоздатьКолонки();
//ЭлементыФормы.ТабличноеПоле2.Значение=Результат.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам);
//ЭлементыФормы.ТабличноеПоле2.СоздатьКолонки();
 
    // Вставить содержимое обработчика.
КонецПроцедуры
Добавлено через 21 час 1 минуту
Кто сможет осилить?
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
07.05.2014, 13:49
Ответы с готовыми решениями:

Для документа "ПродажаТоваров" на форму списка добавить "ПолеВвода"
Для документа "ПродажаТоваров" на форму списка добавить "ПолеВвода" с типом...

Как программно добавить таблицу значений (тип "ДанныеФормыКоллекция") на форму
Подскажите позжайлуста в чем ошибка?:wall: &НаСервере Процедура ДобавитьТаблицуНаСервере() ...

Не получается скопировать выделенные строчки из справочника "Сотрудники" в форму "Выбор"
Здравствуйте! У меня опыта работы с 1С мало поэтому хотел попросить помощи у более опытных коллег....

Динамический список формы списка документа "Реализация товаров и услуг"
Добрый день ув. форумчане , решил визуально улучшить работу в 1с что бы идентичные договора...

11
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
07.05.2014, 14:51 2
Fenlou, Так среднюю цену или количество по товару надо вывести?
Примерно так
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
ТабличноеПоле2.Колонки.Добавить("Товары",
Новый ОписаниеТипов("СправочникСсылка.Товары"), 
"Товары");
ТабличноеПоле2.Колонки.Добавить("Количество",
Новый ОписаниеТипов("Число",,,Новый КвалификаторыЧисла(15,3)), 
"Количество");
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               |    ПродажаТоваровТовары.Товар КАК Товары,
               |    ПродажаТоваровТовары.Количество КАК Количество
               |ИЗ
               |    Документ.ПродажаТоваров.Товары КАК ПродажаТоваровТовары
               |
               |СГРУППИРОВАТЬ ПО
               |    ПродажаТоваровТовары.Товар,
               |    ПродажаТоваровТовары.Количество
               |
               |УПОРЯДОЧИТЬ ПО
               |    Количество УБЫВ
               |ИТОГИ
               |    СРЕДНЕЕ(Количество)
               |ПО
               |    Товары";
 
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
СтрокиДеревоЗначений = ТабличноеПоле2.Строки;    
Пока Выборка.Следующий() Цикл
    
    НоваяСтрока = СтрокиДеревоЗначений.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, Выборка);
 
КонецЦикла;
 
ЭлементыФормы.ТабличноеПоле2.СоздатьКолонки();
1
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 483
07.05.2014, 16:02  [ТС] 3
Цитата Сообщение от SPR1TE89 Посмотреть сообщение
Примерно так
из документа "ПоступлениеТоваров"

Добавлено через 3 минуты
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
ТабличноеПоле2.Колонки.Добавить("Товары",
Новый ОписаниеТипов("СправочникСсылка.Товары"), 
"Товары");
ТабличноеПоле2.Колонки.Добавить("Количество",
Новый ОписаниеТипов("Число",,,Новый КвалификаторыЧисла(15,3)), 
"Количество");
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               |    ПоступлениеТоваровТовары.Товар КАК Товар,
               |    ПоступлениеТоваровТовары.Количество КАК Количество
               |ИЗ
               |    Документ.ПоступлениеТоваров.Товары КАК ПоступлениеТоваровТовары
               |
               |СГРУППИРОВАТЬ ПО
               |    ПоступлениеТоваровТовары.Товар,
               |    ПоступлениеТоваровТовары.Количество
               |
               |УПОРЯДОЧИТЬ ПО
               |    Количество УБЫВ
               |ИТОГИ
               |    СРЕДНЕЕ(Количество)
               |ПО
               |    Товар";
 
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
СтрокиДеревоЗначений = ТабличноеПоле2.Строки;   
Пока Выборка.Следующий() Цикл
    
    НоваяСтрока = СтрокиДеревоЗначений.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, Выборка);
 
КонецЦикла;
 
ЭлементыФормы.ТабличноеПоле2.СоздатьКолонки();
Сделал так, но наименование товара не показывается, но считает правильно!
0
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
07.05.2014, 16:02 4
Fenlou, поменяй в запросе текст - вместо ПродажаТоваровТовары напиши ПоступлениеТоваровТовары.
1
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 483
07.05.2014, 16:03  [ТС] 5
вот
0
Миниатюры
На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений"  
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
07.05.2014, 16:05 6
Fenlou,
Цитата Сообщение от Fenlou Посмотреть сообщение
ПоступлениеТоваровТовары.Товар КАК Товар
Псевдоним не Товар, а Товары
1
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 483
07.05.2014, 16:09  [ТС] 7
Цитата Сообщение от Fenlou Посмотреть сообщение
ТабличноеПоле2.Колонки.Добавить("Товары", Новый ОписаниеТипов("СправочникСсылка.Товары"), "Товары"); ТабличноеПоле2.Колонки.Добавить("Количество", Новый ОписаниеТипов("Число",,,Новый КвалификаторыЧисла(15,3)), "Количество");
как без этого можно обойтись? по другому как-нибудь?
0
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 483
07.05.2014, 16:10  [ТС] 8
А так спасибо все получается
0
Миниатюры
На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений"  
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
07.05.2014, 16:11 9
Fenlou, Это просто создание колонок на форме твоего дерево значений. Да можно обойтись создай колонки у дерево значений, и проставь типы Товары - справочникссылка.товары, и количество число(15,3)
0
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 483
07.05.2014, 16:21  [ТС] 10
Цитата Сообщение от SPR1TE89 Посмотреть сообщение
Это просто создание колонок на форме твоего дерево значений. Да можно обойтись создай колонки у дерево значений, и проставь типы Товары - справочникссылка.товары, и количество число(15,3)
еще тут это использовать надо
1C
1
2
ЭлементыФормы.ТабличноеПоле2.Значение=Результат.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам);
ЭлементыФормы.ТабличноеПоле2.СоздатьКолонки();
Добавлено через 20 секунд
может как раз через это?

Добавлено через 1 минуту
Цитата Сообщение от SPR1TE89 Посмотреть сообщение
(15,3)
почему именно эти цифры?

Добавлено через 5 минут
сам сделал
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               |    ПоступлениеТоваровТовары.Товар КАК Товары,
               |    ПоступлениеТоваровТовары.Количество КАК Количество
               |ИЗ
               |    Документ.ПоступлениеТоваров.Товары КАК ПоступлениеТоваровТовары
               |
               |СГРУППИРОВАТЬ ПО
               |    ПоступлениеТоваровТовары.Товар,
               |    ПоступлениеТоваровТовары.Количество
               |
               |УПОРЯДОЧИТЬ ПО
               |    Количество УБЫВ
               |ИТОГИ
               |    СРЕДНЕЕ(Количество)
               |ПО
               |    Товары";
 
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
СтрокиДеревоЗначений = ТабличноеПоле2.Строки;   
Пока Выборка.Следующий() Цикл
    
 
КонецЦикла;
ЭлементыФормы.ТабличноеПоле2.Значение=Результат.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам);
ЭлементыФормы.ТабличноеПоле2.СоздатьКолонки();
0
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
07.05.2014, 16:26 11
Fenlou, Пробуй, стандартные цифры для количества.Необязательные параметры.
1
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 483
07.05.2014, 16:32  [ТС] 12
еще один запрос плиз
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
07.05.2014, 16:32

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

1С 8.3 Розница 2.1.4.9 "Текущая цена розницы" и "Остаток" в форме элемента "Номенклатура"
Есть ли готовое решение, можно через внешнюю форму нужно контроль "Текущая цена розницы" и...

1С 8.2 Розница - "Текущая цена розницы", "Остаток" в форме элемента "Номенклатура"
Всем добрый день! Нужна помощь. В Форму элемента "Номенклатура" нужно добавить два поля с выводом...

ЗуП -> добавление картинки в форму списка "справочника сотрудники"
Здравствуйте уважаемые программисты . приму любой совет от знающих людей . стоит задача в ЗуП...

Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".
МОЙ ВОЗРАСТ. Для заданого 0&lt;=n&lt;=200.Расматриваемого как возраст человека,вывести фразу вида: &quot;Мне...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.