Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
Заблокирован
1
1C 8.x (тонкий)

Форма списка управляемая, базовые моменты

09.06.2014, 19:31. Просмотров 1062. Ответов 3
Метки нет (Все метки)


Возможно ли на управляемой форме списка создать новую табличную часть с данными.
Или можно создать некое подобие табличной части, но только элементы формы и без данных?
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
09.06.2014, 19:31
Ответы с готовыми решениями:

Управляемая форма. Не работает форма списка документа
Здравствуйте! Создал форму списка документа, сделал ее основной формой списка. В конфигураторе все...

Управляемая форма.ОсновныеНачисленияСотрудникОбработкаВыбора
Вопрос по программированию управляемого интерфейса.Есть книжка "Сборник задач для подготовки к...

Управляемая форма обработки с компонентами, создаваемыми программно
Изучаю программирование. Что прочесть, чтобы сделать управляемую форму с компонентами, создаваемыми...

Отбор помеченных на удаление в иерархическом справочнике управляемая форма
Добрый день. Устанавливаю отбор в справочнике Пользователи, при открытии формыВыбора выдает только...

3
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
09.06.2014, 22:19 2
Насколько я понимаю, в тонкой форме даже в конфигураторе нет контролов. Одна схема.
0
62 / 60 / 0
Регистрация: 02.10.2012
Сообщений: 448
10.06.2014, 15:46 3
Цитата Сообщение от Gokusa Посмотреть сообщение
Возможно ли на управляемой форме списка создать новую табличную часть с данными
хоть мильон 9вконф игураторе0, тока нать будет програмно управлять открытием нужной
0
Шизофреник
360 / 363 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
10.06.2014, 17:00 4
собсно можно и программно напилить как реквизиты формы, так и элементы завязанные(либо не завязанные) на них

Добавлено через 6 минут
вдруг пригодится:
добавляем реквизит формы, создаем элемент формы, связываем их меж собой, заливаем в реквизит [например высасаное запросом(ТЗ)], назначаем обработчик событию "Выбор" для созданного элемента формы

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
&НаСервере
Процедура СотворитьТЗПрограммно()
......
ТЗ = Запрос.Выполнить().Выгрузить();
 
    ТипРеквизита = Новый Массив;
    ТипРеквизита.Добавить(Тип("ТаблицаЗначений"));
    ОписаниеТиповДляРеквизита = Новый ОписаниеТипов(ТипРеквизита);
    ТаблЗначений = Новый РеквизитФормы("ТЗ_Формы", ОписаниеТиповДляРеквизита);
    ДобавляемыеРеквизиты = Новый Массив;
    ДобавляемыеРеквизиты.Добавить(ТаблЗначений);
    ИзменитьРеквизиты(ДобавляемыеРеквизиты);
    Выб = ЭтотОбъект.Элементы.Добавить("Выборка",Тип("ТаблицаФормы"),ЭтаФорма);
    Выб.ПутьКДанным = "ТЗ_Формы";
    МассивДобавляемыхРеквизитов = Новый Массив;
    Для Каждого Колонка Из ТЗ.Колонки Цикл 
        РеквизитФормы = Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "ТЗ_Формы", Колонка.Имя); 
        МассивДобавляемыхРеквизитов.Добавить(РеквизитФормы); 
    КонецЦикла;
    ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);
    Для Каждого Колонка Из ТЗ.Колонки Цикл 
        Элемент = Элементы.Добавить(Колонка.Имя, Тип("ПолеФормы"), Выб); 
        Элемент.Вид = ВидПоляФормы.ПолеВвода;
        Элемент.ПутьКДанным = "ТЗ_Формы." + Колонка.Имя;
    КонецЦикла;
    ЭтаФорма["ТЗ_Формы"].Загрузить(ТЗ);
    Элементы.Выборка.ТолькоПросмотр=Истина;
    Элементы.Выборка.РежимВыделенияСтроки = РежимВыделенияСтрокиТаблицы.Строка;
    Выб.УстановитьДействие("Выбор","ВыбратьСтрокуТЗ");
Собсно сам обработчик выбора... например вытаскиваем данные выбранной строки и, к примеру, прятаем сотворенную тз

1C
1
2
3
4
5
6
7
8
&НаКлиенте
Процедура ВыбратьСтрокуТЗ()
    Наименование = Элементы.Выборка.ТекущиеДанные.Наименование;
    Код = Элементы.Выборка.ТекущиеДанные.Код;
//..и тд.
    Эл = ЭтотОбъект.Элементы.Найти("Выборка");
    Эл.Видимость = Ложь
КонецПроцедуры
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
10.06.2014, 17:00

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Как сделать так чтобы управляемая форма не расплывалась
Суть проблемы: расплывается табличная часть в управляемой форме по высоте, когда раскрываю формы...

управляемая форма и картинка
нужно в управляемой форме загрузить картинку в поле картинки. есть форма элемента справочника и...

Как пользоваться планшетом (базовые моменты пользования)
Только что подарили планшет huaway, до этого с планшетами не работал, установил на компе hsuite,...

Не изменяется управляемая форма
проблема такая. есть УТ в ней обработка. я сделал ее как внешнюю обработку и изменил в том числе...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.