Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.69/29: Рейтинг темы: голосов - 29, средняя оценка - 4.69
Заблокирован
1

Программное создание команд в упр форме

15.09.2014, 15:17. Показов 5428. Ответов 4
Метки нет (Все метки)

Пишу
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
&НаКлиенте
Процедура Скомпоновать(Команда)
    СкомпоноватьНаСервере();
КонецПроцедуры
 
 
&НаСервере
Процедура СкомпоноватьНаСервере()
    //  УдалитьКнопки();
    ЭтаФорма.СкомпоноватьРезультат();
    НарисоватьКнопки();
КонецПроцедуры
 
 
&НаСервере
Процедура НарисоватьКнопки()
    КоличествоГруппСтрок = Результат.КоличествоУровнейГруппировокСтрок(); 
    Для Сч = 1 По Результат.КоличествоУровнейГруппировокСтрок() Цикл 
         ИмяКоманды  = "Команда" + Строка(Сч);
         ИмяЭлемента = "Кнопка" + ИмяКоманды;
         ДобавляемаяКоманда = Команды.Добавить(ИмяКоманды);
         ДобавляемаяКоманда.Действие = "СвернутьГруппировки";
         НовыйЭлемент = Элементы.Добавить(ИмяЭлемента, Тип("КнопкаФормы"), Элементы.ГруппаКнопок);
         НовыйЭлемент.ИмяКоманды = ИмяКоманды;
     КонецЦикла;
     Элементы.ГруппаКнопок.Видимость = Истина;
конецпроцедуры
при возвращении на клиента выдает ошибку
"по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: button Форма: Элемент Тип: {http://v8.1c.ru/8.2/managed-application/logform}Button"

в чем может быть проблема, я ведь никакие данные никуда не передаю.
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
15.09.2014, 15:17
Ответы с готовыми решениями:

программное создание документа по форме
Уважаемые программисты. Нужно собрать информацию по каждой БД, находящейся в каталоге …Notes/Data и...

1С 8.3 Программное создание таблицы значений на форме с условным оформлением
Добрый день! Помогите пожалуйста разобраться с УО. На управляемой форме 1С 8.3 хочу программно...

Программное заполнение счетов в документе упр приложение
Суть: конфа Бп 3.0, есть внешняя обработка в ней в процедуре на сервере создаю доки Комплектации в...

Считывание .csv файла, создание на его основе таблицы, и её программное отображение на форме
Добрый день! Столкнулся с проблемой. Пишу обработчик считывания .csv файла, создание и заполнение...

4
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,242
Записей в блоге: 1
15.09.2014, 16:16 2
Цитата Сообщение от Gokusa Посмотреть сообщение
НовыйЭлемент = Элементы.Добавить(ИмяЭлемента, Тип("КнопкаФормы"), Элементы.ГруппаКнопок);
* * * * *НовыйЭлемент.ИмяКоманды = ИмяКоманды;
Как это не передаете? Вы на сервере накидали чего-то там, чего не было на форме - получили ошибку преобразования. Не надо накидывать на сервере.
0
Заблокирован
15.09.2014, 16:48  [ТС] 3
просто в том то все и дело, что мы можем добавить команду только на сервере.
причем при повторном выполнении, форма становится перерисованной. т.е. на ней появляеются кнопки.

Добавлено через 34 секунды
форму обновит не получается.
как поступить?

Добавлено через 19 секунд
принудительно обновить форму не получается.
как поступить?
0
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,242
Записей в блоге: 1
15.09.2014, 17:13 4
Gokusa, поглядел.

ЭтаФорма.Команды.Добавить() - Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, мобильное приложение(клиент), мобильное приложение(сервер).

Отчего же только на сервере?
0
Заблокирован
15.09.2014, 18:03  [ТС] 5
да, вы правы.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
15.09.2014, 18:03

Картинки на упр форме
имеется справочник хранидищеДопИнф, который хранит файлы либо картинки. я запросом получаю те...

Работа с картинками на упр форме
Возникл анеобходимость отобразить прикрепленные ранее картинки на форме. картинки прикрепляются...

Изменить порядок обхода в упр форме
еще раз всем привет. задача: ситуация: есть упр форма. в ней две таблицы. табл1 и табл2. и...

многострочный заголовок в табл упр форме
как сделать многострочный заголовок у поля в табл упр форме. высота заголовка ни на что не...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.