Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
3 / 3 / 1
Регистрация: 18.12.2014
Сообщений: 94
1

Не вычитаются остатки

03.11.2015, 13:56. Показов 477. Ответов 4
Метки нет (Все метки)

Добрый день, Есть два документа , поступление и отгрузка товара , регистр накопления - остатки и отчёт по остаткам, так вот при отгрузке товара в отчёте кол-во товара не уменьшается а наоборот складывается.

Поступление

Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
Процедура ОбработкаПроведения(Отказ, Режим)    
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
 
    // регистр Остатки Приход
    Движения.Остатки.Записывать = Истина;
    Для Каждого ТекСтрокаПоступ Из Поступ Цикл
        Движение = Движения.Остатки.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Период = Дата;
        Движение.ТипТовара = ТекСтрокаПоступ.ТипТовара;
        Движение.Контрагент = Получатель;
        Движение.Склад = Склад;
        Движение.Длина = ТекСтрокаПоступ.Длина;
        Движение.Ширина = ТекСтрокаПоступ.Ширина;
        Движение.Высота = ТекСтрокаПоступ.Высота;
        Движение.Количество = ТекСтрокаПоступ.КоличествоМест;
        Движение.Сумма = ТекСтрокаПоступ.СуммаПозиций;
    КонецЦикла;
 
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры
 
 
Отгрузка
 
Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
 
    // регистр Остатки Расход
    Движения.Остатки.Записывать = Истина;
    Для Каждого ТекСтрокаОтгр Из Отгр Цикл
        Движение = Движения.Остатки.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
        Движение.Период = Дата;
        Движение.ТипТовара = ТекСтрокаОтгр.ТипТовара;
        Движение.Контрагент = Покупатель;
        Движение.Склад = Склад;
        Движение.Длина = ТекСтрокаОтгр.Длина;
        Движение.Ширина = ТекСтрокаОтгр.Ширина;
        Движение.Высота = ТекСтрокаОтгр.Высота;
        Движение.Количество = ТекСтрокаОтгр.КоличествоМест;
        Движение.Сумма = ТекСтрокаОтгр.СуммаПозиций;
    КонецЦикла;
 
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры



Отчёт
Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
ВЫБРАТЬ
    Остатки.ТипТовара,
    Остатки.Контрагент,
    Остатки.Склад,
    СУММА(Остатки.Длина) КАК Длина,
    СУММА(Остатки.Ширина) КАК Ширина,
    СУММА(Остатки.Высота) КАК Высота,
    СУММА(Остатки.Количество) КАК Количество,
    СУММА(Остатки.Сумма) КАК Сумма
ИЗ
    РегистрНакопления.Остатки КАК Остатки
 
СГРУППИРОВАТЬ ПО
    Остатки.ТипТовара,
    Остатки.Контрагент,
    Остатки.Склад
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.11.2015, 13:56
Ответы с готовыми решениями:

Остатки
Заработался, не могу сообразить... Пришел товар 2 раза: 1.08.2012 100 шт 25.10.2012 100 шт ...

Остатки
Скажите мне нужно очистить базу и перенести в чистую только остатки, но чистая она должна быть с...

РБ.Остатки
Не могу понять, почему у меня по полю СуммаОстатокДт нулевое значение в результате запроса....

Остатки
Есть такой вопрос, наверное, более теоретический. Дано: были в базе остатки, резервировались,...

4
Эксперт 1С
841 / 604 / 211
Регистрация: 24.07.2013
Сообщений: 2,098
03.11.2015, 14:57 2
Количество в регистре это что? похоже на измеренияе
0
3 / 3 / 1
Регистрация: 18.12.2014
Сообщений: 94
03.11.2015, 15:08  [ТС] 3
Нет, это ресурс
0
Эксперт 1С
841 / 604 / 211
Регистрация: 24.07.2013
Сообщений: 2,098
03.11.2015, 17:45 4
А почему таблицу оборотов не используешь? Она здесь более уместна.
0
2953 / 1765 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
06.11.2015, 09:33 5
Надо брать виртуальную таблицу с остатками на дату:
РегистрНакопления.Остатки.Остатки(&Дата) КАК Остатки
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.11.2015, 09:33
Помогаю со студенческими работами здесь

остатки
Я посмотрел примеры от 1С к сборнику "Специалист по платформе". Хотел бы спросить, зачем нужны эти...

Остатки по счетам
задача: есть 3 счета 012.1 , 012.2 , 10.1 во всех трех ведется учет материалов, их места...

Зависшие остатки
1С БГУ 1.0. Был перенос вводом остатков с помощью дока Корректировка регистров. После этого повисли...

Нулевые остатки
Подскажите как сделать чтоб показывали нулевые остатки в отчете. Как это можно правильно сделать?


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru