Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
1
1C 8.x

Выбор справочника

10.11.2015, 15:30. Показов 496. Ответов 8
Метки нет (Все метки)

Добрый день! Пытаюсь реализовать выбор нужного мне справочника, задача стоит если значение Перечисления выбрано АбонентИГБУ тогда Тип значения к реквизиту Лицевой Счет присваиваем Справочники.ЛицевыеСчетаАбонентов.ПолучитьФорму("ФормаСписка ")

Выдает ошибку {Обработка.ЗаявкиЕдиноеОкно.Форма.ФормаВводаЗаявки.Форма(337 )}: Преобразование значения к типу Булево не может быть выполнено
Если Перечисления.ВидЗаявки.АбонентИГБУ Тогда


Вот код
1C
1
2
3
4
5
6
7
8
9
10
11
Процедура ВидЗаявкиПриИзменении(Элемент)
    Если Перечисления.ВидЗаявки.АбонентИГБУ Тогда
        ЛицевойСчет=Справочники.ЛицевыеСчетаАбонентов.ПолучитьФорму("ФормаСписка");
    ИначеЕсли Перечисления.ВидЗаявки.АбонентГРО Тогда
        ЛицевойСчет=Справочники.ЛицевыеСчетаАбонентовГРО.ПолучитьФорму("ФормаСписка");
        ЭлементыФормы.Контрагент.Видимость=Ложь;
    ИначеЕсли Перечисления.ВидЗаявки.Прочее Тогда
        ЭлементыФормы.ЛицевойСчет.Видимость=Ложь;
        ЭлементыФормы.Контрагент.Видимость=Ложь;
    КонецЕсли; 
КонецПроцедуры
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
10.11.2015, 15:30
Ответы с готовыми решениями:

Выбор нескольких значений справочника
Добра всем!!! В 1с не силен только приступил к изучению. Так что прошу сильно не пинать))) а помочь...

Выбор был только из определенной группы справочника в поле документа
Здравствуйте! Есть справочник с предопределенными группами, как реализовать, чтобы в поле...

Выбор данных для формы документа из табличной части справочника
Всем доброго времени суток! Ситуация. Есть справочник клиентов, в котором есть табличная часть с...

Запрос на выбор всех сотрудников из справочника и документов, записанных сотрудниками в периоде
Здравствуйте. Пытаюсь решить задачу в собственной конфигурации на 1с 8.3. Суть в следующем. Создал...

8
Злой самаритянин
182 / 182 / 94
Регистрация: 24.04.2014
Сообщений: 686
10.11.2015, 15:53 2
Цитата Сообщение от Ermak27 Посмотреть сообщение
если значение Перечисления выбрано АбонентИГБУ
Где у тебя оно выбирается?
1C
1
Если [Реквизит с выбранным перечислением] = Перечисления.ВидЗаявки.АбонентИГБУ Тогда
1
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
10.11.2015, 16:06  [ТС] 3
SHIFT_969, С этой ошибкой разобрался
1C
1
2
3
4
5
6
7
8
9
10
11
Процедура ВидЗаявкиПриИзменении(Элемент)
    Если ВидЗаявки=Перечисления.ВидЗаявки.АбонентИГБУ Тогда
        ЛицевойСчет=Справочники.ЛицевыеСчетаАбонентов.ПолучитьФорму("ФормаСписка");
    ИначеЕсли ВидЗаявки=Перечисления.ВидЗаявки.АбонентГРО Тогда
        ЛицевойСчет=Справочники.ЛицевыеСчетаАбонентовГРО.ПолучитьФорму("ФормаСписка");
        ЭлементыФормы.Контрагент.Видимость=Ложь;
    ИначеЕсли ВидЗаявки=Перечисления.ВидЗаявки.Прочее Тогда
        ЭлементыФормы.ЛицевойСчет.Видимость=Ложь;
        ЭлементыФормы.Контрагент.Видимость=Ложь;
    КонецЕсли; 
КонецПроцедуры
Теперь значение ЛицевойСчет принимает Форма, а мне надо выбирать Справочники.ЛицевыеСчетаАбонентов

Добавлено через 1 минуту
ТипЗначения у реквизита ЛицевойСчет Строка
0
Злой самаритянин
182 / 182 / 94
Регистрация: 24.04.2014
Сообщений: 686
10.11.2015, 18:02 4
Ermak27, Зачем тогда форму получаешь? Тебе надо, чтобы при проверке Открывалась форма списка Справочники.ЛицевыеСчетаАбонентов, пользователь заполнял и это значение попадало в ЛицевойСчет?
0
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
10.11.2015, 20:12  [ТС] 5
SHIFT_969, выбирать значение лицевой счет
0
2953 / 1765 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
11.11.2015, 09:24 6
1C
1
2
3
4
5
ЭлементыФормы.Контрагент.Видимость=ВидЗаявки=Перечисления.ВидЗаявки.АбонентИГБУ;
ЭлементыФормы.ЛицевойСчет.Видимость=(ВидЗаявки=Перечисления.ВидЗаявки.АбонентИГБУ ИЛИ ВидЗаявки=Перечисления.ВидЗаявки.АбонентИГБУ);
Если ЭлементыФормы.ЛицевойСчет.Видимость Тогда
Справочники.ЛицевыеСчетаАбонентовГРО.ПолучитьФорму("ФормаСписка",ЭлементыФормы.ЛицевойСчет).Открыть();
КонецЕсли;
Добавлено через 49 секунд
ФормуВыбора, наверное
1
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
11.11.2015, 12:55  [ТС] 7
duk337, Не много не так. Идея такая, есть два реквизита
1) ВидЗаявки - Тип ПеречислениеСсылка.ВидЗаявки
2) ЛицевойСчет - Тип Строка

Если ВидЗаявки принимает значение АбонентИГБУ, реквизит ЛицевойСчет принимает тип Справочники.ЛицевыеСчетаАбонентов.ПолучитьФорму("ФормуВыбора ")
Если ВидЗаявки принимает значение АбонентГРО, реквизит ЛицевойСчет принимает тип Справочники.ЛицевыеСчетаАбонентовГРО.ПолучитьФорму("ФормуВыб ора")
0
2953 / 1765 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
11.11.2015, 13:21 8
и чо?

Добавлено через 24 секунды
у меня ж не реферат и не дисер

Добавлено через 1 минуту
Могу лишь посоветовать Справочники[имя]

Добавлено через 2 минуты
а поле ЛицевойСчет двух типов - это в конфигураторе. Тип уточняется методом - не помню, в синт.поме смотреть. Но поле типа "форма" - нонсенс

Добавлено через 15 минут
Цитата Сообщение от Ermak27 Посмотреть сообщение
2) ЛицевойСчет - Тип Строка
Цитата Сообщение от Ermak27 Посмотреть сообщение
ЛицевойСчет принимает тип Справочники.ЛицевыеСчетаАбонентов
в стиле "Уральских пельменей"
0
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
12.11.2015, 08:53  [ТС] 9
Нашел извращенный способ . Всем спасибо!
0
12.11.2015, 08:53
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
12.11.2015, 08:53

При выборе реквизита справочника выводить табличную часть другого справочника
Помогите пожалуйста сделать выборку. Есть справочник с реквизитами сотрудника и табличной частью с...

Обновление ссылки на документ в реквизите справочника и заполнение реквизитов элемента справочника по новой ссылке
Здравствуйте. В собственной конфигурации есть документ "Объектныйграфик" с реквизитами: ШифрОбъекта...

Запись элемента справочника из модуля объекта другого справочника
Добрый день. 1С:Предприятие 8.3. Управляемые формы. К внутреннему документу...

Подстановка значения в ТЧ Справочника из другого Справочника
Есть справочники ОКВЭД и ЮЛ. В ТЧ КодыСтатистики справочника ЮЛ первый столбец ВидКода выбирается...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru