Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.56/34: Рейтинг темы: голосов - 34, средняя оценка - 4.56
16 / 0 / 0
Регистрация: 18.09.2012
Сообщений: 17
1
1C 8.x (тонкий)

1С 8.3. Вызов функции из общего модуля на тонком клиенте

22.12.2015, 20:36. Просмотров 6251. Ответов 6
Метки нет (Все метки)

Помогите пожалуйста разобраться новичку.
Пытаюсь создать и вызвать функцию в общих модулях.
В общем модуле создан модуль общиеФункции с функциейЗаполнитьТаблицуФормы()
Содержимое:
1C
1
2
3
4
Функция ЗаполнитьТаблицуФормы()экспорт
рез = 1+1;
возврат рез;
КонецФункции
На общих функциях стоит галочка Сервер и ВызовСервера

Текст обработки:
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура Команда1(Команда)
ВыполнитьЗапросНаСервере();
КонецПроцедуры
&НаСервере
Процедура ВыполнитьЗапросНаСервере()
a = ОбщиеФункции.ЗаполнитьТаблицуФормы();
сообщить(a);
КонецПроцедуры
И теперь обработка вообще не открывается, пишет: Ошибка инициализации
модуля: Форма.Форма.Форма
по причине:
{Форма.Форма.Форма(16,7)}: Переменная не определена (ОбщиеФункции)
a = <<?>>ОбщиеФункции.ЗаполнитьТаблицуФормы();
Запускаю под тонким клиентом.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
22.12.2015, 20:36
Ответы с готовыми решениями:

Вызов процедуры из общего модуля
Создаю общий модуль &quot;РаботаСДокументами&quot; Процедура РасчитатьСумму(СТЧ) Экспорт; ...

Массив в тонком клиенте
Добрый день всем. Подскажите каким образом и где объявить массив, чтобы &quot;&amp;НаКлиенте&quot; к нему можно...

Управляемые формы. Вызов процедуры общего модуля.
Код ( (Unknown Language)): &amp;НаСервереБезКонтекста Процедура ВычислитьСебестоимостьНаСервере()...

Открыть форму на тонком клиенте
Добрый день, пытаюсь получить форму внешней обработки, но вот ПолучитьФорму работает та только на...

__________________

Записывайтесь на профессиональные курсы 1C-разработчиков
6
Эксперт 1С
840 / 604 / 211
Регистрация: 24.07.2013
Сообщений: 2,095
22.12.2015, 21:04 2
В свойствах общего модуля стоит галка "Глобальный".
0
16 / 0 / 0
Регистрация: 18.09.2012
Сообщений: 17
23.12.2015, 09:08  [ТС] 3
Галка "Глобальный" не стоит
0
Модератор
Эксперт 1С
3055 / 2749 / 515
Регистрация: 10.03.2011
Сообщений: 10,550
Записей в блоге: 1
23.12.2015, 09:47 4
Camekk, ну тогда ищи ошибки в идентификаторах (в названиях модуля, функции) и пользуйся контекстной подсказкой (ctrl+spase)
0
16 / 0 / 0
Регистрация: 18.09.2012
Сообщений: 17
23.12.2015, 10:42  [ТС] 5
По ctrl+spase выбрана функция. по F12 переходит в общиемодули. При сохранении обработки, ошибок не выдает. Не открывает обработку в режиме 1С предприятия.
Выдает сообщение Ошибка инициализации модуля: Форма.Форма.Форма
по причине:
{Форма.Форма.Форма(17,6)}: Переменная не определена (ОбщиеФункции)
a = <<?>>ОбщиеФункции.ЗаполнитьТаблицуФормы();
0
Модератор
Эксперт 1С
3055 / 2749 / 515
Регистрация: 10.03.2011
Сообщений: 10,550
Записей в блоге: 1
23.12.2015, 12:12 6
Camekk, так ты сохранил изменения? клавиша - F7

Добавлено через 3 минуты
Camekk,
Следует обратить внимание на то, что база данных может содержать до трех видов конфигураций:

Конфигурация базы данных – это конфигурация, с которой работают пользователи;
Рабочая конфигурация (основная) – это конфигурация, в которую мы можем вносить изменения, при этом пользователи могут продолжать работать;
Конфигурация поставщика – это исходная конфигурация поставщика, на основе которой обычно создаются рабочая конфигурация и конфигурация базы данных. В базе данных может быть несколько конфигураций от различных поставщиков. Поставщиком конфигурации может быть не только фирма «1С».
0
16 / 0 / 0
Регистрация: 18.09.2012
Сообщений: 17
23.12.2015, 14:23  [ТС] 7
Большое спасибо!
Обновление конфигурации по F7 помогло.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
23.12.2015, 14:23

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Получить объект на тонком клиенте
Как правильно получить объект на тонком клиенте? &amp;НаСервере Функция ПолучитьДок(Ссылка) ...

ОткрытьМодально в тонком клиенте, возможно?
Создал внешнюю обработку, и прицепил ее к документу, и в модуле объекта обработки написал такой,...

Где в 1С 8.2 в тонком клиенте отобразить итог таблицы?
Здравствуйте. Скажите пожалуйста, где в 1С 8.2 в тонком клиенте отобразить итог таблицы?

Вызов общего модуля из С-шарп
Из C# дергаю 1С. Появилась необходимость перейти с V82.COMConnector на V82.Application. При...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.