Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
1
1C 8.x

Новый Регистр

25.12.2015, 09:42. Показов 414. Ответов 14
Метки нет (Все метки)

Можете подсказать как прописать условие для регистра сведений, для документа я прописал так

1C
1
2
3
Если ЭтотОбъект.ЭтоНовый() Тогда
        Участок=ПараметрыСеанса.ГруппаТекущегоПользователя
    КонецЕсли
В Регистре не работает, выдает ошибку, как быть тогда?
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
25.12.2015, 09:42
Ответы с готовыми решениями:

Регистр сведений «Списанные материалы из эксплуатации». Почему регистр сведений, а не регистр накопления?
Существует Регистр сведений «Списанные материалы из эксплуатации». Регистр сведений предназначен...

Регистр сведений. Регистр накоплений
Здравствуйте! Нужна помощь в создании (и настройки работы) регистра сведений и регистра накопления....

Новый регистр сведений
Добрый день всем. 8.2 УТ 10.3. Необходимо создать новый регистр сведений (Непериодический), который...

Регистр сведений
Приветствую. Расскажите про регистр сведений. Не могу никак разобраться. Объясните на пальцах....

__________________

Записывайтесь на профессиональные курсы 1C-разработчиков
14
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
25.12.2015, 09:58 2
ЭтаФорма.Параметры.Ключ.Пустой()
0
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
25.12.2015, 10:15  [ТС] 3
Xomych, {РегистрСведений.ПланировщикЗаявокНаПоставкуБаллонов.Форма.Ф ормаЗаписи.Форма(4)}: Поле объекта не обнаружено (Параметры)
Если ЭтаФорма.Параметры.Ключ.Пустой() Тогда
0
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
25.12.2015, 10:18 4
У меня вот так работает
1C
1
2
3
4
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ЭтаФорма.Параметры.Ключ.Пустой();
КонецПроцедуры
0
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
25.12.2015, 10:26  [ТС] 5
Xomych, а потом как использовать в ПередЗаписью(Отказ) ?
0
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
25.12.2015, 10:28 6
1C
1
2
3
4
5
6
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    if ЭтаФорма.Параметры.Ключ.Пустой() then
        // тут твой код
    endif;  
КонецПроцедуры
0
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
25.12.2015, 10:38  [ТС] 7
Xomych, а тут как ПередОткрытием(Отказ, СтандартнаяОбработка)

Добавлено через 1 минуту
Xomych, а как подцепить к форме, что то я не понимаю

1C
1
2
3
4
5
6
7
8
9
10
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    Если НЕ ЭтаФорма.Параметры.Ключ.Пустой() Тогда
        Если Модифицированность() Тогда
            Редактор=ПараметрыСеанса.ТекущийПользователь
        КонецЕсли;
    Иначе
        Автор=ПараметрыСеанса.ТекущийПользователь
    КонецЕсли; 
КонецПроцедуры
0
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
25.12.2015, 10:49 8
А подробно можешь написать то, что ты хочешь сделать?
0
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
25.12.2015, 14:33  [ТС] 9
Xomych, Вот как у меня сделано для документов

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)   
    Если ЭтаФорма.Параметры.Ключ.Пустой() Тогда
        АбонентскийУчасток=ПараметрыСеанса.ГруппаТекущегоПользователя
    КонецЕсли  
КонецПроцедуры
 
Процедура ПередЗаписью(Отказ)     
    Если НЕ ЭтаФорма.Параметры.Ключ.Пустой() Тогда
        Если Модифицированность() Тогда
            Редактор=ПараметрыСеанса.ТекущийПользователь
        КонецЕсли;
    Иначе
        Автор=ПараметрыСеанса.ТекущийПользователь
    КонецЕсли;     
КонецПроцедуры
Аналогично мне надо сделать для Регистра сведений
0
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
25.12.2015, 16:49 10
Что такое Автор и Редактор?
0
Заблокирован
26.12.2015, 14:40 11
что надо сделать то?
верно ли я понял, что если у тебе в регистре сведений в записи не заполнены поля, то нужно их заполнить из параметров сеанса????
//////
это верно?
вообще это какое то говно по логике.
озвучьте всю задачу циликом пожалуйста
0
Эксперт 1С
840 / 604 / 211
Регистрация: 24.07.2013
Сообщений: 2,095
26.12.2015, 16:58 12
Цитата Сообщение от Gokusa Посмотреть сообщение
верно ли я понял, что если у тебе в регистре сведений в записи не заполнены поля, то нужно их заполнить из параметров сеанса????
//////
это верно?
вообще это какое то говно по логике.
Почему говно? Инициализировать объекты значениями из параметров сеанса вполне нормальная ситуация.
0
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,228
26.12.2015, 17:20  [ТС] 13
Xomych, это реквизиты
0
Заблокирован
26.12.2015, 18:16 14
Цитата Сообщение от Tklwegsd Посмотреть сообщение
Почему говно? Инициализировать объекты значениями из параметров сеанса вполне нормальная ситуация.
ситуация нормальная, но для набора регистра сведений применять такое, я думаю не айс.
я бы так не делал 100%.
во первых вероятен факт того что запись буде неуникальна, и прочее.
ну карочи смотря для чего.
может надо вообще регитстр перепроектировать и структуру конфигурации менять.
))
мне почему то кажжется, что вот именно в этом случае это не айс.
1
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
27.12.2015, 09:47 15
Цитата Сообщение от Ermak27 Посмотреть сообщение
Аналогично мне надо сделать для Регистра сведений
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    if ЭтаФорма.Параметры.Ключ.Пустой() then
        Запись.Измерение1=Справочники.СтраховыеАгенты.НайтиПоНаименованию("Петров",Истина);
    endif;  
КонецПроцедуры
 
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    if ЭтаФорма.Параметры.Ключ.Пустой() then
        ТекущийОбъект.Измерение1=Справочники.СтраховыеАгенты.НайтиПоНаименованию("Петров",Истина);
        ТекущийОбъект.Ресурс1=Справочники.Договоры.НайтиПоНаименованию("Договор Петрова",Истина);
    endif;  
КонецПроцедуры
Как это не удивительно. но я сошласен с Gokusa, имхо, в регистр сведений такое лучше не запихивать, но смотри сам
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
27.12.2015, 09:47

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Регистр остатков
Добрый день, подскажите, как в 8.2 создать регистр остатков "Остатки материалов", чтобы в плюс шло...

Регистр накопления
Здравствуйте, уважаемые 1с специалисты. Вопрос такой. У меня есть 2 регистра накопления: в одном...

Регистр Накопления 1С
Привет. Я очень мало знаю русский. Извините за этого. Как заполнить одну колонку (себестоимость) в...

Загрузить ТП в Регистр
Подскажите какой нужно поставить отбор если я загружаю с ТП в регистр (Независимый) ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.