0 / 0 / 0
Регистрация: 18.05.2016
Сообщений: 117
1

Ошибка Неверное имя колонки При добавлении колонки ТЗ

05.06.2016, 20:23. Показов 16901. Ответов 6
Метки нет (Все метки)

Народ, подскажите что не правильно, Выдет ошибку.Результат отчета помещаю в таблицу значений
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
&НаСервере
Процедура ПолучитьТЗИзМакета() Экспорт
    //Получаем Макет
    ТаблицаДанных = Новый ТаблицаЗначений();
    ТекМакет = Отчеты.ИнвентаризационнаяВедомостьТовара.ПолучитьМакет("Макет");
    Для НомерСтр = 9 По ТекМакет.ВысотаТаблицы Цикл
        
        Если НомерСтр >9 Тогда 
            ТекСтр = ТаблицаДанных.Добавить();
        КонецЕсли;
        
        Для НомерКол = 2 По ТекМакет.ШиринаТаблицы Цикл
            Яч = ТекМакет.Область(НомерСтр,НомерКол);
            Если Яч.СодержитЗначение Тогда
                ЗначениеЯч = Яч.Значение;
            Иначе
                 ЗначениеЯч = Яч.Текст;
             КонецЕсли;  
                          
             Если НомерСтр = 9 Тогда 
                ТаблицаДанных.Колонки.Добавить(ЗначениеЯч);
             Иначе 
                ТекСтр[НомерКол-2] = ЗначениеЯч;
            КонецЕсли;          
        КонецЦикла;
    КонецЦикла;
             
КонецПроцедуры
Только выдает ошибку :
{ОбщийМодуль.РаботаСоСправочниками.Модуль(91)}: Ошибка при вызове метода контекста (Добавить)
ТаблицаДанных.Колонки.Добавить(ЗначениеЯч);
по причине:
Неверное имя колонки
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
05.06.2016, 20:23
Ответы с готовыми решениями:

Значения колонки в таблице, если имя колонки - переменная
Дана таблица tbTest. В таблице колонки: Field1, Field2, Field3,Field4, Field5, Хранимая процедура...

Сreative 5.1 - при проигровании музыки работают 2 фронтальные колонки и саб, остальные колонки молчат
Здравствуйте Купил аудиосистему Сreative 5.1, поставил в комп карту SB Сreative audigy SE 5.1,...

Как проинициализировать значение колонки в grid при добавлении записи?
В grid из навигатора плюсиком "+" добавляю новую строку. Необходимо проинициализировать значения...

Составить запрос, чтобы user_id из колонки comments сравнивался с id из колонки user_personal
У меня таблица comments с колонками user_id, name и page_id и есть таблица user_personal с...

6
0 / 0 / 0
Регистрация: 18.05.2016
Сообщений: 117
05.06.2016, 20:24  [ТС] 2
Вот макет
Миниатюры
Ошибка Неверное имя колонки При добавлении колонки ТЗ  
0
0 / 0 / 0
Регистрация: 18.05.2016
Сообщений: 117
06.06.2016, 02:13  [ТС] 3
Народ, подскажите СРОЧНО. Что не правильно. Заполняют ТЗ значениями ТД. Выдает ошибку :
{ОбщийМодуль.РаботаСоСправочниками.Модуль(80)}: Ошибка при вызове метода контекста (Добавить)
ТаблицаДан.Колонки.Добавить(ИмяКол);
по причине:
Неверное имя колонки
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
&НаСервере
Процедура ПолучитьТЗИзМакета(ТабДок) Экспорт
    
    ТаблицаДан = Новый ТаблицаЗначений();
    НомерКол = 1;
    
    Пока НомерКол < 7 Цикл 
        НомерКол = НомерКол +1;
        ИмяКол = ТабДок.Область(9,НомерКол).Текст;
        ТаблицаДан.Колонки.Добавить(ИмяКол);
    КонецЦикла;
    
    Для НомерКол = 2 По 7 Цикл
        НомерСтр = 10; К = 1;
        Пока Не ПустаяСтрока(ТабДок.Область(НомерСтр,НомерКол).Текст) Цикл
            ТекстСтр = ТаблицаДан.Добавить();
            ЗничениеЯч = ТабДок.Область(НомерСтр,НомерКол).Текст; 
            ТекстСтр[НомерКол - 2] = ЗничениеЯч;
            НомерСтр = НомерСтр + 1;
        КонецЦикла;
        К = К + 1;
    КонецЦикла;        
КонецПроцедуры
0
Эксперт 1С
841 / 604 / 211
Регистрация: 24.07.2013
Сообщений: 2,098
06.06.2016, 08:17 4
Имя колонки - это ее идентификатор, и должен соответствовать требованиям написания идентификатора: состоять только из букв, цифр и знаков подчеркивания, начинаться с буквы и не содержать пробелов.
0
0 / 0 / 0
Регистрация: 18.05.2016
Сообщений: 117
06.06.2016, 09:57  [ТС] 5
Tklwegsd, Если в ячейках используется объединение это не влияет

Добавлено через 48 секунд
Tklwegsd, В отладчике смотрел значение = "Товар" ТиП строка
0
Эксперт 1С
841 / 604 / 211
Регистрация: 24.07.2013
Сообщений: 2,098
07.06.2016, 20:17 6
Цитата Сообщение от gabd_marat Посмотреть сообщение
Если в ячейках используется объединение это не влияет
По описанию ошибки вроде бы должно быть понятно, что речь не о табличном документе, а о таблице значений.

Добавлено через 6 минут
Цитата Сообщение от gabd_marat Посмотреть сообщение
В отладчике смотрел значение = "Товар" ТиП строка
Это значение чего?
0
60 / 30 / 5
Регистрация: 22.05.2012
Сообщений: 102
08.06.2016, 14:45 7
А нельзя Результат отчета на прямую выгрузить в ТЗ? Че за цирк с конями?? для чего через макет ?

Добавлено через 4 минуты
У Вас в макете наименование колонок имеет знаки препинания и пробелы, Можете попробовать их сначала удалить а потом у вас все запишется
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
08.06.2016, 14:45

Минимальный элемент каждой колонки вычесть из данной колонки(со строками работает)
#include &lt;iostream&gt; #include &lt;algorithm&gt; #include &lt;cmath&gt; using namespace std; int main()...

Макет в 3 колонки дивами. Резина центральной колонки
Подскажите. Нужен стандартный, в принципе, трёхколоночный макет для Jooml'ы. Посередине - основной...

Сортировка колонки DataGridView по значениям другой колонки
Подскажите решение проблемы. Есть Grid. Нулевая колонка (с именем NOMER) содержит цифровые...

имя колонки
подскажите пожалуйста я в ексель перечисляю имена колонок(экпорт делаю) чтобы их не писать,как...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.