Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/9: Рейтинг темы: голосов - 9, средняя оценка - 5.00
0 / 0 / 0
Регистрация: 07.06.2016
Сообщений: 4
1

Управляемая форма обработки с компонентами, создаваемыми программно

07.06.2016, 09:24. Просмотров 1831. Ответов 8
Метки нет (Все метки)


Изучаю программирование. Что прочесть, чтобы сделать управляемую форму с компонентами, создаваемыми программно?

Что я сделал:
1. Создал чистую конфигурацию
2. Создал обработку
3. Создал форму
4. Внес в модуль формы код
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
&НаСервере 
Процедура СоздатьПолеКнопок()
    ГруппаКнопок = Элементы.ГруппаКнопок;
    Для ии = 0 по 9 Цикл
        ИмяГруппы = "ГруппаКнопок"+ии;
        НоваяГруппа = Элементы.Добавить(ИмяГруппы, Тип("ГруппаФормы"), ГруппаКнопок);
        НоваяГруппа.Вид = ВидГруппыФормы.ОбычнаяГруппа;
        НоваяГруппа.Группировка = ГруппировкаПодчиненныхЭлементовФормы.Горизонтальная;
        НоваяГруппа.ОтображатьЗаголовок = Ложь;
        
        Для йй = 0 по 9 Цикл 
            ИмяКнопки = "Кнопка"+(ии*10+йй);
            НоваяКнопка = Элементы.Добавить(ИмяКнопки, Тип("КнопкаФормы"), НоваяГруппа);
            НоваяКнопка.Вид = ВидКнопкиФормы.ОбычнаяКнопка;
            НоваяКнопка.Заголовок = Прав("0"+(ии*10+йй),2);
            НоваяКнопка.ИмяКоманды = "КомандаДляКнопок";
        КонецЦикла;
    КонецЦикла;
КонецПроцедуры
 
&НаКлиенте
Процедура СоздатьКнопки(Команда)
    СоздатьПолеКнопок();
КонецПроцедуры
 
&НаКлиенте
Процедура КомандаДляКнопок(Команда)
    Кнопка = ЭтаФорма.ТекущийЭлемент;
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "Нажата "+Кнопка.Имя;
    Сообщение.Сообщить();
КонецПроцедуры
5. Сохранил конфигурацию, обновил конфигурацию базы данных
6. Начал отладку.
7. Открыл созданную обработку - там нет ничего, пустота, только крестик и кнопка еще.
Что я делаю не так?

Я надеюсь, так можно.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
07.06.2016, 09:24
Ответы с готовыми решениями:

Управляемая форма. Не работает форма списка документа
Здравствуйте! Создал форму списка документа, сделал ее основной формой списка. В конфигураторе все...

Управляемая форма.ОсновныеНачисленияСотрудникОбработкаВыбора
Вопрос по программированию управляемого интерфейса.Есть книжка "Сборник задач для подготовки к...

управляемая форма и картинка
нужно в управляемой форме загрузить картинку в поле картинки. есть форма элемента справочника и...

Форма списка управляемая, базовые моменты
Возможно ли на управляемой форме списка создать новую табличную часть с данными. Или можно создать...

8
Злой самаритянин
181 / 181 / 94
Регистрация: 24.04.2014
Сообщений: 686
07.06.2016, 10:00 2
vermazar, в обработке твоя форма выбрана как основная форма?
Имя команды ты присвоил, а сама команда существует?
Проставь свойство Видимость на всякий случай.
0
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,401
07.06.2016, 10:37 3
Всё что ты создаёшь программно, не сохраняется в конфигураторе
0
0 / 0 / 0
Регистрация: 07.06.2016
Сообщений: 4
07.06.2016, 21:12  [ТС] 4
Поле объекта не обнаружено (ГруппаКнопок)
0
162 / 158 / 62
Регистрация: 28.09.2013
Сообщений: 293
07.06.2016, 21:34 5
vermazar, добавьте на форму обычную группу с именем ГруппаКнопок или также программно её создайте.
ГруппаКнопок = Элементы.ГруппаКнопок; <- вы её используете а её не сушествует.
0
0 / 0 / 0
Регистрация: 07.06.2016
Сообщений: 4
07.06.2016, 22:05  [ТС] 6
Если создать обычную группу ГруппаКнопок:

{Обработка.Обработка1.Форма.Форма.Форма(16)}: Ошибка при установке значения атрибута контекста (ИмяКоманды)
НоваяКнопка.ИмяКоманды = "КомандаДляКнопок";
по причине:
Недопустимое значение
0
162 / 158 / 62
Регистрация: 28.09.2013
Сообщений: 293
07.06.2016, 22:29 7
vermazar, скиньте обработку, просто интересно посмотреть =). Я себе верхний код скопировал и все там работает нормально.
0
Модератор
Эксперт 1С
3053 / 2747 / 514
Регистрация: 10.03.2011
Сообщений: 10,522
Записей в блоге: 1
08.06.2016, 00:37 8
vermazar, потому что команда не создана с именем
Цитата Сообщение от vermazar Посмотреть сообщение
"КомандаДляКнопок"
0
0 / 0 / 0
Регистрация: 07.06.2016
Сообщений: 4
08.06.2016, 06:45  [ТС] 9
Понял ошибку. Я не добавлял команду "КомандаДляКнопок"
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
08.06.2016, 06:45

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Как сделать так чтобы управляемая форма не расплывалась
Суть проблемы: расплывается табличная часть в управляемой форме по высоте, когда раскрываю формы...

Отбор помеченных на удаление в иерархическом справочнике управляемая форма
Добрый день. Устанавливаю отбор в справочнике Пользователи, при открытии формыВыбора выдает только...

Управляемая форма обработки
Есть обработка (не внешняя, а в конфигурации), есть её форма. 2 процедуры: &amp;НаКлиенте...

Не изменяется управляемая форма
проблема такая. есть УТ в ней обработка. я сделал ее как внешнюю обработку и изменил в том числе...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.