Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.69/13: Рейтинг темы: голосов - 13, средняя оценка - 4.69
4 / 4 / 4
Регистрация: 12.07.2011
Сообщений: 533
1

Не изменяется значение параметра в варианте отчета на СКД

01.06.2017, 10:38. Просмотров 2641. Ответов 5
Метки нет (Все метки)

Здравствуйте. В Собственной конфигурации на 1С 8.3 есть отчет в СКД и 2 варианта - Вариант1 Вариант2(не важно как называются). Параметр отчета - ШифрОбъекта. Выбираю значение параметра, вариант1 - формируется. Выбираю Вариант2 для этого же значения - тоже все норм. Затем возвращаюсь к варианту1, меняю ШифрОбъекта на другое значение и в варианте 2 остается предыдущее значение параметра ШифрОбъекта. Как сделать, чтобы в обоих вариантах было новое значение? помогите пожалуйста.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
01.06.2017, 10:38
Ответы с готовыми решениями:

Как найти среднее значение параметра, который изменяется через бегунок
Подскажите как можно найти среднее значение параметра, который изменяется через бегунок. Т.е в...

при формировании отчёта в режиме 1 с выявляется ошибка метода контекста.Недопустимое значение параметра (параметр №1)
Здраствуйте я новенький в среде 1 с поэтому могу задавать глупые вопросы.При программировании в...

Вывод отчета на скд
Есть отчет. Внешний вид: http://upload.akusherstvo.ru/image629368.jpg Настройки:...

Расшифровка отчета на СКД
Есть отчет на скд. Внешний вид отчета: Оборудование| Нач остаток| Приход | Расход| Кон остаток ...

5
Форумчанин
Эксперт 1С
3018 / 1945 / 520
Регистрация: 25.06.2009
Сообщений: 6,840
02.06.2017, 12:00 2
jediAlex, думаю, только программно. Настройки отчета СКД автоматически сохраняются для каждого из вариантов.
0
4 / 4 / 4
Регистрация: 12.07.2011
Сообщений: 533
02.06.2017, 13:48  [ТС] 3
подскажите, как это можно сделать. Такой способ:
1C
1
2
3
4
5
6
Процедура ПриОткрытии()
   ПараметрСКД = КомпоновщикНастроек.Настройки.ПараметрыДанных.
                                 Элементы.Найти("ИмяПараметра")
   ПараметрСКД.Использование = Истина;
   ПараметрСКД.Значение  = Значение;
КонецПроцедуры
мне не подойдет, т.к. значение параметра пользователь сам выбирает в одном варианте отчета и это же выбранное значение надо передать в другой вариант
0
Форумчанин
Эксперт 1С
3018 / 1945 / 520
Регистрация: 25.06.2009
Сообщений: 6,840
02.06.2017, 15:05 4
jediAlex, вообще, как вариант - убрать этот параметр из пользовательских настроек отчета СКД. Вынести на форму отчета новое поле, ПриИзменении() которого прописать выставление значение параметра отчета, как вы написали выше.
0
4 / 4 / 4
Регистрация: 12.07.2011
Сообщений: 533
02.06.2017, 16:26  [ТС] 5
сделал так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаСервере
Процедура ОбъектПриИзмененииНаСервере()
    // Вставить содержимое обработчика.
ПараметрСКД = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Объект");
   ПараметрСКД.Использование = Истина;
   ПараметрСКД.Значение  = Элементы.Объект;
    
КонецПроцедуры
 
&НаКлиенте
Процедура ОбъектПриИзменении(Элемент)
    ОбъектПриИзмененииНаСервере();
    
КонецПроцедуры
Параметр "Объект" убрал из пользовательских настроек, добавил реквизит "Объект" в отчет. При попытке сформировать отчет с выбранным значением объекта система ругнулась:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'v':
форма: Элемент
имя: {http://v8.1c.ru/8.2/uobjects}v
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'settings':
форма: Элемент
имя: {http://v8.1c.ru/8.1/data-composition-system/settings}settings
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'item':
форма: Элемент
имя: {http://v8.1c.ru/8.1/data-composition-system/core}item
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'value':
форма: Элемент
имя: {http://v8.1c.ru/8.1/data-composition-system/core}value
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ПолеФормы'
что не так?

Добавлено через 29 секунд
как задать отображение?

Добавлено через 14 минут
переделал так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
НаСервере
Процедура ОбъектПриИзмененииНаСервере()
    // Вставить содержимое обработчика.
ПараметрСКД = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Объект");
   ПараметрСКД.Использование = Истина;
   ПараметрСКД.Значение  = Отчет.Объект;
    
КонецПроцедуры
 
&НаКлиенте
Процедура ОбъектПриИзменении(Элемент)
    ОбъектПриИзмененииНаСервере();
    
КонецПроцедуры
Ошибка исчезла, но теперь отчет не формируется - пустой отчет получается, данных нет...

Добавлено через 38 минут
пробовал и так:
1C
1
   ПараметрСКД.Значение  = Отчет.Объект.Ссылка;
не помогает...та же ситуация...
0
580 / 367 / 63
Регистрация: 22.07.2009
Сообщений: 875
Записей в блоге: 4
12.06.2017, 17:23 6
Он при выборе варианта подменяет настройки. Не спасет перехватчик "ПриИзменении"

Варианты (По возрастанию затрат программиста)

Вариант 1 : Отказаться от сего извращения - пусть пользователи при смене варианта меняют и параметр ручками
Вариант 2 : Если можно - перенести параметр в отбор - сделать это и использовать параметры открытия формы (а именно "отбор")
Вариант 3 : Убрать параметр в "недоступные", в модуль отчета или модуль формы добавить реквизит "Объект" и в модуле отчета в процедуре ПриКомпоновкеДанных, прописать указанный выше код
1C
1
2
3
ПараметрСКД = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Объект");
   ПараметрСКД.Использование = Истина;
   ПараметрСКД.Значение  = Отчет.Объект;
Сложность: нужно будет делать сохранение зашрузку "объекта" из настроек
Вариант 4 : (для экстра извращенцев) - написать собственное хранилище настроек
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
12.06.2017, 17:23

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Настройка отчета на СКД
Здравствуйте! :) Есть отчет. В нем к примеру 2 ресурса - Количество и сумма. В настройках скд...

Настройка отчёта в СКД
Подскажите пожалуйста как в СКД,для пустых строк сделать вывод "0" И можно ли скрыть...

Расшифровка отчета на СКД
Добрый день.Есть отчет такого вида: Номенклатура|Характеристика|Цена|Количество. По клику на...

Вывод отчета в СКД
есть отчет годовой план. колнки месяцы - тип справочник с номером соотв. порядку месяца в году....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.