Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
0 / 0 / 0
Регистрация: 25.11.2013
Сообщений: 32
1

Выполнение внешней обработки

06.12.2017, 10:31. Показов 585. Ответов 1
Метки нет (Все метки)

Была выгружена обработка с ЗУП 2,5, подогнали все данные под ЗУП 3.1, загрузили в "дополнительные отчеты и обработки", однако при нажатии на выполнить, форма не открывается.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
    ПараметрыРегистрации.Вставить("Наименование", "Выгрузка");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    ПараметрыРегистрации.Вставить("Информация", "Выгрузка");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд,
    "Выгрузка",
    "1",
    "ОткрытиеФормы",
    Истина,"");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    Возврат ПараметрыРегистрации;
КонецФункции
 
Функция ПолучитьТаблицуКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции
 
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры
 
Процедура ВыполнитьКоманду(ИдентификаторКоманды) Экспорт
Форма = ПолучитьФорму("ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма");
Форма.Открыть();
Сообщить ("Выполняется команда");  
КонецПроцедуры
Помогите, пожалуйста!
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
06.12.2017, 10:31
Ответы с готовыми решениями:

Открытие внешней обработки
Доброго времени суток. Я понимаю, что этот вопрос мог тут уже всех задолбать. К сожалению, понять...

ПолучитьФорму внешней обработки
Есть внешняя обработка("Форма"),в ней форма-"Форма".Подключенная через внешние формы и...

Создание внешней обработки 2.0
В документе Отчет о розничных продажах на основании уже вбитой номенклатуры по обработке заполнить...

Разработка внешней обработки ЗаявкаКассовыйРасход
Подскажите как узнать "программное имя" поля: При работе с приложенной внешней обработкой можно...

1
Тест
Эксперт 1С
381 / 162 / 56
Регистрация: 26.02.2010
Сообщений: 1,239
06.12.2017, 16:03 2
Форма из обычных форм не открываются в управляемых.
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.12.2017, 16:03

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Получить данные из внешней обработки
Добрый день! Помогите начинающему... Есть внешняя обработка с несколькими реквизитами. Часть из...

Обращение к реквизиту из внешней обработки
Как обратиться к реквизиту документа из внешней обработки?

Печать своего отчета из внешней обработки
Добрый день. Необходимо написать обработку, из которой будет печататься отчет. Делаю первый раз и...

Настройка подключения внешней обработки в самописке
Всем привет. не знаю как правильно назвать тему ). пишу с нуля. добавил документы, создал внешнею...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.