Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.73/11: Рейтинг темы: голосов - 11, средняя оценка - 4.73
jediAlex
4 / 4 / 4
Регистрация: 12.07.2011
Сообщений: 526
1

Отправка таблицы в сообщении по электронной почте

03.12.2018, 12:00. Просмотров 2166. Ответов 2
Метки нет (Все метки)

Здравствуйте. В собственной конфигурации сделал обработку с ТЧ. Структура обработки во вложении. Суть в том, чтобы получить распределение трудозатрат по всем активным объектам проектирования для выбранного подразделения и затем выбранному сотруднику этого подразделения отправить полученные данные в виде таблицы - записать данные ТЧ обработки в письмо в виде таблицы. Делал отправку так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
&НаСервере
Процедура ОтправитьСтатистикуОтветственномуНаСервере()
    // Вставить содержимое обработчика.
    Если ЗначениеЗаполнено(Ответственный)  И Объект.СтатистикаПоОбъектам.Количество()>0 Тогда
    Почта = Новый ИнтернетПочта;
Попытка
    Почта.Подключиться(ПолучитьПрофиль());
Исключение
    Сообщить(ОписаниеОшибки()); 
    Возврат;
КонецПопытки;
Сообщение = Новый ИнтернетПочтовоеСообщение;
Сообщение.Отправитель = ПараметрыСеанса.Сотрудник.ЭлПочта;
Сообщение.ИмяОтправителя = ПараметрыСеанса.Сотрудник.Наименование;
Сообщение.Получатели.Добавить(Ответственный.ЭлПочта);
Сообщение.Тема ="Распределение трудозатрат подразделения "+Объект.Подразделение+" по активным объектам"; 
//Текст = Сообщение.Тексты.Добавить("Необходимо выдать задания:");
нТекст ="<body><table width="+Символ(34)+"100%"+Символ(34)+ " border="+Символ(34)+"1"+Символ(34)+ " cellpadding="+Символ(34)+"4"+Символ(34)+ " cellspacing="+Символ(34)+"0"+Символ(34)+">"+"<tr>"+ " <th>Объект</th><th>ВыделеноПоРаспредВедомости</th><th>РаспределеноПодразделением</th><th>ДоступноДляПланирования</th><th>СписаноПодразделением</th>"+ "</tr>";
  // <caption>Изменение добычи ресурсов по годам</caption>";
Для Каждого Стр Из объект.СтатистикаПоОбъектам Цикл    
нТекст = нТекст+"<tr><td>"+Стр.Объект+"</td><td>"+Стр.ВыделеноПоРаспредВедомости+"</td><td>"+ Стр.РаспределеноПодразделением+"</td><td>"+Стр.ДоступноДляПланирования+"</td><td>"+Стр.СписаноПодразделением+"</td></tr>"; 
КонецЦикла;
//нТекст = СтрЗаменить(нТекст,"По объекту:",Символы.ПС+"По объекту:");
Текст = Сообщение.Тексты.Добавить("</table></body>");
Текст.ТипТекста = ТипТекстаПочтовогоСообщения.HTML;
Попытка
    // Пытаемся послать письмо
    Почта.Послать(Сообщение);
Исключение
    Сообщить(ОписаниеОшибки()); 
    Возврат;
    Почта.Отключиться();
КонецПопытки;       
КонецЕсли;
КонецПроцедуры
т.е. я в сообщении попытался сверстать таблицу на HTML. На выходе получаю пустое письмо только с заполненной темой. Что не так? помогите пожалуйста. Во вложениях структура обработки и что должно быть в письме.
0
Миниатюры
Отправка таблицы в сообщении по электронной почте   Отправка таблицы в сообщении по электронной почте  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.12.2018, 12:00
Ответы с готовыми решениями:

Отправка счетов по электронной почте
Есть ли обработка для отправки счета по электронной почте из 1С Бухгалтерия 8? Или пример как это...

Отправка по электронной почте
При попытке отправить сообщение возникает SMTPExeption public string MailToAddress =...

Отправка файлов по электронной почте
Здравствуйте! Как с помощью c# отправить несколько(именно не один, а несколько) прикреплённых к...

Отправка сообщения по электронной почте
Мне необходимо написать скрипт, который отправляет сообщение по электронной почте в виде текстового...

2
Xomych
849 / 648 / 111
Регистрация: 01.11.2012
Сообщений: 2,376
03.12.2018, 14:24 2
1C
1
2
3
Текст = Сообщение.Тексты.Добавить();
Текст.ТипТекста = ТипТекстаПочтовогоСообщения.HTML;
Текст.Текст = нТекст;
Ну или
1C
1
 Сообщение.Тексты.Добавить(нТекст,ТипТекстаПочтовогоСообщения.HTML)
1
jediAlex
4 / 4 / 4
Регистрация: 12.07.2011
Сообщений: 526
03.12.2018, 14:32  [ТС] 3
спасибо огромное)) ошибся в мелочи))) все красиво все как надо работает))
0
03.12.2018, 14:32
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
03.12.2018, 14:32

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Программная отправка текста по электронной почте
Пока не получается программно отправить текстовое письмо по электронной почте. Например, при...

Отправка документа по электронной почте на python 3
Здравствуйте уважаемые форумчане столкнулся с такой проблемой как отправить документ по электронной...

Отправка текстового файла по электронной почте
Как программно отправить по электронной почте текстовый файл, созданный в программе?

Отправка многострочного письма по электронной почте
Как отправить письмо так, чтобы оно было не одной сплошной строкой, а несколькими. Т.е. строка...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.