2 / 2 / 0
Регистрация: 04.03.2018
Сообщений: 137
1

Загрузка из txt в 1С

03.02.2020, 22:45. Показов 1656. Ответов 2
Метки нет (Все метки)

Author24 — интернет-сервис помощи студентам
Загружаю данные в справочник 1с из txt файла, всё весьма успешно, но реквизит "Специализация" заполняется из перечисления, и при загрузке все данные есть а специализация пусто
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
&НаСервере
Процедура ЗагрузитьСотрудниковНаСервере()
    
    Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать("C:\Users\bossk\Desktopекущие сотрудники.txt"); 
Для НомерСтроки = 1 по Текст.КоличествоСтрок() Цикл
    Стр = Текст.ПолучитьСтроку(НомерСтроки);
    Позиция = Найти (Стр, "|");
    МассивСтрок =  РазложитьСтрокуВМассивПодстрок(Стр, "|");
    Спр = Справочники.Сотрудники.СоздатьЭлемент();
    
    Спр.ФИО = МассивСтрок[0];
    Спр.Специализация = МассивСтрок[1];
    Спр.СтоимостьЧасаРаботы = МассивСтрок[2];
    
    Спр.Записать();
    
КонецЦикла
 
КонецПроцедуры
 
&НаКлиенте
Процедура ЗагрузитьСотрудников(Команда)
    ЗагрузитьСотрудниковНаСервере();
КонецПроцедуры
 
Функция РазложитьСтрокуВМассивПодстрок(Знач Стр, Разделитель = "|") Экспорт
    
    МассивСтрок = Новый Массив();
    Если Разделитель = " " Тогда
        Стр = СокрЛП(Стр);
        Пока 1 = 1 Цикл
            Поз = Найти(Стр, Разделитель);
            Если Поз = 0 Тогда
                МассивСтрок.Добавить(Стр);
                Возврат МассивСтрок;
            КонецЕсли;
            МассивСтрок.Добавить(Лев(Стр, Поз - 1));
            Стр = СокрЛ(Сред(Стр, Поз));
        КонецЦикла;
    Иначе
        ДлинаРазделителя = СтрДлина(Разделитель);
        Пока 1 = 1 Цикл
            Поз = Найти(Стр, Разделитель);
            Если Поз = 0 Тогда
                Если (СокрЛП(Стр) <> "") Тогда
                    МассивСтрок.Добавить(Стр);
                КонецЕсли;
                Возврат МассивСтрок;
            КонецЕсли;
            МассивСтрок.Добавить(Лев(Стр,Поз - 1));
            Стр = Сред(Стр, Поз + ДлинаРазделителя);
        КонецЦикла;
    КонецЕсли;
    
КонецФункции
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.02.2020, 22:45
Ответы с готовыми решениями:

Сохранение данных с ListView в .txt и загрузка с .txt
Сохранение данных с ListView в .txt и загрузка с .txt Помогите.

Загрузка файла *.txt при открытии приложения при двойном клике на самом файле *.txt
Здравствуйте! Подскажите как сделать так, чтобы при двойном клике по текстовому файлу, к примеру...

Загрузка txt файлов
доброго времени суток! у меня такой вопрос: надо программа на с++ прогнозирование случ...

Загрузка из txt в datagridview
Здравствуйте. У меня есть кнопка сохранения в txt, где сохраняются выборочно 3 столбца, из которых...

2
1275 / 797 / 230
Регистрация: 22.04.2013
Сообщений: 5,845
Записей в блоге: 1
04.02.2020, 07:53 2
пока 1 = 1, вы сериозно?

глубоко не вникал, но вам не кажется странным, что сначала вы пишете "РазложитьСтрокуВМассивПодстрок",
а потом считаете, что ни с того ни с сего строка будет элементом перечисления?
0
858 / 657 / 111
Регистрация: 01.11.2012
Сообщений: 2,411
04.02.2020, 08:35 3
Цитата Сообщение от bossko944 Посмотреть сообщение
но реквизит "Специализация" заполняется из перечисления
Как выше написали, тип в Справочнике перечисление, а ты ему даёшь строку.

Ты бы хотел машину, а тебе бы дали рисунок машины? Ты бы тоже наверное отказался бы ))
0
04.02.2020, 08:35
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
04.02.2020, 08:35
Помогаю со студенческими работами здесь

Загрузка матрицы из txt в DataGridView
Короче... Есть матрица в txt файле. Ее нужно считать и занести в таблицу. Выглядит так 2 3 4 5 6...

Загрузка TXT с интернета в Edit
Видимо не раз похожие темы поднимались.. Я все их прочитал, облазил весь интернет.. Бесполезно. ...

Загрузка данных в массив из txt
Здравствуйте! Есть файл с расширением txt. Создал кнопку в GUI, при нажатии на которую должна...

Загрузка .txt файла в массив С++
Доброго время суток! Помогите кто знает Суть в чем я делаю загрузку так - array&lt;String^&gt;^ strIn =...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2024, CyberForum.ru