5 / 4 / 1
Регистрация: 21.10.2019
Сообщений: 194
1

Как принять параметр открываемой формы ?

10.02.2020, 17:07. Показов 2425. Ответов 2
Метки нет (Все метки)

Из документа открываю внешнюю обработку и передаю в нее параметра для последующего отбора. Надеюсь параметр нормально уходит, такого кода достаточно в инете.

1C
1
2
3
4
ПараметрыФормы = Новый Структура(); 
ПараметрыФормы.Вставить("Док",Ссылка);
 
        ОткрытьФормуМодально(ПолучитьПолноеИмяФормы("ИмяФормыОбработки"), ПараметрыФормы);
А а каким образом мне этот параметр получить на обычной форме, не управляемой?

на управляемой было бы так

1C
1
2
3
4
ПриОткрытииНаСервере()
Если Параметры.Свойство("Док") Тогда
    ЭтаФорма.Документ=Параметры.Док;    
    КонецЕсли;
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
10.02.2020, 17:07
Ответы с готовыми решениями:

Как принять параметр-итератор в шаблоне функции?
Добрый день, знатоки! Чтобы набить руку, затеял наследование от класса std::vector. template...

Обратиться к элементу открываемой формы
Есть две формы: "Добавление товара" "Добавление характеристик" На форме "Добавление товара" есть...

Заполнять поле открываемой формы
Сделал кнопку на открытие формы на создании записи. При этом мне необходимо, чтобы одно из полей...

Задание позиции открываемой формы, относительно предыдущей
Суть: Есть Форма1, на ней расположено множество кнопок имеющих динамический размер и положение...

2
44 / 43 / 1
Регистрация: 11.07.2012
Сообщений: 1,024
10.02.2020, 23:00 2
вот пример от радченко, с передачей параметров из формы в форму
Листинг 8.222. Обработчик события нажатия кнопки «Подбор»
1C
1
2
3
4
5
6
&НаКлиенте
Процедура Подбор(Команда)
ПараметрыПодбора = Новый Структура("ТчТоваровДокумента", Объект.Товары);
ФормаПодбора = ОткрытьФорму("Документ.РасходнаяНакладная.Форма.ФормаПодбора",
ПараметрыПодбора, ЭтаФорма);
КонецПроцедуры
прием

Листинг 8.223. Обработчик события «ПриСозданииНаСервере»
1C
1
2
3
4
5
6
7
8
9
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
ТчТоваровДокумента = Параметры.ТчТоваровДокумента;
Для Каждого ТоварТч Из ТчТоваровДокумента Цикл
Элемент = ОтобранныеТовары.Добавить();
Элемент.Товар = ТоварТч.Товар;
Элемент.Количество = ТоварТч.Количество;
КонецЦикла;
КонецПроцедуры
может и в обычной форме сработает)
1
5 / 4 / 1
Регистрация: 21.10.2019
Сообщений: 194
11.02.2020, 11:35  [ТС] 3
Спасибо, хоть один пользователь ответил, но это я и сам нашел, ну или подобное, мне нужно передать параметр в обычную форму, а не в управляемую, а там другие события при открытии формы и как туда передать параметр не понятно?

Добавлено через 1 час 9 минут
Получить параметр на обычной форме можно видимо так

1C
1
2
3
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Ссылка = ПараметрОснование;
КонецПроцедуры
Осталось решить как передать параметр во внешнюю обработку формы? Как вообще в режиме отладки попасть в открываемую внешнюю форму?

Добавлено через 15 секунд
Получить параметр на обычной форме можно видимо так

1C
1
2
3
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Ссылка = ПараметрОснование;
КонецПроцедуры
Осталось решить как передать параметр во внешнюю обработку формы? Как вообще в режиме отладки попасть в открываемую внешнюю форму?

Добавлено через 2 часа 11 минут
ну вот так работает и реквизит на форме внешней обработки заполняется сам, параметр переходит сам через реквизит вызываемой формы
1C
1
2
3
4
5
6
7
8
9
ВнешняяФорма = Справочники.ВнешниеОбработки.НайтиПоНаименованию("XXXXXXXX");
    
    ИмяФайла = ПолучитьИмяВременногоФайла();
    ДвоичныеДанные = ВнешняяФорма.ХранилищеВнешнейОбработки.Получить();
    ДвоичныеДанные.Записать(ИмяФайла);
    
    Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
    Форма.СсылкаНаОбъект=Ссылка;
    Форма.Открыть();
Добавлено через 19 секунд
ну вот так работает и реквизит на форме внешней обработки заполняется сам, параметр переходит сам через реквизит вызываемой формы
1C
1
2
3
4
5
6
7
8
9
ВнешняяФорма = Справочники.ВнешниеОбработки.НайтиПоНаименованию("XXXXXXXX");
    
    ИмяФайла = ПолучитьИмяВременногоФайла();
    ДвоичныеДанные = ВнешняяФорма.ХранилищеВнешнейОбработки.Получить();
    ДвоичныеДанные.Записать(ИмяФайла);
    
    Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
    Форма.СсылкаНаОбъект=Ссылка;
    Форма.Открыть();
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
11.02.2020, 11:35
Помогаю со студенческими работами здесь

Как принять данные из формы по строкам
Есть поле <textarea></textarea> в него вводятся URLы, каждый строго с новой строки: site1.ru...

Как принять Post данные с формы
как принять данные на контролер с формы пост вот форма @using(var form =...

Как принять параметры из формы по номеру, а не по имени?
У меня тут проблема возникла (даже не одна): в одной ASP-страничке генерится форма с checkbox'ами,...

Как принять данные с формы, если name[phone][name]
Всем привет! Есть форма. Имя полей имеет следующий вид: name="name". Как с них принять с помощью...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru