Форум программистов, компьютерный форум, киберфорум
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.53/15: Рейтинг темы: голосов - 15, средняя оценка - 4.53
0 / 0 / 0
Регистрация: 02.07.2015
Сообщений: 11
1

Хранилище значений

02.07.2015, 17:33. Показов 2747. Ответов 9
Метки нет (Все метки)

Привет всем! Люди, подскажите пожалуйста, первый раз сталкиваюсь с хранилищем значений, как его реализовать, можно ли в него сохранять числовые значения?
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
02.07.2015, 17:33
Ответы с готовыми решениями:

РС + дин список + хранилище значений
день добрый ! есть регистр сведений, один из реквизитов - хранилище значений ( там настройки...

Поле с типом Хранилище Значений
Доброго времени. С 1С абсолютно не знаком, но дали задачу по интеграции с пред написанным...

Сохранение табличного документа в хранилище значений
Добрый день! Реализовал механизм записи Табличного документа в хранилище значений. ПечатнаяФорма...

Хранилище значения
Записываю: Регистр = РегистрыСведений.СохраненныеНастройки.СоздатьНаборЗаписей(); Пользователь =...

9
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,242
Записей в блоге: 1
02.07.2015, 17:59 2
Чачачаа, хранилище - для файлов различных используется в основном.
А что надо то с него?
0
0 / 0 / 0
Регистрация: 02.07.2015
Сообщений: 11
03.07.2015, 07:08  [ТС] 3
надо записать пару-тройку числовых данных, для дальнейших манипуляций
0
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,242
Записей в блоге: 1
03.07.2015, 10:04 4
Чачачаа, по идее всё сохранится, но зачем тайна покрытая мраком.
0
0 / 0 / 0
Регистрация: 02.07.2015
Сообщений: 11
03.07.2015, 10:18  [ТС] 5
на счёт сохранения вроде разобрался, а вот достать не получается
1C
1
2
3
4
5
6
7
8
9
10
Процедура Кнопка1Нажатие(Элемент)
//Хранилище = Новый ХранилищеЗначения(ЭлементыФормы.ПолеВвода1.Значение);
хранилище = новый ХранилищеЗначения( ЭлементыФормы.ПолеВвода1.Значение);
сообщить("сохранил")
КонецПроцедуры
 
Процедура Кнопка2Нажатие(Элемент)
рез =    хранилище.получить();
Сообщить("считал "+рез); 
КонецПроцедуры
0
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,242
Записей в блоге: 1
03.07.2015, 10:24 6
Чачачаа, Хранилище реквизит на форме?
Получить вообще можно только Сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Т.е. на управляемых формах нельзя.
Значит делаем так:

1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
процедура Кнопка2Нажатие(Элемент)
   Результат = ПолучитьНаСервере(Хранилище);
   Сообщить(Результат);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьНаСервере(Знач Хранилище)
  Возврат Хранилище.Получить();
КонецФункции;
0
0 / 0 / 0
Регистрация: 02.07.2015
Сообщений: 11
03.07.2015, 11:31  [ТС] 7
пока что я вас плохо понимаю, я делаю это во внешней обработке
объясните пожалуйста поподробнее
0
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,242
Записей в блоге: 1
03.07.2015, 11:39 8
Чачачаа, где располагается Хранилище?
Это реквизит формы, переменная или что?
0
0 / 0 / 0
Регистрация: 02.07.2015
Сообщений: 11
03.07.2015, 11:45  [ТС] 9
переменная
0
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,242
Записей в блоге: 1
03.07.2015, 12:16 10
Чачачаа, держи пример. Не хранилищезначения, а временное хранилище.
Вложения
Тип файла: 7z ВнешняяОбработка2.7z (2.9 Кб, 10 просмотров)
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
03.07.2015, 12:16

1с На Сетевом Хранилище
Здравствуйте, имеется сетевое хранилище D-link dns-325 и 1С 7.7 Сетевая (Бухгалтерия), два...

Хранилище Значения
Коллеги, изучая интересную вещь ХранилищеЗначения наткнулся на кое какие непонимания.. С...

1с на сетевом хранилище
Здравствуйте, имеется сетевое хранилище D-link dns-325 и 1С 7.7 Сетевая (Бухгалтерия), два...

внешнее хранилище
Кто-нибудь сталкивался с организацией внешнего хранилища для прикрепленных файлов в 1с? Задача -...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.