Форум программистов, компьютерный форум, киберфорум
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.89/9: Рейтинг темы: голосов - 9, средняя оценка - 4.89
0 / 0 / 1
Регистрация: 27.12.2014
Сообщений: 204
1

Изменить показатели расчета зарплаты

11.07.2015, 13:11. Показов 1810. Ответов 1
Метки нет (Все метки)

Часто требуется изменить показатели рассчета зарплаты.
Т.е. пользователь щёлкает по кнопочке "Заполнить" в документе "Начисление зарплаты" и заполняются начисления. Если нажмёт на кнопочку "показать подробности расчета", то будут отображены
Сам результат можно без проблем изменить здесь:
модуль РасчетЗарплатыРасширенныйПереопределяемый. В этом модуле можно изменить строку начислений и результат. А вот несмотря на всё это показатели остаются прежними. То есть если пользователь нажмёт "Показать подробности расчета", показатели будут неизменёнными. Как бы правильно их поменять. Кто-нибудь может подсказать?
Я в принципе нашёл, где рассчитываются сами показатели в типовой.
Это общий модуль "Расчет зарплаты расширенный". В этом модуле есть функция ДанныеДляЗаполненияТаблицДокумента. В ней всё и рассчитывается. Я пробовал в ней изменять значения показателей, но результат аналогичный.
Как правильно это сделать?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
Процедура ИзменитьДанныеЗаполнения(ДанныеЗаполнения) Экспорт
    
        МассивСотрудников = ДанныеЗаполнения.Начисления.ВыгрузитьКолонку("Сотрудник");
    НужноеНачисление = ПланыВидовРасчета.Начисления.НайтиПоНаименованию("СложныеРаботы");
    Если ДанныеЗаполнения.Начисления.Количество() > 0 Тогда
        
        ТЗ = ПолучитьНадбавку(МАссивСотрудников,ДанныеЗаполнения.Начисления[0].ПериодРегистрацииВремени); 
        ТЗ.Индексы.Добавить("Сотрудник");
        Для Каждого Строка Из ДанныеЗаполнения.Начисления Цикл
            Если Строка.Начисление =  НужноеНачисление Тогда
            НайденнаяСтрока = ТЗ.Найти(Новый Структура("Сотрудник", Строка.Сотрудник));
            Если НайденнаяСтрока <> Неопределено Тогда
                НайденнаяСтрока.Значение1 = 1;                 
                НайденнаяСтрока.Значение2 = 2;
                НайденнаяСтрока.Значение3 = 3;
                НайденнаяСтрока.Значение4 = 4;
                НайденнаяСтрока.Значение5 = 5;
                НайденнаяСтрока.Результат = 6;
            КонецЕсли;
            
                
                
            КонецЕсли;
        КонецЦикла;
        
    КонецЕсли;
 
    
КонецПроцедуры
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
11.07.2015, 13:11
Ответы с готовыми решениями:

Редактирование показателей расчета зарплаты ЗУП 3.0
Подскажите как грамотно сделать. Задача: Автоматизируемая задача: Работники подразделения...

Как изменить формулу расчета "ВидЗанятости"?
Всем доброго времени суток! Зарплата и управление персоналом 3.0 Калры/Приемы, переводы,...

Программа расчета недельной зарплаты
Здравствуйте, есть консольная программа расчета недельной зарплаты, а преподавателю нужно что бы...

Программа расчета общей зарплаты
В двумерном массиве хранится информация о зарплате 20 человек за каждый месяц года (первого...

__________________

Записывайтесь на профессиональные курсы 1C-разработчиков
1
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
15.07.2015, 09:14 2
Цитата Сообщение от Dimarik__1 Посмотреть сообщение
Я в принципе нашёл, где рассчитываются сами показатели в типовой.
мимо. Это что-то про надбавки, в этот текст программа может попадать раз в столетие.
ДанныеЗаполнения - Вам надо искать место, где эта хрень формируется.
А вообще, предметная область ЗУП - это "езда под кирпич".
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
15.07.2015, 09:14

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Предметная область: Отдел расчета зарплаты
Господа, очень нужна ваша помощь в данной программе...понятия не имею как её решать :( Кто может,...

Составить программу для расчета средней зарплаты
В Двумерном массиве хранится информация о зарплате 18 человек за каждый месяц года (в первом...

Какие реквизиты нужны для расчета зарплаты?
Подскажите, какие реквизиты нужны для расчета зарплаты в созданной ФормеДокумента и какой нужен...

Помогите найти ошибку. Класс расчета зарплаты.
Задание:Построить три класса(базовый и 2 потомка), описывающих некоторых работников с почасовой...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.