Форум программистов, компьютерный форум, киберфорум
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.78/9: Рейтинг темы: голосов - 9, средняя оценка - 4.78
1 / 1 / 1
Регистрация: 11.01.2013
Сообщений: 153
1
1C 8.x

Исключить из списка

11.07.2015, 18:49. Показов 1820. Ответов 7
Метки нет (Все метки)

Добрый день! Помогите пожалуйста! Как можно исключить из выпадающего списка тип цены (Оптовая) из существующего списка при нажатие на КнопкуВыбрать,
0
Миниатюры
Исключить из списка  
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
11.07.2015, 18:49
Ответы с готовыми решениями:

Исключить элемент из списка
Есть список TShapeList = specialize TFPGList<TShape>; Shape0, Shape1, Shape2... Надо исключить...

Исключить повторяющиеся элементы из списка
Не получается и всё тут! Удалять элементы умею из любой части списка, но вот именно, чтобы из...

Исключить предпоследнее сообщение из списка
Доброе время суток. В общем, на странице выводится одно одно сообщение рубрики с картинкой <?php...

Исключить из списка элементы с минимальным значением
Дан список из n целых чисел a1,a2,...,an. Исключить из списка элементы с минимальным значением.

__________________

Записывайтесь на профессиональные курсы 1C-разработчиков
7
Модератор
Эксперт 1С
3055 / 2749 / 515
Регистрация: 10.03.2011
Сообщений: 10,550
Записей в блоге: 1
11.07.2015, 21:42 2
Примерно так: (из бухни 2.0)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
// Процедура - обработчик события "Начало выбора" поля "Тип цен".
//
Процедура НовыйТипЦенНачалоВыбора(Элемент, СтандартнаяОбработка)
 
    Если НЕ ЗначениеЗаполнено(НовыйТипЦен) Тогда
        НовыйТипЦен = Справочники["ТипыЦенНоменклатуры"].ПустаяСсылка();
    КонецЕсли;
    
    СтандартнаяОбработка = Ложь;
    
    СписокТиповЦен = ПолучитьСписокНужныхТиповЦен();
        
    ЗначениеТипаЦен = ВыбратьИзСписка(СписокТиповЦен, ЭлементыФормы.НовыйТипЦен, СписокТиповЦен.НайтиПоЗначению(НовыйТипЦен));
    Если ЗначениеТипаЦен <> Неопределено Тогда
        НовыйТипЦен = ЗначениеТипаЦен.Значение;
    КонецЕсли; 
 
КонецПроцедуры // НовыйТипЦенНачалоВыбора()
 
//Функция получает список типов цен для выбора
//
Функция ПолучитьСписокНужныхТиповЦен()
    
    СЗ = Новый СписокЗначений;
    Выборка = Справочники.ТипыЦенНоменклатуры.Выбрать();
    Пока Выборка.Следующий() Цикл
        Если НЕ Выборка.ПометкаУдаления Тогда //Не добавляем помеченные на удаление
            СЗ.Добавить(Выборка.Ссылка);
        КонецЕсли; 
    КонецЦикла; 
    
    Возврат СЗ;
    
КонецФункции
0
1 / 1 / 1
Регистрация: 11.01.2013
Сообщений: 153
11.07.2015, 22:27  [ТС] 3
Переписал код.

1C
1
2
3
4
5
6
7
8
9
10
11
Процедура НовыйТипЦенНачалоВыбора(Элемент, СтандартнаяОбработка)
                
    // Установим тип реквизита НовыйТипЦен и, в случае необходимости, владельца.
    Если НЕ ЗначениеЗаполнено(НовыйТипЦен) Тогда
        НовыйТипЦен = Справочники["ТипЦенНоменклатуры"].ПустаяСсылка(); 
    КонецЕсли; 
    СтандартнаяОбработка = Ложь;    
    СписокТиповЦен = ПолучитьСписокНужныхТиповЦен();  
    ВыбратьИзСписка(СписокТиповЦен, ЭлементыФормы.НовыйТипЦен, НовыйТипЦен);
 
КонецПроцедуры // НовыйТипЦенНачалоВыбора()
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Функция ПолучитьСписокНужныхТиповЦен()
       
       СЗ = Новый СписокЗначений;
       Выборка = Справочники.ТипыЦенНоменклатуры.Выбрать();
       Пока Выборка.Следующий() Цикл 
           Если НЕ Выборка.ПометкаУдаления Тогда
               СЗ.Добавить(Выборка.Ссылка);
           КонецЕсли;
       КонецЦикла;
       
       Возврат СЗ;
       
КонецФункции
Выдает ошибку.
{ОбщаяФорма.ФормаЦеныИВалюта.Форма(248)}: Ошибка при вызове метода контекста (ВыбратьИзСписка)
ВыбратьИзСписка(СписокТиповЦен, ЭлементыФормы.НовыйТипЦен, НовыйТипЦен);
по причине:
Несоответствие типов (параметр номер '3')

Еще вопрос, а где именно именно исключает значение из списка, допустим Оптовая?
0
Модератор
Эксперт 1С
3055 / 2749 / 515
Регистрация: 10.03.2011
Сообщений: 10,550
Записей в блоге: 1
11.07.2015, 23:52 4
PuLbKa, скопируй код еще раз. (исправил ошибку)
0
1 / 1 / 1
Регистрация: 11.01.2013
Сообщений: 153
12.07.2015, 09:20  [ТС] 5
Запускается, но почему то не исключает
0
Модератор
Эксперт 1С
3055 / 2749 / 515
Регистрация: 10.03.2011
Сообщений: 10,550
Записей в блоге: 1
13.07.2015, 10:32 6
Лучший ответ Сообщение было отмечено PuLbKa как решение

Решение

PuLbKa, пометь ее на удаление
1
1 / 1 / 1
Регистрация: 11.01.2013
Сообщений: 153
16.07.2015, 20:38  [ТС] 7
Спасибо, заработало! Только есть проблема, после выбора выдает такое сообщение "смотри картинку"
0
Миниатюры
Исключить из списка  
1 / 1 / 1
Регистрация: 11.01.2013
Сообщений: 153
16.07.2015, 20:45  [ТС] 8
Все разобрался надо было удалить строчки

1C
1
2
3
Если ЗначениеТипаЦен <> Неопределено Тогда
        НовыйТипЦен = ЗначениеТипаЦен.Значение;
    КонецЕсли;
Они лишние
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
16.07.2015, 20:45

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Из исходящего списка исключить неудовлетворительные оценки
Привет всем. Прошу помощи с заданием. 1. Сформировать целочисельный список, который содержит...

Исключить из списка все элементы, равные x
1) Создать список из целых чисел. Исключить из списка все элементы, равные x. 2) Создать список...

Исключить активити из списка последних закрытых приложений
Доброго времени суток форумчане! Делаю приложения, и у меня стоит задача нужно открывать активити...

Исключить из списка все повторные вхождения элементов
Помогите плиз добить задачку (а именно часть с ExtraPrintList) на тему &quot;списки&quot;. Дан список из n...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.