Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.92/13: Рейтинг темы: голосов - 13, средняя оценка - 4.92
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
1
1C 7.x

ТаблицаЗначений в печатную форму

11.11.2013, 11:01. Показов 2488. Ответов 12
Метки нет (Все метки)

Помогите, такая вот проблема нужно вывести в строку в печатной форме значений из таблицы значений. как это можно организовать?
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
11.11.2013, 11:01
Ответы с готовыми решениями:

На форму добавить табличное поле «табЗагрузки», с типом значения «ТаблицаЗначений» и командной панелью
На форму добавить табличное поле «табЗагрузки», с типом значения «ТаблицаЗначений» и командной...

Настроить печатную форму
Имеется макет печатной формы и то как он отображается в пользовательском режиме. Мне необходимо...

Выбрать печатную форму
У клиентов свои печатные формы актов, поэтому чтобы не делать кучу печатных форм в кнопке "Печать",...

Вывод на печатную форму. УТ 11
Здравствуйте, в типовой печатной форме нужно вывести данные, в табл часть шаблон вставил, в модуле...

12
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
11.11.2013, 11:16 2
Обходом в цикле ТаблицыЗначений
0
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
11.11.2013, 11:22  [ТС] 3
Цитата Сообщение от Xomych Посмотреть сообщение
Обходом в цикле ТаблицыЗначений
можно подробнее пожалуйса
0
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
11.11.2013, 11:31 4
1C
1
2
3
4
5
6
7
8
9
10
11
12
//Тбл - твоя таблица значений, с колонками Товар, Кол и Сум
//Строка - секция строки печатной формы, куда будем выводить товар, Количество и сумму из Тбл
Таб=СоздатьОбъект("Таблица");
Тбл.ВыбратьСтроки();
Пока Тбл.ВыбратьСтроку()=1 цикл
         Тов=Тбл.Товар;
         Кол=Тбл.Кол;
         Сум=Тбл.Сум;
         //Тов, Кол и Сум - переменные в таблице в секции Строка 
         Таб.ВывестиСекцию("Строка");
КонецЦикла;
Таб.Показать();
0
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
11.11.2013, 11:45  [ТС] 5
Цитата Сообщение от Xomych Посмотреть сообщение
1C
1
2
3
4
5
6
7
8
9
10
11
12
//Тбл - твоя таблица значений, с колонками Товар, Кол и Сум
//Строка - секция строки печатной формы, куда будем выводить товар, Количество и сумму из Тбл
Таб=СоздатьОбъект("Таблица");
Тбл.ВыбратьСтроки();
Пока Тбл.ВыбратьСтроку()=1 цикл
         Тов=Тбл.Товар;
         Кол=Тбл.Кол;
         Сум=Тбл.Сум;
         //Тов, Кол и Сум - переменные в таблице в секции Строка 
         Таб.ВывестиСекцию("Строка");
КонецЦикла;
Таб.Показать();
скорее не выбратьсроку, а получитьстроку? так ведь? если да то уже так делал но не выходит все значения в одну строку забить в печформе
0
285 / 185 / 18
Регистрация: 20.02.2012
Сообщений: 925
11.11.2013, 12:02 6
Цитата Сообщение от shiro93 Посмотреть сообщение
все значения в одну строку забить в печформе
если значений в табл знач много как вы представляете себе это в одной строке ?
0
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
11.11.2013, 12:04  [ТС] 7
Цитата Сообщение от shiro93 Посмотреть сообщение
скорее не выбратьсроку, а получитьстроку? так ведь? если да то уже так делал но не выходит все значения в одну строку забить в печформе
Цитата Сообщение от SonicQ Посмотреть сообщение
если значений в табл знач много как вы представляете себе это в одной строке ?
у меня такая вот ситуация должно быть так в печформе Присутствующие: и тут перечисление всех членов и их должности...Сотрудники и их должности находятся в ТЗ в разных колонках
0
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
11.11.2013, 12:16 8
Цитата Сообщение от shiro93 Посмотреть сообщение
скорее не выбратьсроку, а получитьстроку? так ведь? если да то уже так делал но не выходит все значения в одну строку забить в печформе
Да ПолучитьСтроку конечно, опечатался
0
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
11.11.2013, 12:19  [ТС] 9
Цитата Сообщение от Xomych Посмотреть сообщение
Да ПолучитьСтроку конечно, опечатался
это понятно, а как сделать чтоб не в колонку выводилось, а все в одну строку
0
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
11.11.2013, 13:56 10
набиваешь стринг фамилиями в цикле, А выводишь уже после "КонецЦикла"
0
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
11.11.2013, 14:57  [ТС] 11
Цитата Сообщение от duk337 Посмотреть сообщение
набиваешь стринг фамилиями в цикле, А выводишь уже после "КонецЦикла"
это чт о с использованием списказначений? или по другому можно?
0
852 / 651 / 111
Регистрация: 01.11.2012
Сообщений: 2,403
11.11.2013, 15:07 12
1C
1
2
3
4
5
6
7
8
9
10
//Тбл - твоя таблица значений, с колонками Товар, Кол и Сум
//Строка - секция строки печатной формы, куда будем выводить товар, Количество и сумму из Тбл
Таб=СоздатьОбъект("Таблица");
Стр="";
Тбл.ВыбратьСтроки();
Пока Тбл.ВыбратьСтроку()=1 цикл
         Стр=Стр+Тбл.Сотрудник+", "+Тбл.Должность+"; ";    
КонецЦикла;
Таб.ВывестиСекцию("Строка");
Таб.Показать();
Например так
1
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
11.11.2013, 15:17  [ТС] 13
Цитата Сообщение от Xomych Посмотреть сообщение
1C
1
2
3
4
5
6
7
8
9
10
//Тбл - твоя таблица значений, с колонками Товар, Кол и Сум
//Строка - секция строки печатной формы, куда будем выводить товар, Количество и сумму из Тбл
Таб=СоздатьОбъект("Таблица");
Стр="";
Тбл.ВыбратьСтроки();
Пока Тбл.ПолучитьСтроку()=1 цикл
         Стр=Стр+Тбл.Сотрудник+", "+Тбл.Должность+"; ";    
КонецЦикла;
Таб.ВывестиСекцию("Строка");
Таб.Показать();
Например так
спасибо помогло
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
11.11.2013, 15:17

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Добавить печатную форму 1С v8
Необходимо Документы - Ведомость в кассу добавить печатную форму 0504403. Зашел в конфигуратор -...

Вывод на печатную форму. УТ 11
Здравствуйте, в типовой печатной форме "приходная накладная" ут 11 создал область, параметр, в...

редактировать печатную форму в УПП 1С: 8
не могу понять как разрешить редактирование печатных форм в УПП 1С 8?! не могу найти макет...

Вывод картинки на печатную форму
Чтобы при нажатии кнопки Печать картинка отображалась на печатной форме.


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
13
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.