0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
1

Журналы документов

07.05.2009, 17:34. Показов 22325. Ответов 17
Метки нет (Все метки)

Привет Форумчане!

Ребята вообщем вопрос такой, в журнале когда жмеш в таблице правой клавишей вылазит контекстное меню, в котором есть графа "Сделать не проведенным", так вот, можно ли перехватить это событие?
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
07.05.2009, 17:34
Ответы с готовыми решениями:

Нумератор и журналы
Помогите! ;) У меня такое дело...Есть расходная накладная в которой при установке галочки меняется...

V7.7 Журналы и Документы
Ребята проблема такая: Создал новый документ, только мне надо чтобы он не показывался ни в каких...

Как быстро очистить все таблицы (справочники, журналы, регистры)
Как быстро очистить все таблицы (справочники, журналы, регистры)

Журналы документов отбор
Подскажите, пожалуйста, как в журналах документа сделать отбор, как на рисунке по орг-ии,...

17
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
07.05.2009, 17:59 2
Какое именно событие? Если отмену проведения, то оно перехватывается в модуле документа. Если показ контекстного меню, то при помощи внешних компонент.
0
0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
07.05.2009, 19:18 3
Цитата Сообщение от vitfil
Если показ контекстного меню, то при помощи внешних компонент.
Перехват нажатия "Сделать не проведенным" из контекстного меню
0
0 / 0 / 0
Регистрация: 21.01.2009
Сообщений: 133
08.05.2009, 01:57 4
Можно, но в соседней ветке
0
0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
08.05.2009, 06:12 5
Цитата Сообщение от ech
Можно, но в соседней ветке
Это в какой?
0
0 / 0 / 0
Регистрация: 21.01.2009
Сообщений: 133
09.05.2009, 00:50 6
В ветки по программировании ООП
0
0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
09.05.2009, 09:57 7
Так ладно ребята голову морочить вам не буду, смысл вот в чем:

В документы реализация и поступление я добавляю реквизит "ДокИсточник", нужен он для того чтобы хранить документ из-за которого произошло следующее движение:

я дописал документ реализации так, что если не хватает ТМЦ, тогда он продаеться нам с другой фирмы (если его хватает), а потом проводиться сама реализация, и перед проведением в документы которые создаются автоматически нашей реализацией в наш реквизит (ДокИсточник) заноситься документ реализации, который возбудил движение. В последствии мы всегда будем знать что и из-за чего. Так вот но если мы будем делать отмену проведения документа, тогда надо чтобы и те документы тоже были отменены, поэтому я так и хотел перехватить обработку события нажатия "Снять проведение или как там". Вопрос тогда ставим так:

Если я в модуле документа напишу обработчик "ОбработкаПроведенияДокумента" , где будут отменяться те вспомогательные документы, будет ли это допустимо?

т.е. :

Процедура ОбработкаУдаленияПроведения()

Если ПустоеЗначение(ДокОснование) = 0 Тогда
Док = СоздатьОбъект("Документ");
Док.НайтиДокумент(ДокОснование );
Док.СделатьНеПроведенным();
Док.Удалить();
КонецЕсли;

КонецПроцедуры;

Вообщем проверил, нормально, будет этот код допустим? Не будет ли он влиять на что-либо?
0
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
09.05.2009, 12:07 8
Ты точно хочешь их удалить? Возможно нарушение ссылочной целостности. В остальном - ничего плохого не случится.
0
0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
09.05.2009, 16:16 9
Цитата Сообщение от unknown181538
Ты точно хочешь их удалить? Возможно нарушение ссылочной целостности. В остальном - ничего плохого не случится.
Удалить надо. А ссылочная целостность не проверяется? Ну вообщем представь картину:

1. Мы создаем док. реализации.
2. Начинаем проводить.
3. Если ТМЦ не хватает, то с других фирм он продаеться, т.е.
(ранее я говорил о том что мы создаем реквизит "ДокИст", который хранит документ создавший это движение)
3.1. Автоматически создаеться док. реализации с недостающим ТМЦ на другой фирме, реквизит "ДокИст" заполняеться "документом" шага 1.
3.2. Автоматически создаеться док. поступления на нашей фирме, реквизит "ДокИст" заполняеться "документом" шага 1.
4. Проводиться наш документ.

Созданные документы (на шагах 3.1 и 3.20) ссылаются на нашу реализацию. А когда мы будем делать отмену проведения, обязательно реквизит "ДокИст" всех найденых подчиненных документов будет проверяться на соответствие нашего в ручную созданного документа. Думаю если их (автоматически созданные) не трогать и удалять то ничего нарушено не будет, как считаете?

И сейчас мне в голову мысль пришла, если реквизит "ДокИст" не пустой, тогда док. будет открываться только для просмотра.

Вообщем, Ребята, описанная выше технология возможна? Я в том плане что нарушаться ничего не будет?

П/С. Все наверное поняли что раннее представленный мною алгоритм показан в качестве примера, в реальности он будет другим.
0
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
10.05.2009, 08:49 10
Цитата Сообщение от Anatoly1987
Док.Удалить();
Не удаляет, а помечает на удаление.
0
0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
10.05.2009, 12:37 11
Цитата Сообщение от vitfil
Не удаляет, а помечает на удаление
Удаляет! "ПометитьНаУдаление" для этого функция есть.
0
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
10.05.2009, 14:57 12
Удалить(<?>);
Delete(<?>);
Синтаксис:
Удалить(<Режим>)
Назначение:
Удалить документ.
Параметры:
<Режим> -: 1 - непосредственное удаление, 0 - пометка на удаление (необязателен, по умолчанию - 1).

ПометкаУдаления()
DeleteMark()
Синтаксис:
ПометкаУдаления()
Назначение:
Возвращает флаг пометки удаления документа:
1 - если на документе стоит пометка удаления,
0 - если нет пометки удаления.
0
0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
10.05.2009, 17:13 13
Цитата Сообщение от vbs
Удалить(<?>);
Delete(<?>);
Синтаксис:
Удалить(<Режим>)
Назначение:
Удалить документ.
Параметры:
<Режим> -: 1 - непосредственное удаление, 0 - пометка на удаление (необязателен, по умолчанию - 1).

ПометкаУдаления()
DeleteMark()
Синтаксис:
ПометкаУдаления()
Назначение:
Возвращает флаг пометки удаления документа:
1 - если на документе стоит пометка удаления,
0 - если нет пометки удаления.
Ну и не хвастайся! :wacko:
0
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
10.05.2009, 17:19 14
Цитата Сообщение от Anatoly1987
Ну и не хвастайся!
А в чем хвастовство ? Просто справку привел
0
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
10.05.2009, 19:52 15
Anatoly1987
Прям классика получается...
- А если я ляпну?
- А ты ляпай, но ляпай уверенно!
(с) "Москва слезам не верит!".
0
0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
10.05.2009, 23:20 16
Вот уж ниче сказать нельзя. Ладно мне на вопрос кто0нить ответит?
0
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 38
11.05.2009, 04:11 17
Процедура ПриОтменеПроведенияДокумента(< ?>)
КонецПроцедуры
Procedure OnUnPosting(<?>)
EndProcedure
Синтаксис:
ПриОтменеПроведенияДокумента(< Докум>)
Назначение:
Предопределенная процедура при интерактивной отмене проведения документа.
Параметры:
<Докум> - обрабатываемый документ.
Замечание:
Данная процедура может располагаться только в глобальном программном модуле.
0
0 / 0 / 0
Регистрация: 20.03.2009
Сообщений: 100
11.05.2009, 16:42 18
Цитата Сообщение от kaa
Процедура ПриОтменеПроведенияДокумента(< ?>)
КонецПроцедуры
Procedure OnUnPosting(<?>)
EndProcedure
Синтаксис:
ПриОтменеПроведенияДокумента(< Докум>)
Назначение:
Предопределенная процедура при интерактивной отмене проведения документа.
Параметры:
<Докум> - обрабатываемый документ.
Замечание:
Данная процедура может располагаться только в глобальном программном модуле.
Ага уже нашел. Но все равно спасибо!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
11.05.2009, 16:42
Помогаю со студенческими работами здесь

Отбор по банковскому счету документов в журнале документов (банковская выписка)
Добрый день! Подскажите, пож, как правильно написать код для отбора по банковскому счету документов...

Настройки колонок документов не сохраняются для некоторых документов
Есть база 1С 8. Большинство документов конвертировано из 1с 7.7 с помощью конвертации. Так вот в...

журналы
Группа людей обсуждала, кто какие журналы выписывает. Оказалось, что каждый выписывает два журнала....

Математические журналы
Хочется почитать какой-нибудь математический журнал типа &quot;Современные проблемы математики&quot;. Где их...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
18
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru