0 / 0 / 0
Регистрация: 29.11.2007
Сообщений: 36
1

Как правильно кодить... УдалитьКаталог();

06.12.2007, 13:36. Показов 27605. Ответов 12
Метки нет (Все метки)

Доброго времени суток госпада Программеры!!!

На досуге ради развития знаний... Ну и т.п. и т.д.. Есть вопрос.

По поводу команды УдалитьКаталог();..
Вставляю код док-а



Перем Путь, Свершилось;

Процедура ВыборПапки()
ФС.ВыбратьКаталог(Путь,"Удаляемая папка"); //выбираем папку
Свершилось = 1;
КонецПроцедуры

Процедура Удаление()
ФС.УдалитьКаталог(Путь); //непосредственное удаление
КонецПроцедуры

Процедура Делете()
Если Свершилось = 1 Тогда //проверка выполнения Выбора папки
Вопрос("Вы действительно хотите удалить данную папку?",4);
Удаление();
Иначе
Предупреждение("Укажите директорию... Иначе никак");
СтатусВозврата(1);
КонецЕсли;
КонецПроцедуры
Пишем вместо Пути конктретную папку (вернее путь к ней) все работает безупречно. Если же вместо точного пути пишем переменную (путь директории), ни чего не работает, выдает ошибку "Ошибка при выполнении команды;" Может кто че скажет по этому поводу...
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
06.12.2007, 13:36
Ответы с готовыми решениями:

Не приходит понимание того, как осознанно "кодить"
Доброго времени суток. Прошел комплексный ЦСОшный курс, комплексной подготовки по...

Как кодить с Qt под CLion?
И возможно ли такое. Не использовать стандартный qt creator.

Как кодить в NetBeans C++ на Linux системе.
Поставил себе Linux Ubuntu. Всё бы ничего, да вот нужна очень среда разработки консольных C++...

Как кодить в Делфи из под Линукса
Добрый вечер! У меня вопрос такой: Я переустановила систему с виндовс на линукс - довольна ) Но...

12
0 / 0 / 0
Регистрация: 29.11.2007
Сообщений: 36
10.12.2007, 12:59 2
Неужели все такие умные, что пояснить какую то простейшую функцию, как она должна работать, ниже вашего достоинства??? Либо в ламы??? :blink:
0
Dr.Uyd
10.12.2007, 13:07 3
Попробуй СОКРЛП(Имя_Каталога)... почти на 100% уверен что поможет...

P.S. Этот совет можно отнести к любым функциям и процедурам работающим с путями и именами файлов...
0 / 0 / 0
Регистрация: 29.11.2007
Сообщений: 36
10.12.2007, 13:16 4
Цитата Сообщение от Dr.Uid
Попробуй СОКРЛП(Имя_Каталога)... почти на 100% уверен что поможет...

P.S. Этот совет можно отнести к любым функциям и процедурам работающим с путями и именами файлов...
Это же сколько геморою... Перепроверки названия директории на длуну... Емае... неужели нет какого либо более вразумительго ответа...
0
Dr.Uyd
10.12.2007, 15:02 5
Это ж сколько геморою... написать
ФС.УдалитьКаталог(СокрЛП(Путь));

вместо... ФС.УдалитьКаталог(Путь);

:blink:
Не смеши...
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
11.12.2007, 20:19 6
для physik_gumanitar
Я вот попробовал все варианты, и все кончаются (начинаются то бишь) на 8-ю букву алфавита.
Увы, видимо глюк программы 1С (и такое встречается)
0
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 38
12.12.2007, 03:45 7
Попробуйте вместо УдалитьКаталог УдалитьФайл
0
0 / 0 / 0
Регистрация: 29.11.2007
Сообщений: 36
12.12.2007, 05:15 8
Цитата Сообщение от kaa
Попробуйте вместо УдалитьКаталог УдалитьФайл
УдалитьФайл работает в любом случае...
Опять таки вы не вчитываетесь в суть ТЕМЫ.. Вопрос был про УдалитКаталог()...
0
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
12.12.2007, 10:37 9
Пишем вместо Пути конктретную папку (вернее путь к ней) все работает безупречно
Каким образом явно указать путь к папке ? У меня ни явно, ни через переменную не сработало
0
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 38
12.12.2007, 11:11 10
<!--QuoteBegin-physik_gumanitar+13:12:2007, 13:02 -->
<span class="vbquote">(physik_gumanitar @ 13:12:2007, 13:02 )</span><!--QuoteEBegin-->УдалитьФайл работает в любом случае...
Опять таки вы не вчитываетесь в суть ТЕМЫ.. Вопрос был про УдалитКаталог()...
[snapback]89707" rel="nofollow" target="_blank[/snapback]?[/quote]

Вообщем то отывет прос каталог заблокирован попробуйте так:

Процедура Удаление()
ФС.УстТекКаталог(ФС.WindowsКаталог());
ФС.НайтиПервыйФайл("*.*");
ФС.УдалитьКаталог(Путь); //непосредственное удаление
КонецПроцедуры
0
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
12.12.2007, 12:15 11
каталог заблокирован
+1

Проблема именно в этом. Только искать первый файл не нужно
Достаточно переопределить текущий каталог
0
0 / 0 / 0
Регистрация: 29.11.2007
Сообщений: 36
12.12.2007, 21:00 12
Цитата Сообщение от jj_mail
Каким образом явно указать путь к папке ? У меня ни явно, ни через переменную не сработало
Просто. указав конкретную папку... т.е. путь к папке... Типо "C:\Downloads\Программы"... жеская привязка работает... Переменая же нет...
0
0 / 0 / 0
Регистрация: 29.11.2007
Сообщений: 36
13.12.2007, 07:23 13
Цитата Сообщение от kaa
Вообщем то отывет прос каталог заблокирован попробуйте так:

Процедура Удаление()
ФС.УстТекКаталог(ФС.WindowsКаталог());
ФС.НайтиПервыйФайл("*.*");
ФС.УдалитьКаталог(Путь); //непосредственное удаление
КонецПроцедуры
Спасибо, все работает. Вот только удаление происходит только в том случае, если директория пустая, это уже не так важно...
Дальнейшая судьба всего того с чего начиналось, близится к успешному завершению...
Всем мои благодарности!!! В частности kaa...
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
13.12.2007, 07:23
Помогаю со студенческими работами здесь

Как узнать дано ли мне кодить?
Не могу определиться хочу ли я заниматься программированием. Или как узнать для меня это или нет)....

Как кодить на TASM в windows 7 86 bit
Как кодить на TASM в windows 7 86 bit

как кодить на с в Microsoft visual studio 2010
первый раз встречаюсь с вижлой.как кодить на с в Microsoft visual studio 2010?обьясните...

В общем изучаю маленько как кодить в ТС, и вот такая шляпа
#include &lt;stdio.h&gt; #include &lt;math.h&gt; #include &lt;conio.h&gt; int main() { float a,x,i,c,f,s;...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
13
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru