Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.86/179: Рейтинг темы: голосов - 179, средняя оценка - 4.86
sommys
1

Проблема с 1С.

30.07.2007, 16:36. Просмотров 32420. Ответов 21
Метки нет (Все метки)

Сотрудник сформировал файл "Удаление общее" .Все документы отметились на удаление, как все вернуть.(Приходные,расходные,счета и т.д.)ПОМОГИТЕ!!!
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
30.07.2007, 16:36
Ответы с готовыми решениями:

проблема при работе с китайским J-LINK 8 или же проблема с с
Всем привет. Решил Сам собрать себе дисковери кит на базе at91sam7s64-ek. Подарили мне китайский...

Холодильник LG .мод GR-M392YQ.Проблема с дверю, Проблема с дверю при закрывании
Доброго времени суток уважаемые! Холодильник LG GR-M392YQ с первых дней клиент жалуется на то что...

СМА Indesit AQ70L 05 CIS проблема с вращением двигателя, СМА Indesit AQ70L 05CIS проблема с вращением двигателя
сма Indesit AQ70L 05 CIS серийный 203120035 инд код 50770730000 платформа Аркадия однофазка тип...

проблема с Like
Почемуто не работает если ставить символ %. Если полное название писать то оно выбирает, а если...

21
0 / 0 / 0
Регистрация: 16.07.2007
Сообщений: 170
30.07.2007, 17:07 2
сформировать файл "Отмена удаления общего"... хехе

серьезно - Групповая обработка справочников и документов...
0
sommys
30.07.2007, 17:15 3
А что там делать

Если можно распишите что и как делать!Спрасибо!
0 / 0 / 0
Регистрация: 16.07.2007
Сообщений: 170
30.07.2007, 18:22 4
Дополнение №1 к правилам:
Название темы должно быть максимально информативным. Запрещается создавать темы "Помогите!", "Труба!", "Спасайте, кто может!" и т.д. В названии темы необходимо кратко изложить суть вопроса.
Дополнение №18 (от меня личн0):
Категорически не рекомендуецц0 просить конкретных подробных рекомендаций по решению каких-либо проблем БЕЗ указания версии пплатформы и конфигурации...

хехе...
0
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 38
01.08.2007, 11:36 5
Док=СоздатьОбъект("Документ");

НачатьТранзакцию();

Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.ПометкаУдаления()=1 Тогда
Док.СнятьПометкуУдаления();
КонецЕсли;
КонецЦикла;

ЗафиксироватьТранзакцию();
0
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
01.08.2007, 15:43 6
Для: kaa

Ага, а потом ручками проводить сколько-то там тысяч документов

Док=СоздатьОбъект("Документ");

НачатьТранзакцию(); //ибо на первой же ошибке проведения документа вся транзакция отменится

Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.ПометкаУдаления()=1 Тогда
Док.СнятьПометкуУдаления();
Если Метаданные.Документ(Док.Вид()).РазрешитьПроведение = 1 Тогда
Док.Провести();
КонецЕсли
КонецЕсли;
КонецЦикла;

ЗафиксироватьТранзакцию();
0
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 38
01.08.2007, 15:50 7
<!--QuoteBegin-LSH+2:08:2007, 13:30 -->
<span class="vbquote">(LSH @ 2:08:2007, 13:30 )</span><!--QuoteEBegin-->Ага, а потом ручками проводить сколько-то там тысяч документов
[snapback]74179" rel="nofollow" target="_blank[/snapback]?[/quote]

Просили снять пометку и все, а проведение можно обеспечить стандартными средствами
0
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
01.08.2007, 21:40 8
<!--QuoteBegin-kaa+2:08:2007, 14:37 -->
<span class="vbquote">(kaa @ 2:08:2007, 14:37 )</span><!--QuoteEBegin-->Просили снять пометку и все, а проведение можно обеспечить стандартными средствами
[snapback]74181" rel="nofollow" target="_blank[/snapback]?[/quote]

Вы когда-нибудь проводили документы стандартными средствами?
Любая нехватка товаров на складе сразу проведение останавливается, ищем документ, разбираемся, проводим, запускаем обработку дальше.

Куда уж проще написать самому, но при этом документы будут проводиться без ошибок.
0
somywhyry
02.08.2007, 09:31 9
А что если документы до полного удаления не были проведены ;-) по каким-то причинам - и теперь они все проведутся!
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 38
02.08.2007, 09:40 10
<!--QuoteBegin-LSH+2:08:2007, 19:27 -->
<span class="vbquote">(LSH @ 2:08:2007, 19:27 )</span><!--QuoteEBegin-->Вы когда-нибудь проводили документы стандартными средствами?
[snapback]74261" rel="nofollow" target="_blank[/snapback]?[/quote]

Возможно это не самый быстрый способ, зато самый правильный

ихмо восстановят ГП , иначе на выходе могут получить несоответствие остатков товара и взаиморасчетов с контрагентами

в любом случае проведение стандартными средствами незаймет более 2-3 часов, как доктор говорю
0
0 / 0 / 0
Регистрация: 16.07.2007
Сообщений: 170
02.08.2007, 14:07 11
<!--QuoteBegin-kaa+3:08:2007, 07:27 -->
<span class="vbquote">(kaa @ 3:08:2007, 07:27 )</span><!--QuoteEBegin-->проведение стандартными средствами незаймет более 2-3 часов, как доктор говорю
[snapback]74290" rel="nofollow" target="_blank[/snapback]?[/quote]

все зависит отЪ...
у меня есть база, на которой посл-ть восстанавливаецц0 со скоростью месяц\час...
а на другой год\полчаса...
таГ што доктор из тебя не очень... хехе
0
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
02.08.2007, 15:40 12
<!--QuoteBegin-kaa+3:08:2007, 08:27 -->
<span class="vbquote">(kaa @ 3:08:2007, 08:27 )</span><!--QuoteEBegin-->ихмо восстановят ГП , иначе на выходе могут получить несоответствие остатков товара и взаиморасчетов с контрагентами
[snapback]74290" rel="nofollow" target="_blank[/snapback]?[/quote]

Нет ничего проще...
дописываем после выборки документа строчку УстановитьТАПо(Док.ТекущийДокумент());
Вот вам и граница последовательности.

<!--QuoteBegin-b00tch+3:08:2007, 12:54 -->
<span class="vbquote">(b00tch @ 3:08:2007, 12:54 )</span><!--QuoteEBegin-->у меня есть база, на которой посл-ть восстанавливаецц0 со скоростью месяц\час...
а на другой год\полчаса...
[snapback]74344" rel="nofollow" target="_blank[/snapback]?[/quote]

А я видел базу, где в документе Реализация остатки рассчитвались черным запросом в цикле на каждую строчку документа
Какой месяц-год...тут всё от конфигурации зависит, но ИМХО стандартный механизм проведения документов (да и восстановления ГП) убог.

Да и к тому же, если в некоторых расходных документах партия выбиралась вручную (если конечно же есть партионка и есть возможность выбора партии), то однозначно у них будет пересортица (приходы задним числом, перепроведение расходов будущей датой и т.п.).
Поентому я бы в механизьм перепроведения вставил еще и очистку партий в документах.
0
0 / 0 / 1
Регистрация: 15.05.2014
Сообщений: 7
02.08.2007, 16:59 13
Для: Connic
В конфигураторе 1С есть замечательный пункт в меню: "Администрирование->Сохранить данные..."
Рекомендую пользоваться им почаще.
0
omdy79
02.08.2007, 17:09 14
Помогите пожалуйста. Конфигурация Бухучет. Сельхозпредприятие ред.3. Проблема при проводке документов привес животных, перевод, списание животных. Не проводит документ. До этого в прошлом месяце все работало. А в этом отказывается проводить. Не могу понять причину. Но по моему не тянет на счет К11 головы
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
02.08.2007, 23:54 15
Для: Andi79

Хм...думаю, никто из присутствующих здесь не видел в глаза ни разу конфигурации, заточенной под сельхозпредприятие :D

Ищите программиста, приглашайте, сделает.
0
0 / 0 / 1
Регистрация: 15.05.2014
Сообщений: 7
03.08.2007, 07:44 16
Для: LSH
Я видел: обычная Типовая конфигурация Бухучета с добавленной dll-кой и кучей дополнительных документов, большинство из которых до конца не отлажены. Сама конфигурация довольно такие сырая. Когда связались с фирмой (Rarus (хотя точного названия не помню)) там сказали что это побочный продукт, занимается этим от силу один программист, обновления выходят в лучшем случае раз в полгода. Так что врядли программиста найдете под такую конфу.
PS: Своим клиентам (на прошлом месте работы) мы поменяли им конфигурацию на типовую бухгалтерию и дописали необходимые отчеты.
0
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 38
05.08.2007, 09:56 17
<!--QuoteBegin-Andi79+3:08:2007, 14:56 -->
<span class="vbquote">(Andi79 @ 3:08:2007, 14:56 )</span><!--QuoteEBegin-->Помогите пожалуйста. Конфигурация Бухучет. Сельхозпредприятие ред.3. Проблема при проводке документов привес животных, перевод, списание животных. Не проводит документ. До этого в прошлом месяце все работало. А в этом отказывается проводить. Не могу понять причину. Но по моему не тянет на счет К11 головы
[snapback]74389" rel="nofollow" target="_blank[/snapback]?[/quote]

Что значит не проводит - выдает ошибку, выдает сообщение, выдает предупреждение ?
0
omdy79
05.08.2007, 10:03 18
В том то и дело что выдается пустое сообщение. В строке где должно быть указание на ошибку пусто.
Вот полный текст модуля
////////////////////////////////////////////////////////////////////////////////
// ПРЕДОПРЕДЕЛЕННЫЕ ПРОЦЕДУРЫ
//

//************************************************************ *****************
// Предопределенная процедура
//
Процедура ОбработкаПроведения()

Если МестоХранения.Выбран() = 0 Тогда
ТекстСообщения = "Не указана Ферма!";
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;

Сч20 = СчетПоКоду("20.2");

Если ПривесПриплод=1 Тогда
ДвижениеЖивотных=Перечисление.ДвижениеЖивотных.Привес;
СодержаниеПроводки="Привес животных";
Иначе
ДвижениеЖивотных=Перечисление.ДвижениеЖивотных.Приплод;
СодержаниеПроводки="Приплод животных";
КонецЕсли;

спПарам = СоздатьОбъект("СписокЗначений");
спПарам.Установить("ДвижениеЖивотных", ДвижениеЖивотных);
спПарам.Установить("СодержаниеПроводки", СодержаниеПроводки);

ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
ТекстСообщения="";
СчетЖивотных=ОпределитьСубсчет11(Товар,ТекстСообщения);
Если СчетЖивотных=0 Тогда
Сообщить(ТекстСообщения);
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;

Если Масса=0 Тогда
ТекстСообщения = "Не указана масса "+Товар;
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;

Если ПривесПриплод > 1 Тогда
Если Количество=0 Тогда
ТекстСообщения = "Не указан приплод в головах для "+Товар;
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;
КонецЕсли;

Если ПривесПриплод=1 Тогда
Если Количество<>0 Тогда
ТекстСообщения = "Для привеса указан приплод для "+Товар;
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;
КонецЕсли;

// поступление животных по балансу
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ЖВ";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Д*цензура*.Счет = СчетЖивотных;
Операция.СодержаниеПроводки = СодержаниеПроводки ;
Операция.Д*цензура*.Номенклатура = Товар;
Операция.Д*цензура*.МестаХранения= МестоХранения;
Операция.Д*цензура*.ДвижениеЖивотных = ДвижениеЖивотных;
Операция.Количество=Масса;
Операция.Кредит.Счет = Сч20;
Операция.Кредит.ВидыНоменклатуры = Товар.ВидНоменклатуры;
Операция.Кредит.Подразделения= Подразделение;
Операция.Кредит.СтатьиЗатратНаПроизводство= СтатьяЗатрат;
Операция.Сумма = Всего;

Если ПривесПриплод > 1 Тогда
Если глДопПроведение(Контекст, спПарам) = 0 Тогда
глНеПроводить(Контекст, "");
Возврат;
КонецЕсли;
КонецЕсли;(если эту часть заремовать он проводит документ частично. На счет 11 массу проводит а на забалансовыйК11 головы не попадают) КонецЦикла;

Операция.Записать();

ТекстСообщения = "Документ проведен.";
глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);
глПриПроведении(Контекст);


КонецПроцедуры // ОбработкаПроведения()
0 / 0 / 0
Регистрация: 22.04.2010
Сообщений: 38
05.08.2007, 10:16 19
<!--QuoteBegin-Andi79+6:08:2007, 07:50 -->
<span class="vbquote">(Andi79 @ 6:08:2007, 07:50 )</span><!--QuoteEBegin-->Если ПривесПриплод > 1 Тогда
Если глДопПроведение(Контекст, спПарам) = 0 Тогда
глНеПроводить(Контекст, "");
Возврат;
КонецЕсли;
КонецЕсли;(если эту часть заремовать он проводит документ частично. На счет 11 массу проводит а на забалансовыйК11 головы не попадают)
[snapback]74498" rel="nofollow" target="_blank[/snapback]?[/quote]

Попробуйте просмотреть в отладчике процедуру глДопПроведение(Контекст, спПарам) почему она = 0
больше к сожелению посоветовать ничего немогу так как у меня релиз конф. 11 и МлдульДокумента другой

может стоит обновить конфигурацию
0
0 / 0 / 1
Регистрация: 15.05.2014
Сообщений: 7
06.08.2007, 13:01 20
Для: Andi79

[/quote]
<!--QuoteBegin-Andi79+6:08:2007, 07:50 -->
<span class="vbquote">(Andi79 @ 6:08:2007, 07:50 )</span><!--QuoteEBegin-->глДопПроведение(Контекст, спПарам)
[snapback]74498" rel="nofollow" target="_blank[/snapback]?[/quote]
А код этой функции можно?
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.08.2007, 13:01

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Проблема
3 дня назад подключил wifi,после этого начались такие проблемы,когда захожу на сервер программы...

Проблема с VJ++
Posle dolgih mucheniy postavil nakonec-to VJ++6 no vot beda, pohoge et u menja nepolnaja versija -...

Проблема
Есть прога unit MainForm; interface uses Windows, Messages, SysUtils, Variants, Classes,...

Информация не отправляется в базу данных
Здравствуйте, помогите решить проблему, раньше это делал в лёгкую, сейчас не могу понять в чём...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.