Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/40: Рейтинг темы: голосов - 40, средняя оценка - 4.80
otturkryy
1

Цикл Для Подсчета Записей В Таблице

14.05.2014, 09:24. Просмотров 7345. Ответов 10
Метки нет (Все метки)

Помогите добавить в код:
Процедура Кнопка4 - формирует отчет исходя из: сотрудника и ведомого им контрагента. Выдав в виде таблицы всех пациент из базы, проходящих по этому контрагенту за период.
Процедура Кнопка1 - формирует другой отчет в общем виде: сотрудники и ведомые за ними контрагенты.
Можно ли пересчитать количество пациентов, проходящих по контрагенту, и падающих в отчет по Кнопке4, в дополнительный столбец общего отчета : (кнопка1)
????
Здесь код обеих процедур, но куда добавить цикл, считающий пациентов ?


.SpoilerTarget">Спойлер: Раскрывающийся Текст
Процедура Кнопка4Нажатие(Элемент)

ТабДок = Новый ТабличныйДокумент();
Макет = ПолучитьМакет("Макет");

Область = Макет.ПолучитьОбласть("Шапка");
Область.Параметры.УслП = "Отчет по оказанным услугам юр. лицам за период с " + Строка(НачПериода) + " по " + Строка(КонПериода);

Если ПолеВвода1.Пустая() Тогда
Область.Параметры.Стр2 = "По всем организациям";
Иначе
Область.Параметры.Стр2 = "Организация: " + Строка(ПолеВвода1);
КонецЕсли;

Если ПолеВвода3.Пустая() Тогда
Область.Параметры.Стр3 = "";
Иначе
Область.Параметры.Стр3 = "Менеджер по продажам: " + Строка(ПолеВвода3);
КонецЕсли;

Если ПолеВвода4.Пустая() Тогда
Область.Параметры.Стр4 = "";
Иначе
Область.Параметры.Стр4 = "Менеджер поддержки: " + Строка(ПолеВвода4);
КонецЕсли;

ТабДок.Вывести(Область);


Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| СУММА(НазначениеНаОсмотр.СуммаДокумента) КАК СуммаДокумента,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Код КАК Код,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Наименование КАК Владелец,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка КАК ВладелецСсылка,
| НазначениеНаОсмотр.Организация.Ссылка,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам КАК МенПрод,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки КАК МенПодд
|ИЗ
| Документ.НазначениеНаОсмотр КАК НазначениеНаОсмотр
|ГДЕ
| НазначениеНаОсмотр.Дата >= &ДатаНач
| И НазначениеНаОсмотр.Дата <= &ДатаКон
| И НазначениеНаОсмотр.Проведен = &Истина
| И НазначениеНаОсмотр.ВыставитьКОплате = &Ист
| И НазначениеНаОсмотр.ОсновнойДоговор.ВидДоговора = &ВидДог";



Если не ПолеВвода1.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.Организация.Ссылка = &Орг";
КонецЕсли;
Запрос.УстановитьПараметр("Орг", ПолеВвода1);

Если не ПолеВвода2.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка = &Контрагент";
КонецЕсли;
Запрос.УстановитьПараметр("Контрагент", ПолеВвода2);

Если не ПолеВвода3.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам = &Мен1";
КонецЕсли;
Запрос.УстановитьПараметр("Мен1", ПолеВвода3);

Если не ПолеВвода4.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки = &Мен2";
КонецЕсли;
Запрос.УстановитьПараметр("Мен2", ПолеВвода4);



Запрос.Текст = Запрос.Текст +
"
|СГРУППИРОВАТЬ ПО
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Код,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Наименование,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка,
| НазначениеНаОсмотр.Организация.Ссылка,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки
|
|УПОРЯДОЧИТЬ ПО
| Владелец";


Запрос.УстановитьПараметр("ДатаНач", НачПериода);
Запрос.УстановитьПараметр("ДатаКон", КонПериода);
Запрос.УстановитьПараметр("Истина", Истина);
Запрос.УстановитьПараметр("Ист", Ложь);
Запрос.УстановитьПараметр("ВидДог", Перечисления.ВидДоговора.Предприятие);


Результат = Запрос.Выполнить().Выбрать();

н = 1;
СумОбщ = 0;
Пока Результат.Следующий() цикл

Область = Макет.ПолучитьОбласть("Строка");
Область.Параметры.н = н;
Область.Параметры.КонтрагентП = Результат.Владелец;
Область.Параметры.СуммаП = Результат.СуммаДокумента;
Область.Параметры.МенПродП = Результат.МенПрод;
Область.Параметры.ЭкономистП = Результат.МенПодд;
СумОбщ = СумОбщ + Результат.СуммаДокумента;

ТабДок.Вывести(Область);
н = н + 1;

КонецЦикла;

Область = Макет.ПолучитьОбласть("Подвал");
Область.Параметры.СумОбщП = СумОбщ;
ТабДок.Вывести(Область);

Табдок.Показать("Краткий финансовый отчет");

КонецПроцедуры

Процедура ПриОткрытии()

Орг = Справочники.Организации.Выбрать();
Пока Орг.Следующий() Цикл
Если Орг.Основная = Истина Тогда

ПолеВвода1 = Орг.Ссылка;
Прервать;

КонецЕсли;
КонецЦикла;
ЭлементыФормы.Флажок1.Значение = Ложь;

КонецПроцедуры




Процедура Кнопка1Нажатие(Элемент)

Если ПолеВвода2.Пустая() Тогда
Предупреждение("Не заполнено поле контрагент");
Возврат;
КонецЕсли;

ТабДок = Новый ТабличныйДокумент();
Макет = ПолучитьМакет("Макет1");

Область = Макет.ПолучитьОбласть("Шапка");
Область.Параметры.УслП = "Отчет по оказанным услугам юр. лицам за период с " + Строка(НачПериода) + " по " + Строка(КонПериода);

Если ПолеВвода1.Пустая() Тогда
Область.Параметры.КонтрП = "По всем организациям";
Иначе
Область.Параметры.КонтрП = "Организация: " + Строка(ПолеВвода1);
КонецЕсли;

Если ПолеВвода3.Пустая() Тогда
Область.Параметры.Стр3 = "";
Иначе
Область.Параметры.Стр3 = "Менеджер по продажам: " + Строка(ПолеВвода3);
КонецЕсли;

Если ПолеВвода4.Пустая() Тогда
Область.Параметры.Стр4 = "";
Иначе
Область.Параметры.Стр4 = "Менеджер поддержки: " + Строка(ПолеВвода4);
КонецЕсли;

ТабДок.Вывести(Область);

// ********************************************************************************
*******************************************




Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| СУММА(НазначениеНаОсмотр.СуммаДокумента) КАК СуммаДокумента,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Код КАК Код,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Наименование КАК Владелец,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка КАК ВладелецСсылка,
| НазначениеНаОсмотр.Организация.Ссылка,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам КАК МенПрод,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки КАК МенПодд
|ИЗ
| Документ.НазначениеНаОсмотр КАК НазначениеНаОсмотр
|ГДЕ
| НазначениеНаОсмотр.Дата >= &ДатаНач
| И НазначениеНаОсмотр.Дата <= &ДатаКон
| И НазначениеНаОсмотр.Проведен = &Истина
| И НазначениеНаОсмотр.ВыставитьКОплате = &Ист
| И НазначениеНаОсмотр.ОсновнойДоговор.ВидДоговора = &ВидДог";



Если не ПолеВвода1.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.Организация.Ссылка = &Орг";
КонецЕсли;
Запрос.УстановитьПараметр("Орг", ПолеВвода1);

Если не ПолеВвода2.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка = &Контрагент";
КонецЕсли;
Запрос.УстановитьПараметр("Контрагент", ПолеВвода2);

Если не ПолеВвода3.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам = &Мен1";
КонецЕсли;
Запрос.УстановитьПараметр("Мен1", ПолеВвода3);

Если не ПолеВвода4.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки = &Мен2";
КонецЕсли;
Запрос.УстановитьПараметр("Мен2", ПолеВвода4);



Запрос.Текст = Запрос.Текст +
"
|СГРУППИРОВАТЬ ПО
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Код,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Наименование,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка,
| НазначениеНаОсмотр.Организация.Ссылка,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки";


Запрос.УстановитьПараметр("ДатаНач", НачПериода);
Запрос.УстановитьПараметр("ДатаКон", КонПериода);
Запрос.УстановитьПараметр("Истина", Истина);
Запрос.УстановитьПараметр("Ист", Ложь);
Запрос.УстановитьПараметр("ВидДог", Перечисления.ВидДоговора.Предприятие);


Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() цикл

Область = Макет.ПолучитьОбласть("Строка");
Область.Параметры.КонтрагентП = Результат.Владелец;
Область.Параметры.СуммаП = Результат.СуммаДокумента;


ТабДок.Вывести(Область);

КонецЦикла;



// ********************************************************************************
********************






Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| НазначениеНаОсмотр.СуммаДокумента КАК СуммаДокумента,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Код КАК Код,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Наименование КАК Владелец,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка КАК ВладелецСсылка,
| НазначениеНаОсмотр.Организация.Ссылка,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам КАК МенПрод,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки КАК МенПодд,
| НазначениеНаОсмотр.Ссылка КАК СсылкаДок,
| НазначениеНаОсмотр.Пациент.Наименование КАК Пациент
|ИЗ
| Документ.НазначениеНаОсмотр КАК НазначениеНаОсмотр
|ГДЕ
| НазначениеНаОсмотр.Дата >= &ДатаНач
| И НазначениеНаОсмотр.Дата <= &ДатаКон
| И НазначениеНаОсмотр.Проведен = &Истина
| И НазначениеНаОсмотр.ВыставитьКОплате = &Ист
| И НазначениеНаОсмотр.ОсновнойДоговор.ВидДоговора = &ВидДог";

Если не ПолеВвода1.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.Организация.Ссылка = &Орг";
КонецЕсли;
Запрос.УстановитьПараметр("Орг", ПолеВвода1);

Если не ПолеВвода2.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка = &Контрагент";
КонецЕсли;
Запрос.УстановитьПараметр("Контрагент", ПолеВвода2);

Если не ПолеВвода3.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам = &Мен1";
КонецЕсли;
Запрос.УстановитьПараметр("Мен1", ПолеВвода3);

Если не ПолеВвода4.Пустая() Тогда
Запрос.Текст = Запрос.Текст + "
| И НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки = &Мен2";
КонецЕсли;
Запрос.УстановитьПараметр("Мен2", ПолеВвода4);


Запрос.УстановитьПараметр("ДатаНач", НачПериода);
Запрос.УстановитьПараметр("ДатаКон", КонПериода);
Запрос.УстановитьПараметр("Истина", Истина);
Запрос.УстановитьПараметр("Ист", Ложь);
Запрос.УстановитьПараметр("ВидДог", Перечисления.ВидДоговора.Предприятие);


Результат = Запрос.Выполнить().Выбрать();

к = 1;
Пока Результат.Следующий() цикл

Область = Макет.ПолучитьОбласть("Строка2");
Область.Параметры.к1 = к;
Область.Параметры.ДокП = Результат.СсылкаДок;
Область.Параметры.СуммаДокП = Результат.СуммаДокумента;
Область.Параметры.ПациентП = Результат.Пациент;

ТабДок.Вывести(Область);



Если Флажок1 = Истина Тогда

ДокОб = Результат.ССылкаДок.ПолучитьОбъект();
Для Каждого СтрТЧ из ДокОб.Услуги Цикл

Область = Макет.ПолучитьОбласть("Документы");
Область.Параметры.УслугаП = СтрТЧ.Услуга;
Область.Параметры.СотрП = СтрТЧ.Сотрудник;
Область.Параметры.СпециальностьП = СтрТЧ.СпециализацияВрача;
Область.Параметры.ЦенаЗаУслП = СтрТЧ.Цена;

ТабДок.Вывести(Область);

КонецЦикла;


КонецЕсли;




к = к + 1;

КонецЦикла;

Табдок.Показать("Развернутый финансовый отчет");



КонецПроцедуры

Процедура ВыбПериодНажатие(Элемент)
НастройкаПериода = Новый НастройкаПериода;
НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода=0001-01-01, КонПериода, КонецДня(КонПериода)));
НастройкаПериода.РедактироватьКакИнтервал = Истина;
НастройкаПериода.РедактироватьКакПериод = Истина;
НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
Если НастройкаПериода.Редактировать() Тогда
НачПериода = НастройкаПериода.ПолучитьДатуНачала();
КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
КонецЕсли;
КонецПроцедуры


НачПериода = НачалоМесяца(ТекущаяДата());
КонПериода = ТекущаяДата();
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.05.2014, 09:24
Ответы с готовыми решениями:

Цикл для подсчета записей в таблице
Помогите добавить в код: Процедура Кнопка4 - формирует отчет исходя из: сотрудника и ведомого им...

Цикл для нумерации записей в таблице
Народ подскажите как написать цикл нумерации записей в таблице? Добавлено через 17 минут у меня...

Цикл по одной таблице и обновление соответствующих записей в другой
Всем привет!!! Вопрос наверное совсем новичковый ... нужно в цикле пройтись по записям таблицы А1...

Цикл для подсчета строк ф файле.
какой цикл надо задать чтобы из файла читалось столько строк сколько есть в файле..именно строк а...

10
Vtodot
0 / 0 / 0
Регистрация: 21.05.2012
Сообщений: 22
17.05.2014, 23:57 2
Очень много кода.
Навскидку - подсчет пациентов (как и любых количественных показателей) лучше добавить в секцию запроса ИТОГИ. А там уже указать по каким группировкам считать итоги, а также считать ли общие или нет.

Код ( (Unknown Language)):
"ВЫБРАТЬ
| НазначениеНаОсмотр.СуммаДокумента КАК СуммаДокумента,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Код КАК Код,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Наименование КАК Владелец,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.Ссылка КАК ВладелецСсылка,
| НазначениеНаОсмотр.Организация.Ссылка,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоПродажам КАК МенПрод,
| НазначениеНаОсмотр.ОсновнойДоговор.Владелец.МенеджерПоддержки КАК МенПодд,
| НазначениеНаОсмотр.Ссылка КАК СсылкаДок,
| НазначениеНаОсмотр.Пациент.Наименование КАК Пациент
|ИЗ
| Документ.НазначениеНаОсмотр КАК НазначениеНаОсмотр
|ГДЕ
| НазначениеНаОсмотр.Дата >= &ДатаНач
| И НазначениеНаОсмотр.Дата <= &ДатаКон
| И НазначениеНаОсмотр.Проведен = &Истина
| И НазначениеНаОсмотр.ВыставитьКОплате = &Ист
| И НазначениеНаОсмотр.ОсновнойДоговор.ВидДоговора = &ВидДог
|ИТОГИ ПО // ----------------------------------------------------------------
| ОБЩИЕ,
| НазначениеНаОсмотр.Пациент // ---------------------------------------";
Костыль, конечно.
Я бы добавил регистр оборотов для фиксирования обращений пациентов и их взаимодействия с сотрудниками и уже из регистра выбирал необходимые мне сведения.
Для общего развития рекомендую проработать книгу Радченко "Практическое пособие разработчика" по соответствующей версии 1С. Для простых форм - по версии 8.1, для управляемых - по версии 8.2.
Он очень хорошо описывает теорию и примеры. Пример из книги - отчет по мастерам.
0
otturkryy
20.05.2014, 16:39 3
Цитата Сообщение от Vladal
Очень много кода.
Привел на всякий случай весь модуль.
А вот эта часть:


Результат = Запрос.Выполнить().Выбрать();

к = 1;
Пока Результат.Следующий() цикл

Область = Макет.ПолучитьОбласть("Строка2");
Область.Параметры.к1 = к;
Область.Параметры.ДокП = Результат.СсылкаДок;
Область.Параметры.СуммаДокП = Результат.СуммаДокумента;
Область.Параметры.ПациентП = Результат.Пациент;

ТабДок.Вывести(Область);

Если Флажок1 = Истина Тогда

ДокОб = Результат.ССылкаДок.ПолучитьОбъект();
Для Каждого СтрТЧ из ДокОб.Услуги Цикл

Область = Макет.ПолучитьОбласть("Документы");
Область.Параметры.УслугаП = СтрТЧ.Услуга;
Область.Параметры.СотрП = СтрТЧ.Сотрудник;
Область.Параметры.СпециальностьП = СтрТЧ.СпециализацияВрача;
Область.Параметры.ЦенаЗаУслП = СтрТЧ.Цена;

ТабДок.Вывести(Область);

КонецЦикла;
КонецЕсли;
к = к + 1;

КонецЦикла;
Где в цикле идет итоговый продсчет построчно, и увеличивается переменная k : можно ли использовать ЭТУ часть кода (считающую итоговую сумму по кокретному сотруднику) для счета и контрагентов по этому сотруднику, но на печать не выводить, а продублировать код в другую часть модуля, для искомого отчета, и так уже полученное значение выводить на печать ?
Дийнеки
0 / 0 / 0
Регистрация: 15.11.2009
Сообщений: 947
22.05.2014, 15:57 4
Цитата Сообщение от Артур56
Привел на всякий случай весь модуль.
Хотел ответить, но т.к. за 3 мин. ничего не понял. Передумал.
0
Dortosk
0 / 0 / 0
Регистрация: 23.04.2010
Сообщений: 553
28.05.2014, 01:32 5
Доброго времени суток.
Во-первых: за
ДокОб = Результат.ССылкаДок.ПолучитьОбъект();

убивают неглядя.


Во-вторых: Раз у вас 8.2 то проще использовать механизмы СКД, у них есть свои функции подсчета количества строк внутри группировки. А дальше уже обрабатывать сам результат до вывода на экран.
0
tomot
0 / 0 / 0
Регистрация: 02.03.2007
Сообщений: 272
28.05.2014, 11:35 6
Доброго времени суток.
Во-первых: за
ДокОб = Результат.ССылкаДок.ПолучитьОбъект();

убивают неглядя.


- а что тут криминального? Я, видимо, отстал от жизни, раз не знаю...
0
Dortosk
0 / 0 / 0
Регистрация: 23.04.2010
Сообщений: 553
29.05.2014, 10:31 7
Цитата Сообщение от tanat
Доброго времени суток.
Во-первых: за
ДокОб = Результат.ССылкаДок.ПолучитьОбъект();

убивают неглядя.


- а что тут криминального? Я, видимо, отстал от жизни, раз не знаю...
А криминально то, что "ПолучитьОбъект()" - норма для 7.7, но для 8.х это запрещено для простого перебора строк табличной части документа. Посмотрите стандарты к разработки для 8.х.
0
tomot
0 / 0 / 0
Регистрация: 02.03.2007
Сообщений: 272
29.05.2014, 18:40 8
Ах вонаначё. Я ж грешным образом подумал, что появился какой-то новый метод получения объекта, а я весь в неведении...
0
Dortosk
0 / 0 / 0
Регистрация: 23.04.2010
Сообщений: 553
29.05.2014, 21:04 9
А его надо получать? )))))
0
tomot
0 / 0 / 0
Регистрация: 02.03.2007
Сообщений: 272
30.05.2014, 09:16 10
Мы говорим о получении объекта в контексте данной задачи или вообще? Если в данной - то нет, если вообще - то да. Мне,например, очень интересно, каким образом без получения объекта Вы сможете, к примеру, провести документ программно.
0
Dortosk
0 / 0 / 0
Регистрация: 23.04.2010
Сообщений: 553
30.05.2014, 12:54 11
Ну вроде как 1 задача - 1 тема. А вообще никак, вроде.
0
30.05.2014, 12:54
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.05.2014, 12:54

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

цикл для подсчета элементов списка
Как напистаь цикл для подсчета элементов списка, как получить доступ к К-элементу списка, где К=1...

Цикл для подсчета элементов суммы вектора
Есть вектор длиной 1х2669 , нужно найти подсчет значений больше 20 и записать их в отдельном цикле...

Цикл для подсчёта количества максимальных чисел
Дано 20 действительных чисел. Определить сколько из них принимают максимальное значение....

Цикл для подсчета наибольшего произведения в стобцах
Всем доброго утра(дня). Мне нужно было написать программу, которая создает двумерный массив и...

Как правильно сделать запрос к MySQL для подсчета записей
Всем привет. Сделал себе вот такой вывод всех категорий на главной странице сайта (CMS DLE):...

Организуйте цикл для подсчета суммы 20 первых натуральных чисел вида (2n-2)
Ассемблер задание &quot;Организуйте цикл для подсчета суммы 20 первых натуральных чисел вида (2n-2)&quot;...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.