Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.70/77: Рейтинг темы: голосов - 77, средняя оценка - 4.70
sosty
1

Записать те товары в документ

03.06.2010, 20:54. Просмотров 13878. Ответов 7
Метки нет (Все метки)

для каждого контрагента забивается все товары, т.е. не учитывается какой контрагент указан, как сделать так чтобы он учитывал контрагента и выгружал те товары которые он заказал?

Для Каждого СтрокаДанных Из СоответствияТоваров Цикл
НоваяСтрока = ДокументОбъект.Товары.Добавить ();

Имя = СтрокаДанных.Наименование;
СправочникНоменклатура = Справочники.Номенклатура.Найти ПоНаименованию(Имя);
НоваяСтрока.Номенклатура = СправочникНоменклатура.Ссылка;
НоваяСтрока.Количество = СтрокаДанных.Количество;
НоваяСтрока.Цена = СтрокаДанных.Цена;


КонецЦикла;
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.06.2010, 20:54
Ответы с готовыми решениями:

Документ ПриходТовара: выбрать в таблице из Справочник.Товары
Собственно, пришлось разбиратся в 1С. И так, входные данные: Есть Справочник.Товары Его...

Какой документ свидетельствует, что приобретенные товары попали на склад предприятия?
Какой документ свидетельствует, что приобретенные товары попали на склад предприятия?

Записать дату в документ
привет! помогите, пожалуйста разобраться. необходимо записать дату в блок div. пробовала разные...

Ui-документ, записать данные
Есть БД-1, в ней открыт документ. В БД-2 есть копия этого документа, как только пришло...

7
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
03.06.2010, 21:36 2
Цитата Сообщение от cacti
для каждого контрагента забивается все товары, т.е. не учитывается какой контрагент указан, как сделать так чтобы он учитывал контрагента и выгружал те товары которые он заказал?
:*цензура*you:
Слова не согласованы, кто "он" должен учитывать не понятно...
Косяк забить - это хорошо, но причем тут 1С?

PS Кто придумал такое обозначение смайлику "Да ну вас!", вдруг кто-то в текстовом режиме смотрит??
0
sosty
03.06.2010, 21:49 3
так..создается документ ЗаказПокупателя, заполняются поля номенклатура, контрагент, организация, количество, цена. в поле Номенклатура добавляются все товары, которые в ТЗ. Как сделать чтобы создавался документ для каждого контрагента и заполнялись только те товары, которые относятся к этому контрагенту.
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
03.06.2010, 22:23 4
Угумс... ЗагрузитьВнешнююКомпоненту(tel epat.dll)
Значит, у вас есть обработка, которая программно создает документ. И вероятно в ней есть код. Следует его проанализировать.
А :( , для начала? Есть умение пользоваться операторами "Если ... иначе..."
Код можете выложить даже)
0
sosty
03.06.2010, 22:49 5
можно сказать что я профан)) новичок.просто сижу разбираюсь и пытаюсь что то сделать. я так понимаю мне надо использовать оператор Пока..т.е. т.е. цикл нужен проходит по всех таблице смотрит какие контрагенты одинаковы по ним записывает данные. но как сделать Цикл?
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
03.06.2010, 23:28 6
Код киньте из модуля.
0
sosty
04.06.2010, 01:43 7
Функция СоздатьЗаказТоваров(СтрокаДанн ых)
ДокументОбъект = Документы.ЗаказПокупателя.Созд атьДокумент();


сИмя = СтрокаДанных.Склад;
оИмя = СтрокаДанных.Контрагент;
кИмя = СтрокаДанных.ФИО;

СправочникКонтрагент = Справочники.Контрагенты.НайтиП оНаименованию(кИмя);
СправочникСклад = Справочники.Склады.НайтиПоНаим енованию(сИмя);
СправочникОрганизация = Справочники.Организации.НайтиП оНаименованию(оИмя);

Для Каждого СтрокаДанных Из СоответствияТоваров Цикл

ДокументОбъект.Контрагент = СправочникКонтрагент.Ссылка;
НоваяСтрока = ДокументОбъект.Товары.Добавить ();
Имя = СтрокаДанных.Наименование;
СправочникНоменклатура = Справочники.Номенклатура.Найти ПоНаименованию(Имя);
НоваяСтрока.Номенклатура = СправочникНоменклатура.Ссылка;
НоваяСтрока.Количество = СтрокаДанных.Количество;
НоваяСтрока.Цена = СтрокаДанных.Цена;
ДокументОбъект.Дата=ТекущаяДат а();

КонецЦикла;
Возврат ДокументОбъект;

КонецФункции


и при нажатии кнопки вызывается функция


Процедура Создать(Кнопка)

Для Каждого СтрокаТаблицы Из СоответствияТоваров Цикл
Если ЗначениеЗаполнено(СтрокаТаблиц ы.Номенклатура) Тогда
Продолжить;
Иначе

ДокументОбъект = СоздатьЗаказТоваров(СтрокаТабл ицы);

КонецЕсли;


Попытка

ДокументОбъект.Записать();

Исключение
Сообщить("Ошибка");


Продолжить;
КонецПопытки;

КонецЦикла;

КонецПроцедуры
0 / 0 / 0
Регистрация: 23.04.2010
Сообщений: 553
04.06.2010, 14:27 8
1) Это что такое?


Цитата Сообщение от cacti
СправочникКонтрагент = Справочники.Контрагенты.НайтиП оНаименованию(кИмя);
СправочникСклад = Справочники.Склады.НайтиПоНаим енованию(сИмя);
СправочникОрганизация = Справочники.Организации.НайтиП оНаименованию(оИмя);
У вас документе эти 3 реквизита строки? или все таки ссылки?

2) вместо перебора циклом (строк может быть от 1 до хз сколько) используйте запрос.

В идеале в запросе сделать итоги по контрагенту. А потом уже полученную выборку перебирать циклом.


Добавлено: А еще лучше, выложить здесь обработку свою и конкретнее сформулировать вопрос. Что-то типа:
"на форме у меня 3 реквизита "Склад", "Контрагент", "Организация".
"Так же есть таблица с номенклатурой, ценой, ...".

"Нужно чтоб формировались документы для каждого контрагента со своим товаров". (предполагаю, что контрагент в таблице присутствует)



Цитата Сообщение от unknown181538
Угумс... ЗагрузитьВнешнююКомпоненту(tel epat.dll)
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
04.06.2010, 14:27

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Записать строку в xml документ
Приветствую всех, столкнулся проблемой записи длинной строки. Так записывается у меня обычный файл...

Записать данные в документ Word
Ув.программисты кто работал с Word через с++ подскажите как можно внести в шаблон надпись из...

записать документ сразу после его создания
Возможно, суперламерский вопрос, но очень нужен Ваш совет. Итак, дано: есть документ с тремя...

Прочитать документ Excel и данные записать в структуру
Доброго времени, форумчане. Начал работать с Excel через C#. Необходимо считать документ и данные...

Как записать элементы вектора в текстовый документ?
Как сделать так чтобы при включение программы текст в файле не стирался, а например добавлялся к...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.