0 / 0 / 0
Регистрация: 25.05.2010
Сообщений: 22
1

помогитееее, глупая ошибка, но не могу выявить причину

29.05.2010, 01:52. Показов 11276. Ответов 1
Метки нет (Все метки)

Помогите пожалуйста, при проводке Начисления зарплаты у меня вылезает ошибка Преобразование значения к типу Число не может быть выполнено


Код ( (Unknown Language)):
Процедура РасчитатьНачисления(НаборЗаписейРегистра, ТребуемыйВидРасчета, СписокПерсонала) Экспорт
Регистратор=НаборЗаписейРегистра.Отбор.Регистратор .Значение;
//Рассчитать первичные записи
Если ТребуемыйВидРасчета=ПланыВидовРасчета.ВидыНачислен ий.Оклад тогда

Запрос=Новый Запрос;
Запрос.Текст=
"Выбрать
|НачисленияДанныеГрафика.ЗначениеПериодДействия КАК Норма,
|НачисленияДанныеГрафика.ЗначениеФактическийПериод Действия КАК Факт,
| НачисленияДанныеГрафика.НомерСтроки КАК НомерСтроки
|ИЗ
| РегистрРасчета.Начисления.ДанныеГрафика(Регистрато р=&Регистратор И
| ВидРасчета=&ВидРасчета И
| Персонал В(&СписокПерсонала))
| Как НачисленияДанныеГрафика";

Запрос.УстановитьПараметр("Регистратор",НаборЗапис ейРегистра.Отбор.Регистратор.Значение);
Запрос.УстановитьПараметр("ВидРасчета",ТребуемыйВи дРасчета);
Запрос.УстановитьПараметр("СписокПерсонала", СписокПерсонала);
ВыборкаРезультата=Запрос.Выполнить().Выбрать();
Для Каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл
СтруктураНомер=Новый Структура("НомерСтроки");
СтруктураНомер.НомерСтроки=ЗаписьРегистра.НомерСтр оки;
ВыборкаРезультата.Сбросить();
Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер) тогда
Если ВыборкаРезультата.Норма=0 тогда
Сообщить("ВидРасчета:Оклад-Нет Рабочих дней в заданном периоде",);
ЗаписьРегистра.Результат=0;
Иначе
//Рассчитать оклад по фактическому периоду и исходным данным
ЗаписьРегистра.Результат =(ЗаписьРегистра.ИсходныеДанные/ВыборкаРезультата.Норма)*ВыборкаРезультата.Факт; //<-------------------------тут ошибка-------------
Сообщить("Выполнен расчет"+ЗаписьРегистра.Регистратор+"-"+ ЗаписьРегистра.ВидРасчета+"-"+ЗаписьРегистра.Персонал,);
КонецЕсли;
КонецЕсли;
КонецЦикла;


//Рассчитать вторичные записи
иначеЕсли ТребуемыйВидРасчета=ПланыВидовРасчета.ВидыНачислен ий.Премия тогда
Запрос= Новый Запрос;
Запрос.Текст =
"Выбрать
| НачисленияБазаНачисления.РезультатБаза КАК База,
| НачисленияБазаНачисления.НомерСтроки КАК НомерСтроки
|ИЗ
| РегистрРасчета.Начисления.БазаНачисления(&Измерени яОсновного,
| &ИзмеренияБазового,,
| Регистратор=&Регистратор И
| ВидРасчета=&ВидРасчета И
| Персонал В(&СписокПерсонала))
| КАК НачисленияБазаНачисления";

Измер = Новый Массив(1);
Измер[0]="Персонал";
Запрос.УстановитьПараметр("ИзмеренияОсновного", Измер);
Запрос.УстановитьПараметр("ИзмеренияБазового", Измер);
Запрос.УстановитьПараметр("Регистратор", Регистратор);
Запрос.УстановитьПараметр("ВидРасчета", ТребуемыйВидРасчета);
Запрос.УстановитьПараметр("СписокПерсонала", СписокПерсонала);
ВыборкаРезультата=Запрос.Выполнить().Выбрать();
Для Каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл
СтруктураНомер=Новый Структура("НомерСтроки");
СтруктураНомер.НомерСтроки=ЗаписьРегистра.НомерСтр оки;
ВыборкаРезультата.Сбросить();
Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер) тогда
ЗаписьРегистра.Результат=ВыборкаРезультата.База*(1 0/100);
Сообщить("Выполнен расчет"+ЗаписьРегистра.Регистратор+"-"+ЗаписьРегистра.ВидРасчета+"-"+ЗаписьРегистра.Персонал,);
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
Ошибка в ВыборкаРезультата.Норма и ВыборкаРезультата.Факт, Работаю по Родченко
мне кажеться что ошибка не от туда идёт, ао этому выложил бызу (она очень маленькая) очень надо помогите, пожалуйста
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
29.05.2010, 01:52
Ответы с готовыми решениями:

Работа со списками. В чем такая глупая ошибка не могу найти?
В чем такая глупая ошибка не могу найти? program sp; type {Тип основных данных.} TElem=real;...

Как выявить причину исчезновения соединения
У меня adsl линия В последнее время когда захожу на определенные сайты с ноутбука (в т.ч мобильный...

Как выявить причину ошибки рендеринга?
Создал TableLayout. Начал заполнять ячейки. где0то перемудрил. Выдается ошибка (см ниже). Не...

Зависание намертво. Как выявить причину?
Доброго времени суток Проблема - зависание компьютера. Симптомы всегда одинаковые: зависание...

1
0 / 0 / 0
Регистрация: 25.05.2010
Сообщений: 22
29.05.2010, 11:22 2
всё, ошибка найдена. График работы и график выдачи зарплаты не совпадал
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
29.05.2010, 11:22
Помогаю со студенческими работами здесь

Как выявить причину в домашних условиях?
Проблема в том, что с недавнего времени начал тормозить комп при игре( фифа 11) и просмотре...

Помогите разобраться. Нужно выявить причину игнора.
Всем привет. Сегодня не выдержал и решил написать уже Вам.) В общем ситуация такова. Есть...

Ошибка в коде, не могу понять причину
Ошибка в строчке 67: 'p.MESWERT::getEinheit' does not have class type. В чем причина? #include...

глупая задача, никак въехать не могу
Постараюсь вспомнить корректное условие.... Есть n людей, и у каждого человека есть m номер, по...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2023, CyberForum.ru