Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.71/247: Рейтинг темы: голосов - 247, средняя оценка - 4.71
pyrfomomsy
1

Журнал документов + ТЗ

02.09.2009, 12:08. Просмотров 44582. Ответов 33
Метки нет (Все метки)

Всем Хай. В академических целях интересует: Возможно ли в Фоме Журнала документов оганизовать просмотр табличной части текущего документа в расположенной в форме журнала таблице значений. Т.е. при перемещении курсора по списку документов в журнале его табличная часть отображалась бы в подрисованной таблице значений на этом же журнале документов. По аналогии как в журнале операций - журнал разделен на две части - сверху сами записи операций, а при установлении курсора на запись - снизу отображается ее содержимое. У кого какие есть предложения? Касательно платформы 7.7
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
02.09.2009, 12:08
Ответы с готовыми решениями:

журнал документов
как создать внешний журнал документов и новые документы в нем (тоже внешние). а также удаление....

Журнал документов
Доброго времени суток! Помогите решить такую проблему. Есть два документа: договор и приложение...

Журнал документов
Можно ли использовать журнал документов чтобы извлечь информацию с конкретного документа?

журнал документов
Доброго времени суток. Простите за такой простой вопрос, но может кто знает, нельзя ли в 1с 8 при...

33
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
02.09.2009, 12:14 2
В форме журнала
Процедура ПриВыбореСтроки()
ТЗ.Очистить();
ТекущийДокумент.ВыгрузитьТабличнуюЧасть(ТЗ);
КонецПроцедуры
0
pyrfomomsy
02.09.2009, 12:23 3
По описанию процедура ПриВыбореСтроки() не катит . Вот что гласит описание(точнее замечание):"Замечание: Режим обработки выбора строки (двойной щелчок мыши или кла­виша Enter) предопределенной процедурой ПриВыбореСтроки включается в форме списка справочника, журнала, счетов, журнала операций, журна­ла проводок при помощи метода Форма.ОбработкаВыбораСтроки(1).
А задача заключается в том чтобы ТЗ отображала данные при перемещении курсора по форме журнала
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
02.09.2009, 12:29 4
Действительно...

Попробуй добавить в таблицу журнала текстовое поле и ему в "формулу" пропиши вызов процедуры
а само поле сделай невидимым
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
02.09.2009, 21:53 5
Цитата Сообщение от Hryv
Попробуй добавить в таблицу журнала текстовое поле и ему в "формулу" пропиши вызов процедуры
а само поле сделай невидимым
Классная идея. Только не процедуру повесить на это поле, а функцию.
Попробовал на Бух 4.5, мне понравилось, взял на вооружение
0
pyrfomomsy
03.09.2009, 09:12 6
Цитата Сообщение от Hryv
Попробуй добавить в таблицу журнала текстовое поле и ему в "формулу" пропиши вызов процедуры
а само поле сделай невидимым
Сорри за вопрос, но именно какое поле? Т.е. создать какой нито общий "текстовый" реквизит для документов или же "текстовый" реквизит конкретного документа, который будет добавляться в форму журнала?
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
03.09.2009, 09:18 7
Текстовое поле на форме журнала. Никаких реквизитов в документы добавлять не следует.

Кстати, я бы посоветовал использовать не ТЗ, а ТП+ПоставщикДанных из 1С++
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
03.09.2009, 10:48 8
perfomance, текстовое поле, которое есть на панели элементов диалога с синей буквой Т на иконке




Только не процедуру повесить на это поле, а функцию.
а зачем в данном случае функция?
само текстовое поле не будет видно и в него ничего возвращать не надо

или процедура вообще не будет отрабатывать? :mellow:
0
pyrfomomsy
03.09.2009, 11:17 9
Цитата Сообщение от Hryv
perfomance, текстовое поле, которое есть на панели элементов диалога с синей буквой Т на иконке
Понятно....



а зачем в данном случае функция?
само текстовое поле не будет видно и в него ничего возвращать не надо
или процедура вообще не будет отрабатывать? :mellow:
Млин. Ну если попробовать вписать в формулу такого "текстового поля" и в модуле обозвать ее как Процедура, то уже в самой системе выходит ошибка: "Процедура вызывается как функция (ИмяФункции)" в табло.
Функция по определению может вычислять и возвращать определенные значения. Просто в модуле самой Функции которая поместится в текстовое поле надо вписать вызов процедуры , которая именно будет выполнять какие либо операторы (так сказать возбуждаться ) из - за выполняемой каждый раз функции.
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
03.09.2009, 11:46 10
в самой системе выходит ошибка: "Процедура вызывается как функция (ИмяФункции)" в табло.
тогда понятно почему нельзя процедуру
я просто на практике не проверял

perfomance, заработало как ты хотел или нет?
0
pyrfomomsy
03.09.2009, 12:17 11
Цитата Сообщение от Hryv
perfomance, заработало как ты хотел или нет?
Заработало. При следовании курсора по списку документов их табличная часть успешно выгружается в ТЗ , которая подрисована внизу. Использовал метод "ВыгрузитьТабличнуюЧасть (ТЗ, "Реквизиты")". Но вот пока фича в том что ТЗ не дает делать скроллинг. Т.е допустим табличную часть документа згрузили в ТЗ и грубо говоря в табличной части строк 20, а сама ТЗ "Маленького роста". И если у ТЗ захочешь протащить линейкой - то она просто не дает. Как колом. Может это особенность метода "ВыгрузитьТабличнуюЧасть"? наверное при данном методе не создаются строки в ТЗ как таковые. Точно - просто линейка не понимает что ТЗ строки то отображает, а на самом деле их нет.
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
03.09.2009, 12:56 12
А если после ВыгрузитьТабличнуюЧасть дописать Форма.Обновить()
0
pyrfomomsy
03.09.2009, 13:30 13
Цитата Сообщение от Hryv
А если после ВыгрузитьТабличнуюЧасть дописать Форма.Обновить()
Не а - одна фигня. Скроллинг ТЗ не дает. Во грабли то . Пробовал методом "ВыгрузитьТабличнуюЧасть" и выбрать строки из текущего документа методом ВыбратьСтроки() с последующим занесением в ТЗ.
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
03.09.2009, 13:57 14
Цитата Сообщение от perfomance
Не а - одна фигня. Скроллинг ТЗ не дает. Во грабли то . Пробовал методом "ВыгрузитьТабличнуюЧасть" и выбрать строки из текущего документа методом ВыбратьСтроки() с последующим занесением в ТЗ.
Похоже, это излишество

А метод, предложенный Hryv, сгодится еще и для создания связанных таблиц значений !
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
03.09.2009, 14:10 15
Не скролит, потому что при попытке промотать ТЗ вниз сразу идет вызов функции забитой в текстовое поле
Кстати, вправо/влево скролит без проблем

Пока не придумал как решить



Цитата Сообщение от vbs
А метод, предложенный Hryv, сгодится еще и для создания связанных таблиц значений !
А это как?
В смысле я не понял темин "связанных таблиц значений"
Если можно, то с примерчиком
0
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
03.09.2009, 14:25 16
Цитата Сообщение от Hryv
Не скролит, потому что при попытке промотать ТЗ вниз сразу идет вызов функции забитой в текстовое поле
Кстати, вправо/влево скролит без проблем

Пока не придумал как решить
Перем ТекДок;
Функция ...
Если ТекущийДокумент() <> ТекДок Тогда
ТекущийДокумент().ВыгрузитьтабличнуюЧасть;
ТекДок = ТекущийДокумент();
КонецЕсли;
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
03.09.2009, 14:43 17
По синтаксису правильно так :
Function ВыборСтроки(Док)
Если Док <> ТекДок Тогда
ТЗ.Очистить();
Док.ВыгрузитьтабличнуюЧасть(ТЗ);
ТекДок = Док;
Return 1
КонецЕсли;
Return 0
endFunction
//******************************************************************************
Но не помогает )))
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
03.09.2009, 15:12 18
vitfil, vbs, я проверил это еще до предыдущего моего поста


А вот и решение: текстовое поле вешаем не в таблицу журнала, а просто на форму
ИСПЫТАНО!
:mellow:


Модуль журнала

Код
Перем ТД;

//*---*---*---*---*---*---*---*---*---*---*---*---*---*---*
Функция ВыгрТЧ()
Если ТД<>ТекущийДокумент Тогда
ТЗ.Очистить();
ТекущийДокумент.ВыгрузитьТабличнуюЧасть(ТЗ);
ТД=ТекущийДокумент;
КонецЕсли;
Возврат 0;
КонецФункции //ВыгрТЧ()
0
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
03.09.2009, 15:20 19
Hryv
а я сразу и не заметил, что вы табличное поле вешали в таблицу журнала. ясен пень, что не работало бы!
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
03.09.2009, 15:28 20
ясен пень, что не работало бы!
лично мне не ясен
логики не вижу
0
03.09.2009, 15:28
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
03.09.2009, 15:28

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Фильтры На Журнал Документов 1с77
Здравствуйте. Есть вопрос по фильрации общего журнала. Есть Графа отбора &quot;ФакультетДляОтбора&quot;...

Журнал документов и последовательность
всем привет. вопрос: что лучше сделать последовательность документов или журнал документов, для...

Вывести журнал документов на УФ
Всем привет. Подскажите или дайте примерчик. Есть обработка на 8.3 УФ, на неё необходимо вывести...

Журнал документов СКЛАД
Есть журнал документов склад. В данных выбрал документы (Списание, перемещение, поступление)....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.