Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/6: Рейтинг темы: голосов - 6, средняя оценка - 5.00
9 / 9 / 0
Регистрация: 01.06.2015
Сообщений: 45
1

При выборе числа в календаре сделать так, чтобы число всегда сбрасывалось на начало года (т.е на 01.01.20??).

06.02.2018, 06:47. Показов 1120. Ответов 10
Метки нет (Все метки)

Народ помогите пожалуйста. Проблема такая. Необходимо на форме документа, у реквизита типа Дата, при выборе любого числа в календаре , сделать так чтобы число всегда сбрасывалось на начало года (т.е на 01.01.20??). К примеру в календаре выбрано значение 28.10.2020 то должно сбросить на 01.01.2020.
не получается сделать , помогите плиз
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
06.02.2018, 06:47
Ответы с готовыми решениями:

Как при выборе определенного значения, сделать так, чтобы при нажатии на кнопку переходило на соответствующую
Существует 4 формы. На главной форме есть ComboBox и кнопка. В ComboBox 3 значения. Как при выборе...

Как мне сделать чтобы при нажатии на число в календаре, если в таблице нет данных высвечивалась ошибка
public partial class MainForm : Form { public MainForm() { InitializeComponent();...

Как сделать так,чтобы при выборе строки в TreeView загружался текст?
Где я ошибся собственно? Судя по всему это строка с TreeView1, так как я не знаю как правильно...

Сделать так, чтобы при выборе option's в select'e не было перезагрузки страницы
Privetik vsem :good: Помогите сделать так, чтобы при выборе option's в select'e не было...

10
Тест
Эксперт 1С
382 / 161 / 56
Регистрация: 26.02.2010
Сообщений: 1,239
06.02.2018, 06:55 2
1C
1
НачалоГода(МояДата);
1
9 / 9 / 0
Регистрация: 01.06.2015
Сообщений: 45
06.02.2018, 07:03  [ТС] 3
Это надо щелкнуть на форме по реквизиту и открыть ПриИзменении? там вставить код этот? просто так сделал ошибка
Документ.ПланированиеАктивов1.Форма.ФормаДокумента.Форма(144 ,12)}: Встроенная функция может быть использована только в выражении. (НачалоГода)
НачалоГода<<?>>(МояДата); (Проверка: Тонкий клиент)
0
Тест
Эксперт 1С
382 / 161 / 56
Регистрация: 26.02.2010
Сообщений: 1,239
06.02.2018, 07:08 4
МояДата это реквизит с вашей датой, так что туда свой реквизит ставьте.
При изменеии, или после изменения не помню, поиграйте с обработчиком.
И это ворожение соответственно должно присваиваться вашей дате.
1C
1
МояДата = НачалоГода(МояДата);
1
9 / 9 / 0
Регистрация: 01.06.2015
Сообщений: 45
06.02.2018, 07:17  [ТС] 5
Цитата Сообщение от _ЕГОР_ Посмотреть сообщение
МояДата это реквизит с вашей датой, так что туда свой реквизит ставьте.
При изменеии, или после изменения не помню, поиграйте с обработчиком.
И это ворожение соответственно должно присваиваться вашей дате.
1C
1
МояДата = НачалоГода(МояДата);
Вот код
&НаКлиенте
Процедура ПериодПланированияПриИзменении(Элемент)
ПериодПланирования = НачалоГода(ПериодПланирования);
КонецПроцедуры
Вот ошибка. Что-то неясно
{Документ.ПланированиеАктивов1.Форма.ФормаДокумента.Форма(14 4)}: Преобразование значения к типу Дата не может быть выполнено
ПериодПланирования = НачалоГода(ПериодПланирования);
0
Тест
Эксперт 1С
382 / 161 / 56
Регистрация: 26.02.2010
Сообщений: 1,239
06.02.2018, 07:28 6
Странно странно. Только что создал, все работает
1C
1
2
3
4
&НаКлиенте
Процедура Реквизит1ПриИзменении(Элемент)
    Реквизит1 = НачалоГода(Реквизит1);
КонецПроцедуры
ПериодПланирования у вас какого типа?
1
9 / 9 / 0
Регистрация: 01.06.2015
Сообщений: 45
06.02.2018, 07:32  [ТС] 7
Цитата Сообщение от _ЕГОР_ Посмотреть сообщение
Странно странно. Только что создал, все работает
1C
1
2
3
4
&НаКлиенте
Процедура Реквизит1ПриИзменении(Элемент)
    Реквизит1 = НачалоГода(Реквизит1);
КонецПроцедуры
ПериодПланирования у вас какого типа?
Тип- ДАТА
Состав Даты - дата
0
Тест
Эксперт 1С
382 / 161 / 56
Регистрация: 26.02.2010
Сообщений: 1,239
06.02.2018, 07:34 8
Прям вот так?
https://yadi.sk/i/lR8p6yob3S8JkM
1
9 / 9 / 0
Регистрация: 01.06.2015
Сообщений: 45
06.02.2018, 07:46  [ТС] 9
Да именно так
https://ibb.co/cgNi3x

Добавлено через 3 минуты
https://ibb.co/d3rXwH

ошибка сама
0
Тест
Эксперт 1С
382 / 161 / 56
Регистрация: 26.02.2010
Сообщений: 1,239
06.02.2018, 07:47 10
Лучший ответ Сообщение было отмечено AleXadr999 как решение

Решение

Родительский объект как называется? "Объект"? Если да то так:
1C
1
Объект.ПериодПланирования = НачалоГода(Объект.ПериодПланирования);
1
9 / 9 / 0
Регистрация: 01.06.2015
Сообщений: 45
06.02.2018, 07:50  [ТС] 11
Да объект.
Все заработало.
Огромнейшее спасибо))
Выручили очень
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.02.2018, 07:50

Сделать так, чтобы при выборе одного checkbox'a нельзя было выбрать другой
Помогите сделать так, что бы при выборе одного checkbox'a нельзя было выбрать другой. А так же как...

сделать так, чтобы при выборе ФИО автоматически заполнялся реквизит Телефон(в документе).
Ситуация такая. Делаю конфигурацию для работы сервисного центра по ремонту компьютеров. Имеется...

Как сделать так чтобы при выборе значения в списке менялись данные в таблице ?
Есть проблема: имеется список выбора select и таблица Как сделать так чтобы при выборе значения в...

Как сделать так, чтобы при рандомном выборе цветов 2 цвета подряд не повторялись?
Как сделать так, чтобы при рандомном выборе цветов 2 цвета подряд не повторялись? Если это...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.