Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.95/19: Рейтинг темы: голосов - 19, средняя оценка - 4.95
2 / 2 / 1
Регистрация: 14.02.2017
Сообщений: 92
1
1C 8.x

Настроить печатную форму

28.03.2019, 10:58. Показов 3789. Ответов 4
Метки нет (Все метки)

Имеется макет печатной формы и то как он отображается в пользовательском режиме. Мне необходимо вывести группу курса и под ним все курсы,которые относятся к данной группе. Чтобы курс "русский язык" был один в "гуманитарное направление",а все остальные в "техническое"
подскажите как это сделать? как исправить модуль менеджера печати?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
Процедура Печать(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    Макет = Справочники.Курсы.ПолучитьМакет("Печать");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |   Курсы.Наименование КАК Наименование,
    |   Курсы.ДатаНачала КАК ДатаНачала,
    |   Курсы.Продолжительность КАК Продолжительность,
    |   Курсы.Стоимость КАК Стоимость,
    |   Курсы.Преподаватель КАК Преподаватель
    |ИЗ
    |   Справочник.Курсы КАК Курсы";
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Запрос2 = Новый Запрос;
    Запрос2.Текст =
    "ВЫБРАТЬ Различные
    |   Курсы.Преподаватель.Родитель.Ссылка КАК ГруппаКурс
    |ИЗ
    |   Справочник.Курсы КАК Курсы";
    
    Выборка2 = Запрос2.Выполнить().Выбрать();
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Группа=Макет.ПолучитьОбласть("Группа");
    Элемент=Макет.ПолучитьОбласть("Элемент");
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    
    Шапка.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(Шапка, Выборка.Уровень());
    
    Пока Выборка2.Следующий() Цикл
        Группа.Параметры.Заполнить(Выборка2);
        ТабДок.Вывести(Группа, Выборка2.Уровень());
        Пока Выборка.Следующий() Цикл
            Элемент.Параметры.Заполнить(Выборка);
             ТабДок.Вывести(Элемент, Выборка.Уровень());
            
        КонецЦикла;
    КонецЦикла;
 
    //}}
КонецПроцедуры
Сейчас он просто выводит направления которые есть и в первое направление добавляет все существующие курсы.
Справочник "Сотрудники" иерархический, "Гуманитарное и техническое направления" - это группы.
0
Миниатюры
Настроить печатную форму   Настроить печатную форму  
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
28.03.2019, 10:58
Ответы с готовыми решениями:

Вывод на печатную форму. УТ 11
Здравствуйте, в типовой печатной форме "приходная накладная" ут 11 создал область, параметр, в...

Выбрать печатную форму
У клиентов свои печатные формы актов, поэтому чтобы не делать кучу печатных форм в кнопке "Печать",...

Добавить печатную форму 1С v8
Необходимо Документы - Ведомость в кассу добавить печатную форму 0504403. Зашел в конфигуратор -...

Вывод на печатную форму. УТ 11
Здравствуйте, в типовой печатной форме нужно вывести данные, в табл часть шаблон вставил, в модуле...

__________________

Записывайтесь на профессиональные курсы 1C-разработчиков
4
Эксперт 1С
433 / 304 / 92
Регистрация: 28.05.2014
Сообщений: 1,237
28.03.2019, 11:22 2
1AK1, а как Вы в пользовательском режиме отделяете Гуманиторное направление от Технического?
Просто Группы иерархического справочника?
0
2 / 2 / 1
Регистрация: 14.02.2017
Сообщений: 92
28.03.2019, 11:26  [ТС] 3
Да, Справочник "Специалисты"-иерархический, у него 2 группы "Гуманитарное направление" и "Техническое направление",в группах содержится преподаватель курсов.
0
Эксперт 1С
433 / 304 / 92
Регистрация: 28.05.2014
Сообщений: 1,237
28.03.2019, 11:31 4
Сделайте Итоги По Родителю, получите столько группировок, сколько родителей.
Выборку обходите по группировкам. Верхний уровень - "Гуманитарное направление" и "Техническое направление", вложенный - Наименование курса,Стоимость и т.д.
0
2 / 2 / 1
Регистрация: 14.02.2017
Сообщений: 92
28.03.2019, 12:18  [ТС] 5
Я не совсем понимаю,как это правильно сделать?
Как мне вывести 1 раз группу курса?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
Процедура Печать(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    Макет = Справочники.Курсы.ПолучитьМакет("Печать");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |Курсы.Преподаватель.Родитель.Ссылка КАК ГруппаКурс,
    |Курсы.Наименование КАК Наименование,
    |Курсы.ДатаНачала КАК ДатаНачала,
    |Курсы.Продолжительность КАК Продолжительность,
    |Курсы.Стоимость КАК Стоимость,
    |Курсы.Преподаватель КАК Преподаватель
|ИЗ
    |Справочник.Курсы КАК Курсы
|ИТОГИ ПО
    |Курсы.Преподаватель.Родитель.Ссылка";
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Группа=Макет.ПолучитьОбласть("Группа");
    Элемент=Макет.ПолучитьОбласть("Элемент");
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    
    Шапка.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(Шапка, Выборка.Уровень());
     
    Пока Выборка.Следующий() Цикл
                Элемент.Параметры.Заполнить(Выборка);
             ТабДок.Вывести(Элемент,Выборка.Уровень());
            
    КонецЦикла;
 
    //}}
КонецПроцедуры
При данном коде для печати,выводит теперь правильно группировку,но нужно еще название сверху 1 раз
0
Миниатюры
Настроить печатную форму  
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
28.03.2019, 12:18

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

ТаблицаЗначений в печатную форму
Помогите, такая вот проблема нужно вывести в строку в печатной форме значений из таблицы значений....

Не подставляются значения в печатную форму
Здравствуйте. Я новичок в вопросах 1С программирования. Возникла такая вот проблема. Создал внешнюю...

Выставление даты в печатную форму
Всем доброго время суток! "Бухгалтерии предприятия" В отчете ...

Добавление поля в печатную форму
1С 8.2 Неуправляемое приложение. Такая проблема - надо добавить итоговую скидку по документу в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.