Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.65/26: Рейтинг темы: голосов - 26, средняя оценка - 4.65
14 / 14 / 0
Регистрация: 08.07.2009
Сообщений: 61
1

Групповое пересохранение справочников

14.03.2011, 16:30. Показов 4834. Ответов 11
Метки нет (Все метки)

Необходимо пересохранить все элементы справочника (все реквизиты каждого элемента), чтобы их изменения были снова зафиксированы в журнале регистрации изменений. Сами значения реквизитов не должны измениться, но журнал должен зафиксировать факт из изменения, т.е. изменение надо сэмулировать. Это необходимо, так как есть обработка, которая обрабатывает только изменения в журнале. Чем-то похоже на перепроведение документов, однако товаров много, нужна именно групповая обработка. Есть такая, или как её сделать?
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
14.03.2011, 16:30
Ответы с готовыми решениями:

Пересохранение БД
Подключил БД к проекту. Нужно отключить БД что бы пересохранить, как правильно отключить БД

Пересохранение Агента
Здравствуйте! Подскажите Как программно можно пересохранить агент в базе?

Пересохранение из txt в html
Добрый вечер! Такая ситуация, после ввода данных на форме, они сохраняются в блокнот. Есть...

Пересохранение текстового файла
У меня имеется код который преобразует значения в документе в нужном мне формате, только как...

11
Модератор
Эксперт 1С
3082 / 2768 / 523
Регистрация: 10.03.2011
Сообщений: 10,640
Записей в блоге: 1
14.03.2011, 16:56 2
Групповая обработка справочников и документов что не помогает???
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
14.03.2011, 17:11 3
Заходишь в каждый элемент справочника и нажимаешь кнопку "Записать".
Не нужно благодарностей.
0
14 / 14 / 0
Регистрация: 08.07.2009
Сообщений: 61
14.03.2011, 17:13  [ТС] 4
нет, не помогает
там возможно выставление одного значения для всех элементов, тем самым старые значения будут заменены одним. Мне не нужно изменять текущие значения, их нужно оставить как есть, у каждого своё.

Добавлено через 1 минуту
Цитата Сообщение от fimbulwinter Посмотреть сообщение
Заходишь в каждый элемент справочника и нажимаешь кнопку "Записать".
Не нужно благодарностей.
элементов несколько тысяч, мне вручную не надо, много времени уйдет
0
Модератор
Эксперт 1С
3082 / 2768 / 523
Регистрация: 10.03.2011
Сообщений: 10,640
Записей в блоге: 1
14.03.2011, 17:38 5
в журнале регистрации изменений фиксируются только объекты...
Дык презапиши все объекты тебе нужные
В чем проблема то?
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
14.03.2011, 19:11 6
а какая платформа, конфигурация?
был вроде какой то метод "Модифицированность()"
может поможет.. попробую тогда какую нибудь обработку на коленке собрать
0
14 / 14 / 0
Регистрация: 08.07.2009
Сообщений: 61
14.03.2011, 19:14  [ТС] 7
Цитата Сообщение от fimbulwinter Посмотреть сообщение
а какая платформа, конфигурация?
был вроде какой то метод "Модифицированность()"
может поможет.. попробую тогда какую нибудь обработку на коленке собрать
1С 8.1.15.14
Управление торговлей предприятия 1.1.7.3
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
14.03.2011, 20:04 8
открой в режиме конфигуратора и переконвертируй обработку. У меня просто 8.2.
Сохрани на всякий случай базу. Надеюсь получится.
0
Вложения
Тип файла: rar ВнешняяОбработка1.rar (3.5 Кб, 135 просмотров)
14 / 14 / 0
Регистрация: 08.07.2009
Сообщений: 61
17.03.2011, 13:41  [ТС] 9
что-то не получилось открыть ни в 8.1, ни в 8.2 . Если код небольшой, может сюда кинете?
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
17.03.2011, 14:26 10
1C
1
2
3
4
5
6
7
8
9
10
11
Процедура КнопкаВыполнитьНажатие(Кнопка)
    Спр = Справочник.ПривестиЗначение();
    СпрМенеджер = Справочники[Спр.Метаданные().Имя] ;
    СпрВыборка = СпрМенеджер.Выбрать();
    Пока СпрВыборка.Следующий() Цикл
        СпрОбъект = СпрВыборка.ПолучитьОбъект();
    Форма = СпрОбъект.ПолучитьФорму("ФормаЭлемента");   
    Форма.Модифицированность = Истина;
    СпрОбъект.Записать();
    КонецЦикла;   
КонецПроцедуры
Справочник - реквизит формы типа ОписаниеТипов
0
Модератор
Эксперт 1С
3082 / 2768 / 523
Регистрация: 10.03.2011
Сообщений: 10,640
Записей в блоге: 1
17.03.2011, 14:26 11
fimbulwinter, А зачем модефицированность() = Истина ???
Метод Записать() и так делает нужные движения в журнале регистрации.
1
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
17.03.2011, 15:45 12
тогда еще проще.
1C
1
2
3
4
5
6
7
8
9
Процедура КнопкаВыполнитьНажатие(Кнопка)
        Спр = Справочник.ПривестиЗначение();
        СпрМенеджер = Справочники[Спр.Метаданные().Имя] ;
        СпрВыборка = СпрМенеджер.Выбрать();
        Пока СпрВыборка.Следующий() Цикл
                СпрОбъект = СпрВыборка.ПолучитьОбъект();
                СпрОбъект.Записать();
        КонецЦикла;     
КонецПроцедуры
мне простительно, опыта на 8.х нет)))
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
17.03.2011, 15:45

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Пересохранение файла Компас 16
Не могу открыть файл компаса как пересохранить в 16 версию?

Пересохранение из Word в Excel
Всем добра. Есть примитивная задача, но, в связи с тем что экспортом пытаюсь заниматься первый раз...

Memo пересохранение данных
у меня есть 2 memo один должен сохранять в файл, а другой должен выводить с файла все что есть ...

Пересохранение проекта целиком
Здравствуйте. Как правильно сохранить проект по другим именем так, чтобы в новую папку...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.