Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
457 / 378 / 103
Регистрация: 24.04.2012
Сообщений: 1,484
Записей в блоге: 3
1
1C 8.x (тонкий)

Внешний отчет в подсистеме расширения

30.07.2020, 11:02. Просмотров 126. Ответов 2
Метки нет (Все метки)

Добрый день.
Конфа 1С:ERP Управление предприятием 2 (2.4.12.64)
Хотелка такая - в созданной подсистеме расширения конфигурации отобразить внешние отчеты и обработки.
Т.к. подсистемы расширения при размещении не отображались в форме пришлось копать и изменять.

Изменения в конфе:
Справочник ДополнительныеОтчетыИОбработки
ТабличнаяЧасть Назначение добавлен тип СправочникСсылка.ИдентификаторыОбъектовРасширений
ТабличнаяЧасть Раздел добавлен тип СправочникСсылка.ИдентификаторыОбъектовРасширений
Форма РазмещениеВРазделах реквизит формы (ТаблицаЗначений) Разделы колонка Раздел добавлен тип СправочникСсылка.ИдентификаторыОбъектовРасширений

Добавлено в расширение:
Общий модуль ДополнительныеОтчетыИОбработкиЛокализация
1C
1
2
3
4
&После("ОпределитьРазделыСДополнительнымиОбработками")
Процедура ИРЗ_ОпределитьРазделыСДополнительнымиОбработками(Разделы)
    ОбщегоНазначенияУТ.ДобавитьПодсистемуВКоллекцию(Разделы, "ИРЗ_ПодсистемаРасширения");
КонецПроцедуры
Общий модуль ВариантыОтчетовЛокализация
1C
1
2
3
4
&После("ОпределитьРазделыСВариантамиОтчетов")
Процедура ИРЗ_ОпределитьРазделыСВариантамиОтчетов(Разделы)
    Разделы.Добавить(Метаданные.Подсистемы.ИРЗ_ПодсистемаРасширения, "Отчеты ИРЗ");
КонецПроцедуры
Общий модуль ДополнительныеОтчетыИОбработки
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&ИзменениеИКонтроль("ПредставлениеОбъектаМетаданных")
Функция ИРЗ_ПредставлениеОбъектаМетаданных(Объект)
    #Удаление
    Если ТипЗнч(Объект) = Тип("СправочникСсылка.ИдентификаторыОбъектовМетаданных") Тогда
    #КонецУдаления
    #Вставка
    Если ТипЗнч(Объект) = Тип("СправочникСсылка.ИдентификаторыОбъектовМетаданных") ИЛИ
        ТипЗнч(Объект) = Тип("СправочникСсылка.ИдентификаторыОбъектовРасширений") Тогда
    #КонецВставки
        ОбъектМетаданных = ОбщегоНазначения.ОбъектМетаданныхПоИдентификатору(Объект, Ложь);
        Если ТипЗнч(ОбъектМетаданных) <> Тип("ОбъектМетаданных") Тогда
            Возврат НСтр("ru = '<Не существует>';
            |en = '<does not exist>'");
        КонецЕсли;
    ИначеЕсли ТипЗнч(Объект) = Тип("ОбъектМетаданных") Тогда
        ОбъектМетаданных = Объект;
    Иначе
        ОбъектМетаданных = Метаданные.Подсистемы.Найти(Объект);
    КонецЕсли;
    Возврат ОбъектМетаданных.Представление();
КонецФункции
Подсистема при размещении отображается. Сохраняется норм.
Осталось только отобразить внешний отчет в подсистеме и вот тут у меня трабл

Плиз, хелп
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
30.07.2020, 11:02
Ответы с готовыми решениями:

Как отчет из построителя отчетов сохранить во внешний отчет?
В консоли построителя отчетов(ИР), получается сам очень аккуратный отчет , но сохраняется и...

Внешний отчет
Всем доброго дня. Столкнулась с такой проблемой, не понимаю, что я делаю не так. Стоит задача...

Внешний отчет 1С 8.1
Народ, помогите!!!! работаю в 1С 8.1 &quot;Управление торговлей&quot;, в программировании совершенно не шарю....

Внешний регламентированный отчет
Всем привет! Написал свой регламентированный отчет, формируется и записывается в документ...

2
1260 / 828 / 288
Регистрация: 16.01.2015
Сообщений: 3,346
30.07.2020, 11:12 2
Сам подход вызывает сомнения. Если уж решили расширение, зачем внешние отчеты? Масло масленное? Проще и правильней встроить внешний отчет в расширение и включить его встандартную подсистему
0
457 / 378 / 103
Регистрация: 24.04.2012
Сообщений: 1,484
Записей в блоге: 3
30.07.2020, 11:23  [ТС] 3
Цитата Сообщение от polax Посмотреть сообщение
Проще и правильней
Да, проще. Но это же "хотелка" ))
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
30.07.2020, 11:23

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Не работает внешний отчет
1С:Бухгалтерия 8.2 Создаю внешний отчет для выгрузки документов Списание с расчетного счета в...

Внешний отчет по справочнику
Вопрос вот в чем: есть справочник контрагенты,ему подчинен справочник договора,и в свою очередь...

Нужен внешний отчет
Срочно понадобился отчет (внешний) задача которого состоит в том, чтобы показать пользователю форму...

Внешний отчет о скидках
С Новым Годом! Подскажите пожста как реализовать отчет о скидках которые были поставлены в ручную....

Внешний отчет по выручке
Здравствуйте уважаемые форумчане. Пишу отчет для 1С 7.7 Упрощенка, необходимо сформировать отчет по...

Составить внешний отчет 1с-8.2
Ребята, подскажите последовательность действий для создания внешнего отчета. Реализация по...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.