Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/4: Рейтинг темы: голосов - 4, средняя оценка - 4.50
4 / 4 / 0
Регистрация: 16.03.2011
Сообщений: 201
1
1C 7.x

Недоработанное назначение ЦеныПродажи

15.04.2011, 08:23. Показов 757. Ответов 7
Метки нет (Все метки)

Доброго времени суток всем!
Проблема, такая возникла:
Для учета продажной цены по партиям в Торговля 7.7 (7.70.961), в ДокПоступление, добавил столбец ЦенаПродажи. После чего в справочник Партии добавил элемент ЦенаПродажи (числовой), а в форму элеменетов <<ПолучитьЦенаПродажи()>>, Вот код на получение этой цены:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Функция ПолучитьЦенуПродажи()
    
    Валюта = "";
    Если ДоговорПоставщика.Выбран()=1 Тогда
        Валюта = ДоговорПоставщика.ВалютаВзаиморасчетов;
    ИначеЕсли ПриходныйДокумент.Выбран()=1 Тогда
         Если глЕстьРеквизитШапки("Валюта", ПриходныйДокумент.Вид()) = 1 Тогда
             Валюта = ПриходныйДокумент.Валюта;
         КонецЕсли;
    КонецЕсли;
    
    Возврат ""+глФРМ(ЦенаПродажи,Валюта)+" / "+Владелец.БазоваяЕдиница;
 
КонецФункции // ПолучитьЦенуПродажи()
Если не сложно посмотрите новым взглядом мож что не правильно

Суть в чем если в окне выбора партии цена закупочная отображдается, то ета почемуто нет
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
15.04.2011, 08:23
Ответы с готовыми решениями:

Недоработанное программа
// 11.cpp : Defines the entry point for the console application. // #include &quot;stdafx.h&quot;...

Недоработанное юзабилити использования ООП в MasterSCADA
Ну и дабы не плодить сообщения, пожалуюсь тут. В MasterSCADA заявлено ООП! Но воспользоваться им...

32.Модуль в Паскале (Unit), его назначение, структура модуля, назначение и описание частей модуля
32.Модуль в Паскале (Unit), его назначение, структура модуля, назначение и описание частей модуля.

Назначение FK
Здравствуйте. Только начал изучать SQL, так что прошу прощения за глупый вопрос. Создание таблиц:...

7
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
15.04.2011, 10:46 2
конфигу мылом на mogul13@mail.ru
0
4 / 4 / 0
Регистрация: 16.03.2011
Сообщений: 201
15.04.2011, 10:47  [ТС] 3
fimbulwinter, в SFX архивнуть?
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
15.04.2011, 10:58 4
7z утопчи.
только не всю базу.. достаточно *.md
0
4 / 4 / 0
Регистрация: 16.03.2011
Сообщений: 201
15.04.2011, 10:59  [ТС] 5
fimbulwinter, кинул правда в rar 3,87мв
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
15.04.2011, 11:48 6
уже смотрю

Добавлено через 47 минут
Цитата Сообщение от kipper22 Посмотреть сообщение
Доброго времени суток всем!
Проблема, такая возникла:
Для учета продажной цены по партиям в Торговля 7.7 (7.70.961), в ДокПоступление, добавил столбец ЦенаПродажи. После чего в справочник Партии добавил элемент ЦенаПродажи (числовой), а в форму элеменетов <<ПолучитьЦенаПродажи()>>, Вот код на получение этой цены:

Функция ПолучитьЦенуПродажи()

Валюта = "";
Если ДоговорПоставщика.Выбран()=1 Тогда
Валюта = ДоговорПоставщика.ВалютаВзаиморасчетов;
ИначеЕсли ПриходныйДокумент.Выбран()=1 Тогда
Если глЕстьРеквизитШапки("Валюта", ПриходныйДокумент.Вид()) = 1 Тогда
Валюта = ПриходныйДокумент.Валюта;
КонецЕсли;
КонецЕсли;

Возврат ""+глФРМ(ЦенаПродажи,Валюта)+" / "+Владелец.БазоваяЕдиница;

КонецФункции // ПолучитьЦенуПродажи()

Если не сложно посмотрите новым взглядом мож что не правильно

Суть в чем если в окне выбора партии цена закупочная отображдается, то ета почемуто нет
Не отражается она потому что ты её не записал
0
4 / 4 / 0
Регистрация: 16.03.2011
Сообщений: 201
15.04.2011, 11:57  [ТС] 7
fimbulwinter, Если не сложно напиши что имено не записал, немного непонял

Добавлено через 1 минуту
fimbulwinter, Вплане можно не код, а просто где имено запись не зделал?
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
15.04.2011, 11:58 8
ты не записал свою цену в партию. По сути ты вообще ничего не сделал..
пиши в скайпину, будешь моими глазами. буду говорить что куда добавить
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
15.04.2011, 11:58

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Назначение процессов
расскажите назначение процессов svchost taskhost audiodbg WUDFhost \OSPPSVC.EXE ...

Назначение ip адресов
почему так важно назначать ip адреса что то вроде 192.168.0.1 почему нельзя типа 10.11.12.1?...

Назначение языка
Для чего предназначен питон? Я знаю только что это веб-язык. Я знаю php, стоит ли учить мне питон?...

Назначение клавиш
Доброго времени суток. У меня такой вопросик: Возможно ли в винде изменять назначение клавишь, не...

Назначение адаптеров
Здравствуйте! Скажите, пожалуйста, каким образом можно назначить программам то или иное подключение...

Назначение обработчика
Занимаюсь по Радченко и Хрусталевой Практическое пособие разработчика. Вот они пишут - любую...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.