Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/6: Рейтинг темы: голосов - 6, средняя оценка - 4.50
11 / 13 / 1
Регистрация: 24.12.2010
Сообщений: 74
1

Выскакивает ошибка

22.06.2011, 17:42. Просмотров 1233. Ответов 1
Метки нет (Все метки)

Выкидывает у меня ошибку
{Форма.Форма.Форма(2811,2)}: Ожидается ключевое слово 'КонецФункции' ('EndFunction')
<<?>>КонецЕсли;

вот в этом коде
C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
Функция НайтиКонтрагента(ИНН,КПП,XB)
    Запрос = Новый Запрос;
    Если (ЗначениеНеЗаполнено(КПП) или КПП="-") и (ЗначениеНеЗаполнено(ИНН) или ИНН="-") тогда
        Выборка=Новый ТаблицаЗначений;
    ИначеЕсли (ЗначениеНеЗаполнено(КПП) или КПП="-") тогда
        Запрос.Текст="ВЫБРАТЬ
        |   Контрагенты.Ссылка
        |ИЗ
        |   Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |   Контрагенты.ИНН = &ИНН";
        Запрос.УстановитьПараметр("КПП",КПП);
        Запрос.УстановитьПараметр("ИНН",ИНН);
        Результат = Запрос.Выполнить();
        Выборка = Результат.Выбрать();
    ИначеЕсли (ЗначениеНеЗаполнено(ИНН) или ИНН="-") тогда
        Запрос.Текст="ВЫБРАТЬ
        |   Контрагенты.Ссылка
        |ИЗ
        |   Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |   Контрагенты.КПП = &КПП";
        Запрос.УстановитьПараметр("КПП",КПП);
        Запрос.УстановитьПараметр("ИНН",ИНН);
        Результат = Запрос.Выполнить();
        Выборка = Результат.Выбрать();
    Иначе
        Запрос.Текст="ВЫБРАТЬ
        |   Контрагенты.Ссылка
        |ИЗ
        |   Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |   Контрагенты.КПП = &КПП и Контрагенты.ИНН = &ИНН";
        Запрос.УстановитьПараметр("КПП",КПП);
        Запрос.УстановитьПараметр("ИНН",ИНН);
        Результат = Запрос.Выполнить();
        Выборка = Результат.Выбрать();
    КонецЕсли;
    
    Если Выборка.Количество()= 0 Тогда 
        Если СоздаватьКонтрагентов тогда
            Спр=Справочники.Контрагенты.СоздатьЭлемент();
            Спр.НаименованиеПолное="";
            Спр.Наименование="";
            Спр.КодПоОКПО="";
            Спр.ИНН="";
            Спр.Покупатель=Истина;
            Спр.НаименованиеПолное=СокрЛП(xB.ПолучитьЗначениеПоля("name"));
            Спр.Наименование=СокрЛП(xB.ПолучитьЗначениеПоля("trade_name"));
            Спр.КодПоОКПО=СокрЛП(xB.ПолучитьЗначениеПоля("zkpo"));
            Спр.ИНН=СокрЛП(xB.ПолучитьЗначениеПоля("ipn"));
            Спр.КПП=СокрЛП(xB.ПолучитьЗначениеПоля("VATN"));
            
            
            
            //Slik 21.01.2008
            //Работа с менеджером 
            ИДМенеджера=xB.ПолучитьЗначениеПоля("Owner_ID");
            Запрос = Новый Запрос;
            Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
            |   Пользователи.Ссылка
            |ИЗ
            |   Справочник.Пользователи КАК Пользователи
            |ГДЕ
            |   Пользователи.ФизЛицо.Код = &Код";
            
            Запрос.УстановитьПараметр("Код",ИДМенеджера);
            
            Результат = Запрос.Выполнить();
            Выборка = Результат.Выбрать();
            
            Если Выборка.Следующий() Тогда
                Спр.ОсновнойМенеджерПокупателя=Выборка.Ссылка;
            Иначе
                Сообщить("Не найден менеджер с кодом: "+ИДМенеджера+". Загрузите справочник менеджеров, и/или проставте соответствие менеджеров в справуочнике пользователей.");
            КонецЕсли;     
            
            //КонецРаботи с менеджером
            //Slik 21.01.2008
            
            //Работа с банком
            СпрБанк=Справочники.БанковскиеСчета.НайтиПоКоду(СокрЛП(xB.ПолучитьЗначениеПоля("bankcode")));
            Если ЗначениеНеЗаполнено(СпрБанк) тогда
                СпрБанк=Справочники.БанковскиеСчета.СоздатьЭлемент();
            Иначе
                СпрБанк=СпрБанк.ПолучитьОбъект();
            КонецЕсли;
            //РР=СокрЛП(xB.ПолучитьЗначениеПоля("RR"));
            //Если ЗначениеНеЗаполнено(РР) или РР="-" тогда
            //иначе                
            //  СпрБанк.НомерСчета=РР;
            //  Банк=Справочники.Банки.НайтиПоКоду(СокрЛП(xB.ПолучитьЗначениеПоля("bankCode")));
            //  Если ЗначениеНеЗаполнено(Банк) тогда
            //      Сообщить("Нету банка с кодом: "+СокрЛП(xB.ПолучитьЗначениеПоля("bankCode")));
            //  Иначе                  
            //      СпрБанк.Банк=Банк;
            //  КонецЕсли;
                СпрБанк.ВалютаДенежныхСредств=мВалютаРегламентированногоУчета;
                Спр.Записать();
                СпрБанк.ВЛАДЕЛЕЦ=Спр.ССЫЛКА;
                СпрБанк.Записать();              
                Спр.ОсновнойБанковскийСчет=СпрБанк.Ссылка;
            КонецЕсли;
            //Если ЗначениеНеЗаполнено(Спр.ОсновнойДоговорКонтрагента) тогда
            //  Спр.Записать();
            //  Запрос = Новый Запрос;
            //  Запрос.Текст = "ВЫБРАТЬ
            //  |   ДоговорыКонтрагентов.Ссылка
            //  |ИЗ
            //  |   Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
            //  |ГДЕ
            //  |   ДоговорыКонтрагентов.Владелец = &Владелец";
            //  
            //  Запрос.УстановитьПараметр("Владелец",Спр.Ссылка);
            //  
            //  Результат = Запрос.Выполнить();
            //  Выборка = Результат.Выбрать();
            //  
                Если Выборка.Следующий() Тогда
                    Спр.ОсновнойДоговорКонтрагента=Выборка.Ссылка;
                Иначе              
                    СпрДоговор=Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
                    СпрДоговор.Владелец=Спр.Ссылка;
                    СпрДоговор.ВалютаВзаиморасчетов=мВалютаРегламентированногоУчета;
                    СпрДоговор.ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоДоговоруВЦелом;
                    СпрДоговор.ВидУсловийДоговора=Перечисления.ВидыУсловийДоговоровВзаиморасчетов.БезДополнительныхУсловий;
                    СпрДоговор.Дата = xB.ПолучитьЗначениеПоля("CREATDATE");
                    СпрДоговор.Наименование="Основной договор";
                    СпрДоговор.Организация=Организация;
                    СпрДоговор.ТипЦен = Справочники.ТипыЦенНоменклатуры.ПустаяСсылка();
                    СпрДоговор.ВидДоговора=Перечисления.ВидыДоговоровКонтрагентов.СПокупателем;
                    СпрДоговор.Записать();
                    Спр.ОсновнойДоговорКонтрагента=СпрДоговор.Ссылка;
                КонецЕсли;
            //КонецЕсли;
            
            Спр.Записать();
            Возврат Спр.Ссылка;
        Иначе          
            Формаспр=Справочники.Контрагенты.ПолучитьФормуВыбора();
            Формаспр.РежимВыбора=Истина;
    
            Формаспр.Заголовок="Выберете контрагента для торговой точки: "+СокрЛП(xB.ПолучитьЗначениеПоля("trade_name"))+" ИНН: "+СокрЛП(xB.ПолучитьЗначениеПоля("ipn"))+" КПП:"+СокрЛП(xB.ПолучитьЗначениеПоля("VATN"));
            Элементспр=Формаспр.ОткрытьМодально();
            //Возврат Элементспр;
        КонецЕсли;
    //иначе
        //Выборка.Следующий();
        //Возврат Выборка.ссылка;
        
    КонецЕсли;
КонецФункции

Помогите если кто может)))
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
22.06.2011, 17:42
Ответы с готовыми решениями:

Не могу справиться с проблемой. Выскакивает эта ошибка incompatible types. Не могу никак понять почему выскакивает
procedure qSort(var work: array of TWork; min, max: Integer); //ïðîöåäóðà áûñòðîé ñîðòèðîâêè ïî...

Выскакивает ошибка Stack around the voriable 'text' was corrupted. Подскажите пожалуйста в чём ошибка
Выскакивает ошибка Stack around the voriable 'text' was corrupted. Подскажите пожалуйста в чём...

Ошибка при использовании vector (в конце, после вывода результатов выскакивает ошибка, но сам результат коректен)
Суть в следующем, мы считываем введеные значения и выводим этот массив Проблема такова что...

варочная индукционная поверхность Electrolux EHD 6576NOK pnc 94976006801 s 24002695, ошибка Е8 иногда выскакивает E3, ошибка Е8
Со слов клиента ошибка Е8 стала появляться после того как поверхность залили бульоном, после моих...

1
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
22.06.2011, 18:04 2
см. строка 105
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
22.06.2011, 18:04

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Выскакивает ошибка: В документе XML (1, 2) присутствует ошибка
Возникает ошибка здесь: object obj = mySerializer.Deserialize(ms); class Program { static...

При попытке добавить программно запись в зашифрованную паролем БД MS Access с помощью метода Insert выскакивает ошибка - Неизвестная ошибка
При попытке добавить программно запись в зашифрованную паролем БД MS Access с помощью метода Insert...

Выскакивает ошибка
CREATE VIEW ViewBanks AS SELECT SPLIT_STR(DirectorPIB, ' ', 1) AS &quot;Director Surname&quot;,...

Выскакивает ошибка
Здравствуйте,я новичок.пишу плагин WP по видео урокам,у меня вот такая ошибка вылезла,как ее...

Выскакивает ошибка
Помогите разобраться. Создал класс TMyClass на основе класса ListBox.Добавил класс TTreeView....

Выскакивает ошибка
Всем привет. В моей программе данные должны вводится в таблицу и расчет стоимости должен выводится...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.